• 0
jmayr2000

Database query issue in 0.9.8

Question

ok so I was having some issues loading into my update on exile on my server. No after reviewing all my logs I found this in my MySQL logs. [02:16:39:524332 --4:00] [Thread 150800] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'money' in 'field list' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: SELECT id,class,spawned_at,account_uid,is_locked,fuel,damage,hitpoints,position_x,position_y,position_z,direction_x,direction_y,direction_z,up_x,up_y,up_z,cargo_items,cargo_magazines,cargo_weapons,pin_code,vehicle_texture,deleted_at,money FROM vehicle WHERE id = ?

so what is the issue well after reviewing the update sql files in the server update download the following alter table sql updates were missing

ALTER TABLE container ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;        I found this this one reviewing the exile.sql
 
ALTER TABLE vehicle ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;
 
the above sql updates were missing in the upgrade-0.9.60-to-0.9.80.sql. I hope this helps anyone else updating their servers for 0.9.8
 
Jason M
2 people like this

Share this post


Link to post
Share on other sites

11 answers to this question

  • 1

Posted (edited)

I solved removing all members in dev array, config.cpp, but new error occurs.

    class ServerSettings
    {
        /*
            Support for custom server FSM if wanted
        */
        serverFSM = "exile_server\fsm\main.fsm";

        /*
            If this is enabled, Exile developers will spawn with a ton of pop tabs.
            We will have a hard time debugging things if you disable this.
        */
        devFriendyMode = 1;

        devs[] = 
        {
        };
    };

 

New error

 0:11:46 Error in expression <llExtension _query);
(_result select 1) select 0>
 0:11:46   Error position: <select 0>
 0:11:46   Error Generic error in expression
 0:11:46 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16

 

I found this solution and solved it:

"

Also, you need to disable strict mode on sql, not enable it. 

All you need to do is modify your my.ini and find the line that says:

# Set the SQL mode to strict
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

And then replace this with:

# Set the SQL mode to strict
sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

Restart your sql server and then you'll be good.

"

 

Edited by Antonio arjona00

Share this post


Link to post
Share on other sites
  • 0

Thanks for that solution!

It removed one of the problems i've been having.

But now i get a new one :D

Spoiler

10:49:06 Error in expression <yerUID _requestingPlayer) isEqualTo (_x select 0))exitWith 

{

if((name _requesti>

10:49:06   Error position: <select 0))exitWith 

{

if((name _requesti>

10:49:06   Error Generic error in expression

10:49:06 File exile_server\code\ExileServer_object_player_database_load.sqf, line 79

Maybe you have a fix for that as well?

 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

I didn't have that issue, once I altered the database for those new columns. have you updated the exile client on the server to kiwi as well as the @exileserver? if not try updating the @exile folder to the latest version.

Share this post


Link to post
Share on other sites
  • 0

I updated everything twice, just to be safe :D

A lot of people seem to have similar problems, there are about 8 Topics already about this.

Hopfully someone will find a way

Share this post


Link to post
Share on other sites
  • 0

I noticed too that a few df the class functions weren't properly close with a "};" they were just "}"

Share this post


Link to post
Share on other sites
  • 0

yeah open MySQL and choose your database just like you did in the update when you updated your database. then choose SQl at the top. and in the text box paste this below:

ALTER TABLE container ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`; 

 
ALTER TABLE vehicle ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;
 
then click go it should update those tables and you should be good to go.

 

Share this post


Link to post
Share on other sites
  • 0

Well it helped a little ^^

Now Bambi Creation won't work :D

Spoiler

18:54:38 Error in expression <yerUID _requestingPlayer) isEqualTo (_x select 0))exitWith

{

if((name _requesti>

18:54:38   Error position: <select 0))exitWith

{

if((name _requesti>

18:54:38   Error Generic error in expression

18:54:38 File exile_server\code\ExileServer_object_player_createBambi.sqf, line 92

 

But thanks for your help sofar!!

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Same on my server!

 

21:54:45 Error in expression <yerUID _requestingPlayer) isEqualTo (_x select 0))exitWith 
{
if((name _requesti>
21:54:45   Error position: <select 0))exitWith 
{
if((name _requesti>
21:54:45   Error Generic error in expression
21:54:45 File exile_server\code\ExileServer_object_player_createBambi.sqf, line 92

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

7 hours ago, Antonio arjona00 said:

 

Spoiler

 

I solved removing all members in dev array, config.cpp, but new error occurs.

    class ServerSettings
    {
        /*
            Support for custom server FSM if wanted
        */
        serverFSM = "exile_server\fsm\main.fsm";

        /*
            If this is enabled, Exile developers will spawn with a ton of pop tabs.
            We will have a hard time debugging things if you disable this.
        */
        devFriendyMode = 1;

        devs[] = 
        {
        };
    };

 

New error

 0:11:46 Error in expression <llExtension _query);
(_result select 1) select 0>
 0:11:46   Error position: <select 0>
 0:11:46   Error Generic error in expression
 0:11:46 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16

 

I found this solution and solved it:

"

Also, you need to disable strict mode on sql, not enable it. 

All you need to do is modify your my.ini and find the line that says:

 


# Set the SQL mode to strict
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

And then replace this with:


# Set the SQL mode to strict
sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

Restart your sql server and then you'll be good.

"

 

I just met you, and this is crazy...

But i think I'm in love with you.

Tank you!

The Server is still not working properly but an error solved is an error less ^^

Edited by Oph

Share this post


Link to post
Share on other sites
  • 0

ALTER TABLE container ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;
ALTER TABLE vehicle ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.