Sign in to follow this  
Followers 0
Dunsparth

Russian roulette [help]

24 posts in this topic

Posted (edited)

Hello i am trying to get russian roulette setup on my esseker exile map but am having a bit of a problem.
I can't seem to see any of the objects i have placed at the trader for russian roulette and when i go to the russian roulette trader and sign up to play it teleports me into debug.

Here is what i have in my initserver.sqf
for russian roulette
 

Spoiler

///////////////////////////////////////////////////////////////////////////////////////////////////
// Russian Roulette
///////////////////////////////////////////////////////////////////////////////////////////////////

_objects =
[

    ["Land_WoodenTable_large_F", [6633.65,3874.73,1.64079], 179.028, false],
    ["Exile_Sign_RussianRoulette", [6636.58,3866.67,6.31299], 182.645, false],
    ["Land_HumanSkull_F", [6633.7,3874.74,2.479], 96.5061, false]

];

{
    private ["_object"];

    _object = (_x select 0) createVehicle [0,0,0];
    _object setDir (deg (_x select 2));
    _object setPosWorld (_x select 1);
    _object allowDamage false;
    _object enableSimulation (_x select 3);
    _object enableSimulationGlobal (_x select 3);; // :)
}
forEach _objects;

ExileRouletteChairs = [];

ExileRouletteChairPositions = 
[
    [[6633.63,3876.62,1.39166],  358.11], 
    [[6632.42,3875.27,1.5901], 268.35], 
    [[6632.48,3874.17,1.67598], 268.329], 
    [[6633.71,3872.93,1.78276], 179.15], 
    [[6634.94,3874.22,1.68942], 90.2302],
    [[6634.91,3875.26,1.6076], 92.7197]
];

{
    private ["_chair"];

    _chair = "Land_ChairWood_F" createVehicle [0, 0, 0];
    _chair setDir (deg (_x select 1));
    _chair setPosWorld (_x select 0);
    _chair allowDamage false;
    _chair enableSimulationGlobal true;

    ExileRouletteChairs pushBack _chair;
}
forEach ExileRouletteChairPositions;

 

Edited by Dunsparth

Share this post


Link to post
Share on other sites

Im in the middle of making traders for my server so not looked at this yet but thought i would have a quick look for you

 

Looking at the original coordinates the altitude is around 18 and i can see you have yours set at around 1. Going on this im guessing your using ATL and not ASL

Share this post


Link to post
Share on other sites
Advertisement
14 minutes ago, Mr Health And Safety said:

Im in the middle of making traders for my server so not looked at this yet but thought i would have a quick look for you

 

Looking at the original coordinates the altitude is around 18 and i can see you have yours set at around 1. Going on this im guessing your using ATL and not ASL

Sorry i dont know what ATL and ASL is...
 

Share this post


Link to post
Share on other sites

ATL = above terrain level
ASL = above sea level.

Best way to explain it is if your at the coast standing right by the water then ATL = 0 ASL = 0 (i think) but as you climb a mountain ATL would still = 0 as your walking on the terrain but ASL would increase as imagine the sea going right through the terrain (its under it so you cant see it) so as you go higher the distance from you and the sea increases. hope that makes sense lol

1 person likes this

Share this post


Link to post
Share on other sites
18 minutes ago, Mr Health And Safety said:

ATL = above terrain level
ASL = above sea level.

Best way to explain it is if your at the coast standing right by the water then ATL = 0 ASL = 0 (i think) but as you climb a mountain ATL would still = 0 as your walking on the terrain but ASL would increase as imagine the sea going right through the terrain (its under it so you cant see it) so as you go higher the distance from you and the sea increases. hope that makes sense lol


Yes that kind of makes sense should i be using m3editor? 
to get the cords?
 

Share this post


Link to post
Share on other sites

Cords seem to be the one thing i have alot of issues with could never get this trader thing down i can figure everything else out its just this :/

 

Share this post


Link to post
Share on other sites

Im not sure on the best way to get the cords im afraid.

In Eden editor i know the status bar shows the cords, i think its Z that shows ASL. 

Share this post


Link to post
Share on other sites

thats what ive been using is Eden Editor 
ill def give it a shot.
 

Share this post


Link to post
Share on other sites

I have the same issue over here, 

I was able to get the chairs to spawn and show and stay by using ASL instead of PosWorld like what is in the original initserver. But broke the script doing this and Im no scripter by any stretch of the mind >< 

So if you figure it out, let me know!

1 person likes this

Share this post


Link to post
Share on other sites
7 minutes ago, zombietop said:

I have the same issue over here, 

I was able to get the chairs to spawn and show and stay by using ASL instead of PosWorld like what is in the original initserver. But broke the script doing this and Im no scripter by any stretch of the mind >< 

So if you figure it out, let me know!


What is your script doing?
ive got it sorted and working now.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.