• 0
GamersRoost

VON SIDECHAT SIDE CHAT

Question

Server VON voice, sidechat gets locked on.

Seen many posts with no fix.

Seems after borrowning from a post i cant find now, (credit goes to John or someone),

To disable the players ability to speak in sidechat and fucking blow everyones eardrums out....

 

In your Description.EXT

REMOVE totally disableChannels[] = {0, 2};

This will fix the issue. I hope this included in the next patch/update.

Group vehicle and direct work perfectly as before.

"please dont talk in sidechat" is now totally gone (thank god).

 

 

2 people like this

Share this post


Link to post
Share on other sites

24 answers to this question

  • 0

Posted (edited)

Didnt fix it for us, it still happens. tried to remove the line from the "description.ext" but still no luck, as soon as someone starts talking ingame it will turn on, and also its possible to stop it apparently by pushing the PTT for some players.

"A wild guess here would be Exile's custom (no lobby solution) as i remember hearing everyone in the lobby of Arma3 on other gamemodes. everyone is then speaking the the same groupchannel. and if you happen to press PTT right before the mission ends, it may sometimes stay activated trought the mission debriefing and even in the lobby when the mission restarts. So its not farfetching that it has something with the lobby bypassing to do"

Edited by x3nthos

Share this post


Link to post
Share on other sites
  • 0

Weird, it fixes it for my server. You sure your config.cpp is configured to disable VON?

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Posted (edited)

25 minutes ago, John said:

Weird, it fixes it for my server. You sure your config.cpp is configured to disable VON?

well if you disable VON, you get rid of the problem ofcourse, but then NOONE can speak, im talking about GamersRoost's solution. REMOVED the line disabledchannels with no luck. and also even though bugs can have very odd nature, it doesnt seem logic that removing a filter would having anything to do with active voice transmission (PTT).

anyway, im totally on the line with that its totally possible, because of bugs xD. just not likely, i thought it fixed it for us, but as soon someone speaks trough VON it gets back again, even with that line removed, and the channel doesnt matter, creating a party or hammering the PTT trough all the ingame channels seem to work sometimes, but it seems like everyone needs to do it, atleast the ones with their voice currently  transmitting.

Maybe, this function is being defined in another place than the description.ext aswell, need to look up on that. But for now i can neither confirm or disprove GamersRoost's solution.

Edited by x3nthos

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, x3nthos said:

well if you disable VON, you get rid of the problem ofcourse, but then NOONE can speak, im talking about GamersRoost's solution. REMOVED the line disabledchannels with no luck. and also even though bugs can have very odd nature, it doesnt seem logic that removing a filter would having anything to do with active voice transmission (PTT).

anyway, im totally on the line with that its totally possible, because of bugs xD. just not likely, i thought it fixed it for us, but as soon someone speaks trough VON it gets back again, even with that line removed, and the channel doesnt matter, creating a party or hammering the PTT trough all the ingame channels seem to work sometimes, but it seems like everyone needs to do it, atleast the ones with their voice currently  transmitting.

Maybe, this function is being defined in another place than the description.ext aswell, need to look up on that. But for now i can neither confirm or disprove GamersRoost's solution.

No, I mean disable von inside your exile config.cpp

I think the issue is there is a new format for disableChannels --  https://community.bistudio.com/wiki/Description.ext#disableChannels

And, EXILE disable VOn / channels via their own code, however, my belief is because disableChannels is still in the description.ext, it is overwriting their code and simply ONLY disabling those specific channels under the old format, THUS leaving VON enabled for side chat.

Removing the line from my description.ext and only running the correctly configured config below , I can VON on group, vehicle, direct. But not on side.

Spoiler

class CfgVon
{
	// self explanitory isnt it
	class global
	{
		id = 0;
		text = 0;
		von = 0;
	};

	class side
	{
		id = 1;
		text = 1;
		von = 0;
	};

	class command
	{
		id = 2;
		text = 0;
		von = 0;
	};

	class group

	{
		id = 3;
		text = 1;
		von = 1;
	};

	class vehicle
	{
		id = 4;
		text = 1;
		von = 1;
	};

	class direct
	{
		id = 5;
		text = 1;
		von = 1;
	};
};

 

 

Share this post


Link to post
Share on other sites
  • 0

This will still come and go no matter what you do. Exile Mod DEVs have addressed this with BIS as it is an Arma issue. From what I have tried, only thing that helps is join your own group in game, that will stop it for now.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

I have tried all of the above and the only thing currently that fixes it is to disableVon in the server.cfg.

Has anyone tried taking out the von config in exile config.cpp and then only using the new (arma 1.60) disableChannels format in the description.ext? like this:

disableChannels[]={{0, true, true},{1, false, true},{2, true, true},{3, false, false},{4, false, false},{5, false, false},{6, true, true}};

I haven't tried this with the von config in exile config.cpp removed yet. I would test it now but, am knee deep with babies today....!

1 person likes this

Share this post


Link to post
Share on other sites
  • 0
44 minutes ago, BaroN said:

I have tried all of the above and the only thing currently that fixes it is to disableVon in the server.cfg.

Has anyone tried taking out the von config in exile config.cpp and then only using the new (arma 1.60) disableChannels format in the description.ext? like this:


disableChannels[]={{0, true, true},{1, false, true},{2, true, true},{3, false, false},{4, false, false},{5, false, false},{6, true, true}};

I haven't tried this with the von config in exile config.cpp removed yet. I would test it now but, am knee deep with babies today....!

Correct me if im completly wrong now :P

But if you remove or comment out the von section in the exile config.
Wont the von config only fallback on default exile settings, since the config file is mainly user overwrites?

But it really does not hurt to test. So i will test now and give some feedback :)

Share this post


Link to post
Share on other sites
  • 0

to be honest man, I don't know. I'm sort of hoping the description.ext would overwrite anything that may be hidden, if there is anything, in the exile code.

Thanks for the test, let me know if anyone wants a spare baby? I have 3 here and a wife out with her sister...3 is definitely too much! (just trying to help any nutters out there thinking of having more kids.....:) )

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

So, we have tested this setup for 2 days now.
And we have not encountered the random voice in side chat bug anymore.

What we did:

Comment out this in the mission folder config.cpp (Usually at the bottom)

Spoiler

class CfgVon
{
    // self explanitory isnt it
    class global
    {
        id = 0;
        text = 0;
        von = 0;
    };

    class side
    {
        id = 1;
        text = 1;
        von = 0;
    };

    class command
    {
        id = 2;
        text = 0;
        von = 0;
    };

    class group
    {
        id = 3;
        text = 1;
        von = 1;
    };

    class vehicle
    {
        id = 4;
        text = 1;
        von = 1;
    };

    class direct
    {
        id = 5;
        text = 1;
        von = 1;
    };
};

Then put this in your mission file description.ext (If you have the disableChannels field in the top of your file, just replace it with this)

Spoiler

disableChannels[]={{0, true, true},{1, false, true},{2, true, true},{3, false, false},{4, false, false},{5, false, false},{6, true, true}};

 

Edited by GZRep

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.