• 0
Mr.Pig

Database Issue -

Question

@Vishpala

In the exile_server_config has the following declared...

class Database 
		{
			// Remove all deleted items from the database after X days
			_permanentlyDeleteTime = 3;

should be: (Needs the _ removed from permanentlyDeleteTime)

class Database 
		{
			// Remove all deleted items from the database after X days
			permanentlyDeleteTime = 3;

<3

1 person likes this

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

How do you know it needs the underscore removed?

Share this post


Link to post
Share on other sites
Advertisement
  • 0

A guess considering none of the other options have it?

		class Database 
		{
			// Remove all deleted items from the database after X days
			_permanentlyDeleteTime = 3;
			
			// Remove all territories (and contructions + containers in it) that were not paid after X days
			territoryLifeTime = 8;

			// Remove all containers outside of territories that have not been used for X days
			// Example: Tents
			containerLifeTime = 3;

			// Remove all constructions outside of territories that are older than X days or not moved for X days 
			// Example: Work Benches
			constructionLifeTime = 1;

			// Remove all vehicles that were not moved/used for X days
			vehicleLifeTime = 5;
			
			// Set safe as abandoned
			abandonedTime = 8;
			
			// Deletes a base X days after the flag is stolen if the ransom money isn't paid
			stolenFlagLifeTime = 3;
			
			// Sets door & safe pins to 0000 and marks safes to abandoned X days after the flag is stolen if the ransom money isn't paid
			unlockLifeTime = 2;
		};

 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, MGTDB said:

How do you know it needs the underscore removed?

best example is this:
_permanentlyDeleteTime    = getNumber (configFile >> "CfgSettings" >> "GarbageCollector" >> "Database" >> "permanentlyDeleteTime");

so the config entry needs to "not have" that underscore "_" :)

 

welll OR the script is wrong and it's meant to be

_permanentlyDeleteTime    = getNumber (configFile >> "CfgSettings" >> "GarbageCollector" >> "Database" >> "_permanentlyDeleteTime");

 

:rock:

Share this post


Link to post
Share on other sites
  • 0

B|

It was a rhetorical question anyway Mr Chris :D

Share this post


Link to post
Share on other sites
  • 0

Fixed!
Thanks <3 
copy pasta fail :P

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.