• 0
Mejai

Low FPS ONLY on Exile servers?

Question

So my problem is that I'm getting LOW fps on every single Exile server. Other mods like Epoch or Wasteland work fine around 50 fps, but whenever I'm playing on Exile servers I'm getting only 20, even 15 in cities for exemple. I'm playing on multiple servers, most of them having low ping, around 50.. So I assume ping wouldn't be a problem. Even played on less populated servers thinking that maybe the big number of players might affect my fps. Still getting only 20 on 10 players servers. What am I supposed to do?

My PC specs:

AMD FX 6300 6 cores at 3.5ghz

Gigabyte Nvidia Geforce GTX 750 ti OC Edition.

4gigs RAM (I know, shitty)

I know my PC is not that good, but like I said, its good enough to run at 50 fps on other servers that are not Exile.

Any fix to my problem would be awesome! Thanks for reading.

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Yes, FPS took a hit this latest patch.

Share this post


Link to post
Share on other sites
  • 0

Thanks for your answers guys! really helpful...

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Arma 3 always lagged a bit when I had an AMD CPU. I updated to an Intel and I gained significant FPS. I went from averaging around 25 FPS to around 50 FPS.

With the new version of Exile, I've gone from around 50 FPS to 75 - 100 FPS. Huge improvement in FPS. Other players are also confirming the increase in FPS.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Playing on a server that runs a Intel setup makes also a lot of  difference.

Edited by [RG] Salutesh

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, [RG] Salutesh said:

Playing on a server that runs a Intel setup makes also a lot of  difference.

Since Arma doesn't do multi-core, Intel hyperthreading is the big difference. More throughput on one core.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, ynpMOOSE said:

Since Arma doesn't do multi-core, Intel hyperthreading is the big difference. More throughput on one core.

Yhea i miss that little detail, thanks :D

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.