• 1
Timmay

Moving Safes Deletes Poptabs

Question

So this is partly a possible bug report, partly a possible "I f'd something up report"

Had some players complain that they moved their safes and their poptabs vanished. Tested it out myself, adding gear to the safe and  poptabs. Seems upon completion of the move, the gear is there but the poptabs are gone.  Any one experience this on your server?

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

They fixed it if you look at the new preview changelog.

They should just post the fix so we don't have to wait for it.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Posted (edited)

That is because when you move an construction, it deletes it from the database. Exile isn't storing the money before it delete it, so it's either the devs forgot or this was intentional. 

Either way, players need to remember to remove their money because never trust ArmA to remember things for you. 

Edited by WolfkillArcadia
2 people like this

Share this post


Link to post
Share on other sites
  • 0
12 minutes ago, WolfkillArcadia said:

That is because when you move an construction, it deletes it from the database. Exile isn't storing the money before it delete it, so it's either the devs forgot or this was intentional. 

Either way, players need to remember to remove their money because never trust ArmA to remember things for you. 

You are right of course, but players never listen.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Timmay said:

You are right of course, but players never listen.

;) 

Share this post


Link to post
Share on other sites
  • 0

@WolfkillArcadia

Wondering if you could guide me here.

I added this to an override: ExileServer_object_construction_network_moveConstructionRequest.sqf

_popTabs = _object getVariable ["ExileMoney",0];
    if !(_popTabs isEqualTo 0 ) then
    {
        throw "Remove money first!";
    };

It works, but it doesn't throw my text output rather instead it just says "Construction Aborted! Please try again"

Any ideas to get it to throw my text or am I going about this wrong?

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, Timmay said:

@WolfkillArcadia

Wondering if you could guide me here.

I added this to an override: ExileServer_object_construction_network_moveConstructionRequest.sqf

_popTabs = _object getVariable ["ExileMoney",0];
    if !(_popTabs isEqualTo 0 ) then
    {
        throw "Remove money first!";
    };

It works, but it doesn't throw my text output rather instead it just says "Construction Aborted! Please try again"

Any ideas to get it to throw my text or am I going about this wrong?

Try this

 

_popTabs = _object getVariable ["ExileMoney",0];
    if !(_popTabs isEqualTo 0 ) then
    {
        ["ErrorTitleOnly", ["Remove money first!"]] call ExileClient_gui_toaster_addTemplateToast;
    };

 

Share this post


Link to post
Share on other sites
  • 0
30 minutes ago, Timmay said:

@WolfkillArcadia

Wondering if you could guide me here.

I added this to an override: ExileServer_object_construction_network_moveConstructionRequest.sqf

_popTabs = _object getVariable ["ExileMoney",0];
    if !(_popTabs isEqualTo 0 ) then
    {
        throw "Remove money first!";
    };

It works, but it doesn't throw my text output rather instead it just says "Construction Aborted! Please try again"

Any ideas to get it to throw my text or am I going about this wrong?

You aren't wrong. Check out ExileClient_object_construction_network_constructionMoveResponse. It's the default response to an error. 

@Spackler 

That won't work because it's on the server. It will need to be a network message calling that function. On my phone, can't really write it. 

Share this post


Link to post
Share on other sites
  • 0

Work around for me is add safes to r3f player move like the quads and bikes seems to work 

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, 1Man said:

Work around for me is add safes to r3f player move like the quads and bikes seems to work 

Until one of them scrolls to the regular move and not R3F's. Also, using R3F to move objects installed in the base can cause reversion on restarts as it doesn't always update position in the database unless they lock and unlock, and even then it can be hit or miss.

The above solution I wrote works best as it doesn't allow moving of the safe with any poptabs above 0.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.