• 0
SynysterDemon

So many memory errors. Tried so many solutions.

Question

I'm beyond frustrated and angry with the amount of memory errors clients are getting lately... Since this update, clients are crashing every few minutes, and my player base is close to completely gone. 

I've reinstalled countless times, changed around every addon, stripped the server and rebuilt it, and still no change. 

I really fucking hope this is fixed sooner rather than later.

Share this post


Link to post
Share on other sites

25 answers to this question

  • 0
1 hour ago, SynysterDemon said:

I'm beyond frustrated and angry with the amount of memory errors clients are getting lately... Since this update, clients are crashing every few minutes, and my player base is close to completely gone. 

I've reinstalled countless times, changed around every addon, stripped the server and rebuilt it, and still no change. 

I really fucking hope this is fixed sooner rather than later.

It must be really frustrating.

I have not had one complaint.

Do you have a screenshot or something that shows an error?

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, SynysterDemon said:

I'm beyond frustrated and angry with the amount of memory errors clients are getting lately... Since this update, clients are crashing every few minutes, and my player base is close to completely gone. 

I've reinstalled countless times, changed around every addon, stripped the server and rebuilt it, and still no change. 

I really fucking hope this is fixed sooner rather than later.

aaaaaand you expect us to do anything about it with no information? 

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0
10 hours ago, GamersRoost said:

It must be really frustrating.

I have not had one complaint.

Do you have a screenshot or something that shows an error?

Yeah I'll attach the general error message below. It happens literally any random time. Some players report getting about 5 in 10 minutes, whilst a few hours later, they can go an entire server cycle without one... It's odd. 

 

10 hours ago, StokesMagee said:

aaaaaand you expect us to do anything about it with no information? 

I'm sorry, I was just generally pissed off and needed to rant. 

I can't really give any information as there's no obvious cause behind it. RPT doesn't show any strange errors, and we've tried removing any giant addons that may be causing memory leaks (RyansZombies, etc.)

Anything I can show you in particular? 

c1f301106fbf895ec9a6ae2550aa1c97.png

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

1 hour ago, SynysterDemon said:

Yeah I'll attach the general error message below. It happens literally any random time. Some players report getting about 5 in 10 minutes, whilst a few hours later, they can go an entire server cycle without one... It's odd. 

 

I'm sorry, I was just generally pissed off and needed to rant. 

I can't really give any information as there's no obvious cause behind it. RPT doesn't show any strange errors, and we've tried removing any giant addons that may be causing memory leaks (RyansZombies, etc.)

Anything I can show you in particular? 

c1f301106fbf895ec9a6ae2550aa1c97.png

http://www.exilemod.com/announcement/87-098-crashes-groups-and-von/

Client crashes while loading into the server
Many of you have reported a crash to desktop while joining a server. This is related due to Arma running out of memory on certain conditions, especially on Tanoa. As far as we know, the current DEV version of Arma solves this issue. Let us hope for the best. It also crashes for Vishpala and me. The RAGE is real, as we want to finish stuff before APEX strikes.

Edited by GamersRoost

Share this post


Link to post
Share on other sites
  • 0
22 minutes ago, GamersRoost said:

http://www.exilemod.com/announcement/87-098-crashes-groups-and-von/

Client crashes while loading into the server
Many of you have reported a crash to desktop while joining a server. This is related due to Arma running out of memory on certain conditions, especially on Tanoa. As far as we know, the current DEV version of Arma solves this issue. Let us hope for the best. It also crashes for Vishpala and me. The RAGE is real, as we want to finish stuff before APEX strikes.

Yeah it's not this. I've found a fix to this problem by just launching Arma with the mods and joining through the server browser in game. It's whilst the players are in game. 

You have no idea how much I've had to comp people for crashing whilst in mid-flight. xD

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, SynysterDemon said:

Yeah it's not this. I've found a fix to this problem by just launching Arma with the mods and joining through the server browser in game. It's whilst the players are in game. 

You have no idea how much I've had to comp people for crashing whilst in mid-flight. xD

so the SERVER crashes ?

 

Share this post


Link to post
Share on other sites
  • 0

I think the crashes are actually more server related than client. After rebuilding my Exile Esseker with a fresh install of Arma 3 and installing all most fresh, players are no longer crashing, whereas we were all crashing every time we tried connecting.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, SynysterDemon said:

Yeah it's not this. I've found a fix to this problem by just launching Arma with the mods and joining through the server browser in game. It's whilst the players are in game. 

You have no idea how much I've had to comp people for crashing whilst in mid-flight. xD

I see what you are saying now.

The error you mention in the screenshot is certainly a memory issue, but its client side.

List out your mods (copy paste your start parameters) for us to see. You never know.

Otherwise I would suggest that you have old and new Exile mistmatched in some addon or overwrite.

Try having them run arma as administrator as a test.   

Share this post


Link to post
Share on other sites
  • 0

Okay, so the current mods are: 

  • CBA
  • RHS: USAF
  • RHS: AFRF
  • RHS: GREF
  • Exile 
  • Exile Extended Base Mod

and my command line is the following:

-enableHT -name=ExileEXTINCTION "-profiles=instance" "-cfg=instance\basic.cfg" "-config=instance\server.cfg" "-bepath=C:\xxgames\JamesP\12771\battleye" -ip=109.70.149.158 -port=2300 -autoinit -filePatching "-mod=@Exile;@CBA_A3;@Extended_Base_Mod;@RHS_AFRF;@RHS_USAF;@RHS_GREF" "-servermod=@ExileServer;@extDB2;@marma"

 

23 minutes ago, GamersRoost said:

so the SERVER crashes ?

 

It's not a server crash...

22 minutes ago, BetterDeadThanZed said:

I think the crashes are actually more server related than client. After rebuilding my Exile Esseker with a fresh install of Arma 3 and installing all most fresh, players are no longer crashing, whereas we were all crashing every time we tried connecting.

I've rebuilt the server at least 10 times. 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, SynysterDemon said:

Okay, so the current mods are: 

  • CBA
  • RHS: USAF
  • RHS: AFRF
  • RHS: GREF
  • Exile 
  • Exile Extended Base Mod

and my command line is the following:

-enableHT -name=ExileEXTINCTION "-profiles=instance" "-cfg=instance\basic.cfg" "-config=instance\server.cfg" "-bepath=C:\xxgames\JamesP\12771\battleye" -ip=109.70.149.158 -port=2300 -autoinit -filePatching "-mod=@Exile;@CBA_A3;@Extended_Base_Mod;@RHS_AFRF;@RHS_USAF;@RHS_GREF" "-servermod=@ExileServer;@extDB2;@marma"

 

It's not a server crash...

I've rebuilt the server at least 10 times. 

Try to remove the @EXTDB2 - I had lots of issues when I tried that. Not saying its a fix, but since we literally have no clue at all, it is worth a shot.

So let's be clear, unless every single person connecting that crashes is using the same @Exile folder shared from a network location or some shit, you are passing bad memory calls to the clients.

I think its Object related personally.

I know this sucks for you dude. Hope we can figure it out.

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.