Captainjack

zombies [WIP] Modless Zombie Spawn system

74 posts in this topic

Modless Zombies system v1.5Beta

This is a rebuild of the 1st zombie spawner system used for the Exile-Z mod it's made to run client side with no need for server owners to add/edit mods. The Script can support other mod skins if used all you need to do is replace skins in the code with mod skins you want.

Script comeback was a popular request hope you enjoy it :)

Features:
* Dynamic spawns map wide - looks for houses near players
* Zombies damage takes HP off target if close
* Basic loots added to zombies edit in config
* Zombies will find players no matter where they are if in 120m range
* Safezone cleanup check added - checks for ExilePlayerInSafezone

Known issues:
* Ramdom FPS spikes in patch 1.50
* Zombies might not spawn 1st time on some players when they login after a restart
* Zombies Die on 1 shot - will be fixing this soon
* Zombies using base models in game has blood effect to them for the zombie look nothing fancy
* Admins Teleportation can brake spawns for admins only seen this on old admin tool
* Running is causing strange BE kicks removed it for now

What's going to be done: (No ETA on this it takes time Real Life comes first)
* Fix one shot zombie kills
* Clean up errors/functions
* Add custom skins/sounds to zombies
* make zombies hurt legs/arms ect
* Cleanup code


HOW TO INSTALL - backup your mpmission 1st
1 Download the Script form HERE: https://github.com/rscaptainjack/ZOMBIES_CODE/tree/master/MODLESS_ZOMBIES
2 copy files in .rar/.zip file to your mpmission folder of choice
3 update your init.sqf with command in scripts init.sqf or add the init.sqf file to your mpmission
4 add #include "zombie\zed.hpp" just above #include "config.cpp" in description.ext
5 edit zombie/config.sqf
6 repack mpmission and load server!

NOTE: The onplayerrespawn.sqf is used to re-trigger on respawn seems to be a issue in 1.50 patch this is a temp fix found by Ancientevil. Place the file into mpmission if you don't have it or add command inside your custom onplayerrespawn.sqf - it works like the init.sqf retriggers code when respawned.

 

If you want AI to kill the zombies set _zombie setCaptive to false in fnc_Zcontact.sqf this can cause large FPS spikes

 

Battleye Filters: some maybe missing you will have to filter as they show.

scripts.txt add to execVM line

!"onPlayerRespawn.sqf" !"zombie\config.sqf" !"zombie\fnc_Zcontact.sqf" !"zombie\fnc_ZProximity.sqf" !"compile preprocessFile \"\zombie\fnc_Zcontact.sqf\"\;" !"compile preprocessFile \"\zombie\fnc_ZProximity.sqf\"\;"

Add in Setpos.txt & createVehicule.txt first line :

!"C_man_polo_1_F_euro" !"C_man_polo_2_F_asia" !"C_man_polo_3_F" !"C_man_polo_4_F" !"C_man_polo_5_F" !"C_man_polo_6_F" !"C_man_p_fugitive_F" !"C_scientist_F" !"C_man_hunter_1_F" !"C_journalist_F" !"C_Nikos2" !"C_Driver_1_F"

setpos.txt - add all to stop the client kicks for zombie movement

1 "" !"Exile_" !"C_man_polo_1_F_euro" !"C_man_polo_2_F_asia" !"C_man_polo_3_F" !"C_man_polo_4_F" !"C_man_polo_5_F" !"C_man_polo_6_F" !"C_man_p_fugitive_F" !"C_scientist_F" !"C_man_hunter_1_F" !"C_journalist_F" !"C_Nikos2" !"C_Driver_1_F"


Credit to Corvobrok for the basic framework for Proximity triggers it's been reworked to run this script for you all :)           

Edited by Captainjack
zed.cpp was a typo sorry recheck install again
2 people like this

Share this post


Link to post
Share on other sites

A little confused about the BE filters. Do we add that code to the end of the first line in Setpos.txt or do we change the 7 to a 1, as indicated in the second set of filters?

Share this post


Link to post
Share on other sites
Advertisement

I dont get a download option when I go to your github page... Anyone else have the same issue?

Share this post


Link to post
Share on other sites

A little confused about the BE filters. Do we add that code to the end of the first line in Setpos.txt or do we change the 7 to a 1, as indicated in the second set of filters?

add to line one it mayn't be needed added it as a precaution for Setpos.txt keep it as 7 if not kicking

I dont get a download option when I go to your github page... Anyone else have the same issue?

Sorry :) it's in master https://github.com/rscaptainjack/ZOMBIES_CODE has all the other scripts in it you need folder named MODLESS_ZOMBIES

Edited by Captainjack

Share this post


Link to post
Share on other sites

So, when I add this to my server, I don't even get to the lobby. My server and client log has no errors in it but I have a DMP file in the folder where my server log is. Remove it and the server loads fine. I put the zombie folder in another folder called "custom" and I edited the config.cfg:

fncZcontact = compile preprocessFile "custom\zombie\fnc_Zcontact.sqf";
fncZproximity = compile preprocessFile "custom\zombie\fnc_ZProximity.sqf";

Have this in my init.sqf:

[] execVM "custom\zombie\config.sqf";

and this in description.ext:

#include "custom\zombie\zed.cpp"

 

Share this post


Link to post
Share on other sites

So, when I add this to my server, I don't even get to the lobby. My server and client log has no errors in it but I have a DMP file in the folder where my server log is. Remove it and the server loads fine. I put the zombie folder in another folder called "custom" and I edited the config.cfg:

fncZcontact = compile preprocessFile "custom\zombie\fnc_Zcontact.sqf";
fncZproximity = compile preprocessFile "custom\zombie\fnc_ZProximity.sqf";

Have this in my init.sqf:

[] execVM "custom\zombie\config.sqf";

and this in description.ext:

#include "custom\zombie\zed.cpp"

 

ok if moved it to custom you need to edit inside zed.cpp also that could be cause, I only made it for main directory never tested in another file

also edit onPlayerRespawn.sqf

Edited by Captainjack

Share this post


Link to post
Share on other sites

Even using the default locations, I can't get into the lobby with this. If I comment out the lines in init.sqf and description.ext so it doesn't load, the server works fine.

Share this post


Link to post
Share on other sites

Even using the default locations, I can't get into the lobby with this. If I comment out the lines in init.sqf and description.ext so it doesn't load, the server works fine.

hmm do you have custom sounds active? try moving code in zed.cpp to bottom of description.ext then remove

#include "custom\zombie\zed.cpp"

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.