• 0
Sign in to follow this  
Followers 0
phantom_bora

MySQL Error: Could not add database

Question

Posted (edited)

Having an issue after updating to Potato. Here's my RPT error:

8:49:09 "ExileServer - MySQL connection error!" 8:49:09 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong." 8:49:09 "ExileServer - MySQL Error: Could not add database: [0,"Database Exception Error"]" 8:49:09 "ExileServer - Server will shutdown now :("

And here's my extdb log: 


[08:49:08:830301 --7:00] [Thread 10980] extDB2: Database Type: MySQL
[08:49:09:831537 --7:00] [Thread 10980] extDB2: Database Exception Error: Connection attempt failed: Can't connect to MySQL server on '127.0.0.1' (10061)
[08:49:09:842427 --7:00] [Thread 10980] extDB2: Sending Shutdown to Armaserver
 

 

Any input would be greatly appreciated. Thanks!

 

EDIT: Fixed by adding in MySQL IP address and username to extdb-conf.ini file. 

Edited by phantom_bora

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0
1 hour ago, phantom_bora said:

Having an issue after updating to Potato. Here's my RPT error:

8:49:09 "ExileServer - MySQL connection error!" 8:49:09 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong." 8:49:09 "ExileServer - MySQL Error: Could not add database: [0,"Database Exception Error"]" 8:49:09 "ExileServer - Server will shutdown now :("

And here's my extdb log: 


[08:49:08:830301 --7:00] [Thread 10980] extDB2: Database Type: MySQL
[08:49:09:831537 --7:00] [Thread 10980] extDB2: Database Exception Error: Connection attempt failed: Can't connect to MySQL server on '127.0.0.1' (10061)
[08:49:09:842427 --7:00] [Thread 10980] extDB2: Sending Shutdown to Armaserver
 

 

Any input would be greatly appreciated. Thanks!

[08:49:09:831537 --7:00] [Thread 10980] extDB2: Database Exception Error: Connection attempt failed: Can't connect to MySQL server on '127.0.0.1' (10061)

Share this post


Link to post
Share on other sites
  • 0

What is the name of your database? The sql script to create the database that comes with the server download specifically uses "exile" as the database name. If you are using a database with a different name and execute that script without changing the database name (or just taking that part out), then you're kinda screwed.

Otherwise, make sure MySQL is running on your server :P

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Posted (edited)

You must setup your database in the file "arma3_server ROOT/extdb-conf.ini".

Serch for this block at line 66:

[exile]
Type = MySQL
Name = HereYourDatabaseName // this one from you hoster
Username = HereYourDatabeseUsername // this one from you hoster
Password = HereTheDatabasePassword // this one from you hoster
IP = HereTheIPtoTheDatabase // IP or url like this: database.myhoster.tld from your Hoster
Port = 3306 // Port must match with the Port from your Hoster, too
minSessions = 2
idleTime = 60
; Really should only use this if MySQL server is external. Also only for MySQL
compress = false
; Recommend you turn this on  http://dev.mysql.com/doc/refman/5.6/en/mysql-command-options.html#option_mysql_secure-auth
Secure Auth = true

Change the needed field, thats it match with your data from your Hoster.

After that it should works.

Edited by [FCS-DE]^oo^[Linux]
1 person likes this

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, [FCS-DE]^oo^[Linux] said:

You must setup your database in the file "arma3_server ROOT/extdb-conf.ini".

Serch for this block at line 66:


[exile]
Type = MySQL
Name = HereYourDatabaseName // this one from you hoster
Username = HereYourDatabeseUsername // this one from you hoster
Password = HereTheDatabasePassword // this one from you hoster
IP = HereTheIPtoTheDatabase // IP or url like this: database.myhoster.tld from your Hoster
Port = 3306
minSessions = 2
idleTime = 60
; Really should only use this if MySQL server is external. Also only for MySQL
compress = false
; Recommend you turn this on  http://dev.mysql.com/doc/refman/5.6/en/mysql-command-options.html#option_mysql_secure-auth
Secure Auth = true

Change the needed field, thats it match with your data from your Hoster.

After that it should works.

Thank you for the response. Forgot to close the thread and say I was able to fix the problem. It was indeed my extdb-conf.ini file that reverted back to a blank state after updating. Not sure how WinMerge missed it. 

Thanks!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.