Therealrag

fresh db errors

10 posts in this topic

I'm new to mysql, but when I attempted to import the exile.sql i get this error.  


MariaDB [(none)]> source /home/arma3server/mysql/exile.sql
Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 1 row affected (0.01 sec)

Database changed
ERROR 1067 (42000) at line 19 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'first_connect_at'
ERROR 1067 (42000) at line 40 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'created_at'
Query OK, 0 rows affected (0.04 sec)

ERROR 1067 (42000) at line 73 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'spawned_at'
ERROR 1067 (42000) at line 104 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'spawned_at'
ERROR 1067 (42000) at line 140 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'spawned_at'
ERROR 1067 (42000) at line 193 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'died_at'
ERROR 1067 (42000) at line 208 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'created_at'
ERROR 1067 (42000) at line 238 in file: '/home/arma3server/mysql/exile.sql': Invalid default value for 'spawned_at'
Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

MariaDB [exile]>

any help will be great thank you ahead of time.

Share this post


Link to post
Share on other sites

Posted (edited)

 

hi mate,

I get the same errors..

mysql version: 5.5.49-0+deb8u1 Debian 8.2

so i have two guides to setup linux server. i first followed the first one

and 

following the first one it says to do this ....

mysql -u root -p 
create database if not exists exile;
create user 'exile'@'localhost' identified by 'password';
grant all privileges on exile.* to 'exile'@'localhost';
flush privileges;
source /home/steam/steamcmd/arma3/MySQL/exile.sql

it is when i do the

source /home/exile/serverfiles/mysql/exile.sql

that i get these errors..

but the second one says do this....

mysql -u root -p

CREATE DATABASE exile; //don't forget the friggin semicolon
GRANT ALL ON exile.* TO 'exile'@localhost IDENTIFIED BY 'password'; //You can name your user and password whatever you like
exit;

is it required to do the source input ? and which tutorial is correct. both are setup guides for linux, but handle the Mysql part very differently.

Is there a better way or another tutorial on just setting up the database under linux ?

 

regards.

Doug

ll

Edited by igeighty

Share this post


Link to post
Share on other sites
Advertisement
mysql> source /home/exile/serverfiles/mysql/exile.sql
Query OK, 0 rows affected (0.01 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 1 row affected, 1 warning (0.00 sec)

Database changed
ERROR 1067 (42000): Invalid default value for 'first_connect_at'
ERROR 1067 (42000): Invalid default value for 'created_at'
Query OK, 0 rows affected (0.04 sec)

ERROR 1067 (42000): Invalid default value for 'spawned_at'
ERROR 1067 (42000): Invalid default value for 'spawned_at'
ERROR 1067 (42000): Invalid default value for 'spawned_at'
ERROR 1067 (42000): Invalid default value for 'died_at'
ERROR 1067 (42000): Invalid default value for 'created_at'
ERROR 1067 (42000): Invalid default value for 'spawned_at'
Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

my error is practically the same yet doesn't give line numbers.

Share this post


Link to post
Share on other sites
1 hour ago, igeighty said:

mysql> source /home/exile/serverfiles/mysql/exile.sql
Query OK, 0 rows affected (0.01 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 1 row affected, 1 warning (0.00 sec)

Database changed
ERROR 1067 (42000): Invalid default value for 'first_connect_at'
ERROR 1067 (42000): Invalid default value for 'created_at'
Query OK, 0 rows affected (0.04 sec)

ERROR 1067 (42000): Invalid default value for 'spawned_at'
ERROR 1067 (42000): Invalid default value for 'spawned_at'
ERROR 1067 (42000): Invalid default value for 'spawned_at'
ERROR 1067 (42000): Invalid default value for 'died_at'
ERROR 1067 (42000): Invalid default value for 'created_at'
ERROR 1067 (42000): Invalid default value for 'spawned_at'
Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

Query OK, 0 rows affected (0.00 sec)

my error is practically the same yet doesn't give line numbers.

after staying up til 7 am I got it to accept it just installed libmysql - 5.6.31   instead of the one i had,   was out of date...  now if i could only get extDB2 to work

1 person likes this

Share this post


Link to post
Share on other sites

cheers mate ill give it a shot. 2.50 am here...

i am working with mysql workbench, and get the same errors when injecting the file.

ill update mysql and see how we go.

i might be able to help you with extDB2 through steam tomorrow.

thanks

 

Share this post


Link to post
Share on other sites
6 minutes ago, igeighty said:

cheers mate ill give it a shot. 2.50 am here...

i am working with mysql workbench, and get the same errors when injecting the file.

ill update mysql and see how we go.

i might be able to help you with extDB2 through steam tomorrow.

thanks

 

change the @exileserver back to @ExileServer      i did that and now it works...

Share this post


Link to post
Share on other sites

Posted (edited)

updating the mysql to version 5.6 got me a lot further into the server,

i was able to create the database without errors now.

however i am able to get into the pick a spawn point, but after that i get stuck at the requesting bambi character screen. (with a timeout message)

i get returned to server browser.

a snip of the debug from join to kick.. with no other errors up till that point. but its past 4am here, I'm gonna get shot for real.

4:14:21 Player Doug connecting.
 4:14:23 BattlEye Server: Player #0 Doug - GUID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx (unverified)
 4:14:23 Player Doug connected (id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx).
 4:14:23 BattlEye Server: Verified GUID (xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx) of player #0 Doug
Unaccessible
 4:14:31 "ExileServer - Player Doug (UID xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx) connected!"
 4:14:33 Server: Object 7:118 not found (message Type_121)
 4:14:33 Server: Object 7:120 not found (message Type_93)
 4:14:33 Server: Object 7:119 not found (message Type_93)
 4:14:33 Server: Object 7:121 not found (message Type_121)
Error: Object(7 : 120) not found
Error: Object(7 : 119) not found
 4:14:34 "ExileServer - Starting session for 'Doug' with ID 'oAIRPRlU'..."
 4:14:34 "ExileServer - Dispatching hasPlayerRequest for session 'oAIRPRlU'..."
 4:14:50 Error in expression <llExtension _query);
(_result select 1) select 0>
 4:14:50   Error position: <select 0>
 4:14:50   Error Generic error in expression
 4:14:50 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
 4:14:50 Error in expression <llExtension _query);
(_result select 1) select 0>
 4:14:50   Error position: <select 0>
 4:14:50   Error Generic error in expression
 4:14:50 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
 4:14:50 Subgroup R :<No leader> (0x984cd9c0) - network ID 2:1075
 4:14:50  - no leader
 4:14:50 Network simulation, time = 525.388
 4:15:30 Client: Remote object 7:0 not found
 4:15:30 Warning: Cleanup player - person 2:1113 not found
 4:15:30 Player Doug disconnected.
 4:15:30 BattlEye Server: Player #0 Doug disconnected
 4:15:30 Warning: Cleanup player - person 2:1113 not found

 

and from the exdb log

extDB2: Version: 71
extDB2: https://github.com/Torndeco/extDB2
extDB2: Linux Version
Message: All development for extDB2 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB2 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 20/02/15


extDB2: Found extdb-conf.ini
extDB2: Detected 4 Cores, Setting up 4 Worker Threads


[04:05:43 +10:00] [Thread 9343] extDB2: Database Type: MySQL
[04:05:43 +10:00] [Thread 9343] extDB2: Database Session Pool Started
[04:05:43 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Loading Template Filename: /home/exile/serverfiles/@exileserver/extDB/sql_custom_v2/exile.ini
[04:05:43 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available
[04:06:35 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_execute error	[mysql_stmt_error]: Field 'assigned_items' doesn't have a default value	[mysql_stmt_errno]: 1364	[mysql_stmt_sqlstate]: HY000	[statemnt]: INSERT INTO player SET account_uid = ?, name = ?
[04:06:35 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[04:06:35 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: createPlayer:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx:Doug
[04:08:04 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_execute error	[mysql_stmt_error]: Field 'assigned_items' doesn't have a default value	[mysql_stmt_errno]: 1364	[mysql_stmt_sqlstate]: HY000	[statemnt]: INSERT INTO player SET account_uid = ?, name = ?
[04:08:04 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[04:08:04 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: createPlayer:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx:Doug
[04:11:21 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_execute error	[mysql_stmt_error]: Field 'assigned_items' doesn't have a default value	[mysql_stmt_errno]: 1364	[mysql_stmt_sqlstate]: HY000	[statemnt]: INSERT INTO player SET account_uid = ?, name = ?
[04:11:21 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[04:11:21 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: createPlayer:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx:Doug
[04:12:32 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_execute error	[mysql_stmt_error]: Field 'assigned_items' doesn't have a default value	[mysql_stmt_errno]: 1364	[mysql_stmt_sqlstate]: HY000	[statemnt]: INSERT INTO player SET account_uid = ?, name = ?
[04:12:32 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[04:12:32 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: createPlayer:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx:Doug
[04:14:50 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_execute error	[mysql_stmt_error]: Field 'assigned_items' doesn't have a default value	[mysql_stmt_errno]: 1364	[mysql_stmt_sqlstate]: HY000	[statemnt]: INSERT INTO player SET account_uid = ?, name = ?
[04:14:50 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[04:14:50 +10:00] [Thread 9343] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: createPlayer:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx:Doug

similar to this bloke 

 anyways ill look at it tomorrow.

cheers,.,.,

Edited by igeighty

Share this post


Link to post
Share on other sites
6 minutes ago, igeighty said:

setting the database to strict mode worked to solve my errors.

thanks @BlugDeg.

@Therealrag, i see your server is up and running also. well done .

Ya i did.   just fixing battleye issues.    but got it running.

Share this post


Link to post
Share on other sites

good job man, thanks for steering me onto this project, feels good to get something working.

now to go see to those outside jobs :)

cya.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.