AshleyIn1080p

[SOLVED] Problem with xm8.so

9 posts in this topic

Posted (edited)

Hi im using fedora 24 for Exile server, the xm8.so i have problem with, it don't have one package installed, anyone know what package i need? here lld view of file..

[exileserver@gseu a3server]$ ldd xm8.so
        linux-gate.so.1 (0xf770e000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf76bf000)
        libcrypto.so.1.0.0 => not found
        libdl.so.2 => /lib/libdl.so.2 (0xf76ba000)
        libstdc++.so.6 => /lib/libstdc++.so.6 (0xf7536000)
        libm.so.6 => /lib/libm.so.6 (0xf74df000)
        libc.so.6 => /lib/libc.so.6 (0xf7311000)
        /lib/ld-linux.so.2 (0x56638000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf72f3000)

Many thanks..

UPDATE

Seem i do have it installed buy using a different version of it..

[root@gseu ~]# locate libcrypto
/usr/lib64/.libcrypto.so.1.0.2h.hmac
/usr/lib64/.libcrypto.so.10.hmac
/usr/lib64/libcrypto.so.1.0.2h
/usr/lib64/libcrypto.so.10

Edited by AshleyIn1080p

Share this post


Link to post
Share on other sites

I have the same issue. We need libssl1.0.0 however that's not part of the Fedora/RedHat/CentOS distro, they use openssl instead.   Check your /lib folder instead of /lib64 since XM8.so is 32 bit.   If you don't have a libcrypto in /lib

yum install openssl.i686  

If ldd doesn't find it still, you can try creating a link from the filename its looking for to the newer libcrypto file provided by the distro and see if that works.  

 

Share this post


Link to post
Share on other sites
Advertisement

From what i can tell on fedora package is called "openssl-libs" -.- because reasons

Share this post


Link to post
Share on other sites

Thanks Grim.  Confirmed the openssl crap has gone away.   Unfortunately still stuck with only GLIBCXX_3.4.19 and XM8.so requires GLIBCXX_3.4.20.  

 

Spoiler

[ec2-user@ip-172-31-1-173 @exileserver]$ ldd XM8.so
./XM8.so: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./XM8.so)
        linux-gate.so.1 =>  (0xf7772000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf76ef000)
        libdl.so.2 => /lib/libdl.so.2 (0xf76ea000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf7606000)
        libm.so.6 => /lib/libm.so.6 (0xf75c3000)
        libc.so.6 => /lib/libc.so.6 (0xf7405000)
        /lib/ld-linux.so.2 (0x56565000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf73eb000)
 

 

Share this post


Link to post
Share on other sites
21:44:34 "ExileServer - XM8 mesage sent: {""r"":[""123456789012345678""],""m"":""protection-money-paid"",""t"":""Test Base Please Ignore""} ([0,'Config OK MainThread started'])"

Success!  Thank you Grim.   This has been fun and educational.  Playing Exile has made me a better Linux admin.  (At least in my imagination). 


 

Share this post


Link to post
Share on other sites

We have closed this thread and marked it as solved.

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.