• 0
Mr Health And Safety

onHackedData ban/kick

Question

I have been working on custom loot spawns over the past few days and after getting to a position to test them i fired up my test server to try them.

Before even getting onto the server, i got a message pop up "You were banned". Checked the ban.txt file and deleted my steam id. There is no message anywhere that i can see telling me why i am getting banned.

To save keep deleting my id out of ban.txt, i changed onHackedData = ban to kick and now i get kicked instead of banned so i know its not Infistar.

I have now put everything i can think off that i edited (like i say im sure it was only loot) back to default and im still getting kicked.

I deleted my cache (AppData\Local\Arma 3\MPMissionsCache\) and its not even trying to download the mission so its something server side for sure.

Does anyone know of anything to check?

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0
36 minutes ago, Mr Health And Safety said:

I have been working on custom loot spawns over the past few days and after getting to a position to test them i fired up my test server to try them.

Before even getting onto the server, i got a message pop up "You were banned". Checked the ban.txt file and deleted my steam id. There is no message anywhere that i can see telling me why i am getting banned.

To save keep deleting my id out of ban.txt, i changed onHackedData = ban to kick and now i get kicked instead of banned so i know its not Infistar.

I have now put everything i can think off that i edited (like i say im sure it was only loot) back to default and im still getting kicked.

I deleted my cache (AppData\Local\Arma 3\MPMissionsCache\) and its not even trying to download the mission so its something server side for sure.

Does anyone know of anything to check?

onHackedData means that arma thinks that your pbos have been modified from the server's versions. What I would do is verify your arma 3 via steam, verify @Exile via a3launcher or download it again from here, and then copy @Exile to your server to make sure it's correct on your server as well. 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Thanks guys, I had tried everything that was mentioned in the other posts but nothing helped.

Verifying the game files found no fault and doing it to the server found 1 file but it did not fix it after it was replaced.

I got it fixed now anyhow. Thanks for your replys

Share this post


Link to post
Share on other sites
  • 0

infiSTAR has a good explanation for this. :)

Since the last Exile patch, the exile server config.cfg (the example file) has this

onHackedData                         = "ban (_this select 0)";

usually it was

onHackedData                         = "kick (_this select 0)";

That bans your players (because they have corrupted game files).

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Yeah my problem wasn't anything like them hence trying them and not working..

I had downloaded the Eden plug in and extracted it to my arma 3 folder not looking at directory structure and it puts it in the @exile folder. Moved it to its own folder now and set it up as  mod in its own addons folder etc and all is working fine now. 

Edited by Mr Health And Safety

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.