okawa

Object placement question

4 posts in this topic

I've looked this forum over and found no answer. I'm trying to place objects in the initServer.sqf file. That file uses this format: 

["Exile_Sign_Office_Small", [3112.3191,5456.582,15.405867], [[0,1,0],[0,0,1]], [false,false]],

The editor exports into this:

dataType="Object";
class PositionInfo
{
	position[]={3112.3191,5456.582,15.405867};
				angles[]={0,5.1487212,0};
};
side="Empty";
flags=5;
class Attributes
{
};
id=0;
type="Exile_Sign_Office_Small";
atlOffset=-0.69999886;

The problem I'm having is, where do I get the values for setVectorDirAndUp, as opposed to what is exported, from the editor? What am I missing?

Share this post


Link to post
Share on other sites

Eden won't output a format that the initserver.sqf understands. You need to load up Eden with either M3editor or Exile's newly released Eden plugin. This will then show another tab on the menu bar which allows you to export the objects in sqf format.

Share this post


Link to post
Share on other sites
Advertisement

I couldn't get the plugin to work because the moment I run the a3 launcher and it verifies the installation, it deletes the plugin.

Share this post


Link to post
Share on other sites
37 minutes ago, okawa said:

I couldn't get the plugin to work because the moment I run the a3 launcher and it verifies the installation, it deletes the plugin.

Download it manually from the downloads section on the website and place it in your Arma 3 folder. Boot up steam > Run Arma 3 > In the launcher select all the mods you want and then load ExileEden mod as well > Press Go. 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.