• 0
JerryAtricks

Server Mod Startup Parameters, Which Way Is Proper?

Question

I've seen a few different answers to this but can I get something definitive? In my startup.bat I have my mod startup parameters as:

-mod=@Exile;@ExileServer;Kart;Mark;Heli

But I'v seen some that have it with quotation marks like: 

-mod="@Exile;@ExileServer;Kart;Mark;Heli"

As it is, my server starts and plays fine, but which is the actual way I should have it? 

 

Thanks!

Share this post


Link to post
Share on other sites

4 answers to this question

  • 1

 

21 minutes ago, BetterDeadThanZed said:

Actually it's -mod=@Exile -serverMod=@ExileServer

No quotes and no "Kart;Mark;Heli". Those are automatically loaded without being included in the command line.

not 100% right answere 
see sportrep00058 on dev hub 

Updated: Stand-alone Windows Dedicated Server (1.62)
Updated: Stand-alone Linux Dedicated Server (1.62)
Known issue: Steam client modifies the steam_appid.txt file incorrectly. In case of issues, verify its content is: 107410
Known issue: Sometimes the add-ons are loaded from the wrong installation (e.g. main game)
Try adding -mod=curator;kart;heli;mark;expansion;dlcbundle to your arma3server.exe shortcut

and the Quotes u can need too when used a path with SPACE in the mod command like 

Complex example

-mod=@Exile
-mod="mods test\@Exile"
-mod="c:ArmA 3\mods test\@Exile"

"@Exile"  (relative path)
is located in the arma3 installation folder 
("c:ArmA 3\@Exile")

"mods test\@Exile"  (relative path; subfolder)
is in the installation folder 
("c:ArmA 3\mods test\@Exile")

"c:\ArmA 3\mods test\@Exile" (absolute path)
is in 
"c:ArmA 3\mods test\@Exile"

but on standart ur right

Spoiler

-mod=@Exile -serverMod=@ExileServer

and all will work

Share this post


Link to post
Share on other sites
  • 1
2 hours ago, JerryAtricks said:

I've seen a few different answers to this but can I get something definitive? In my startup.bat I have my mod startup parameters as:

-mod=@Exile;@ExileServer;Kart;Mark;Heli

But I'v seen some that have it with quotation marks like: 

-mod="@Exile;@ExileServer;Kart;Mark;Heli"

As it is, my server starts and plays fine, but which is the actual way I should have it? 

 

Thanks!

you only need to use quotes if you have addons with spaces in the folder names

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Actually it's -mod=@Exile -serverMod=@ExileServer

No quotes and no "Kart;Mark;Heli". Those are automatically loaded without being included in the command line.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, second_coming said:

you only need to use quotes if you have addons with spaces in the folder names

Cool, thanks!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.