Sign in to follow this  
Followers 0
FN-2187

Am I blonde? Config.cfg missing.

6 posts in this topic

I was following the guide S made, and it made sense to me.

Then it got to the point where you began to install Exile, extracting the client side and server files into the folder when I came across a lack of config.cfg.. there's a basic.cfg but no config.cfg. Any suggestions?

https://gyazo.com/4daffa4e7871e5db5f9cc941932cefa3

Spoiler

 @echo off


color 0a
title Exile Monitor
:Serverstart
echo Launching Server
C: 
cd "C:\Arma\Server"
echo Exile Server Monitor... Active !
start "Arma3" /min /wait arma3server.exe -mod=@exile;Kart;Mark;Heli; -servermod=@exileserver; -config=C:\Arma\Server\@ExileServer\config.cfg -port=2302 -profiles=SC -cfg=C:\Arma\Server\@ExileServer\basic.cfg -name=SC
ping 127.0.0.1 -n 15 >NUL
echo Exile Server Shutdown ... Restarting!
ping 127.0.0.1 -n 5 >NUL
cls
goto Serverstart

 

 

Edited by FN-2187

Share this post


Link to post
Share on other sites

Hello,

 

Cannot tell you what is what.

What I can tell you is this:

 

Basic.CFG = Network settings

Config.CFG = Server settings/config - usually called SERVER.CFG

You can look up both formats to see what goes in them/can be modified.  To seach for 'config', search using 'server.cfg'.

 

BOTH can be called ANYTHING.  They must be called from the ARMA startup with the proper names though.

 

Here are mine, so you can 'cut-n-paste' if you wish.  Do note, as I have been busy with other stuff, theses files are NOT CURRENT.  Though, they still may be valid, I did not wish for you to think that they were.

 

Good luck!

 

:)

 

**********

 

Basic.CFG:

//
// Exile Mod basic.cfg Settings
//
// This file has been tuned for a box running only one Arma 3 server on a
// 1 GBit/s pipe with 100 slots
//
// See https://community.bistudio.com/wiki/basic.cfg
//

///////////////////////////////////////////////////////////////////////////////
// Default Options
///////////////////////////////////////////////////////////////////////////////
language = "English";
adapter = -1;
3D_Performance = 1.000000;
Resolution_W = 800;
Resolution_H = 600;
Resolution_Bpp = 32;

///////////////////////////////////////////////////////////////////////////////
// Bandwidth Tuning
//
// Be sure to adjust this to your server settings!
// This example is for 1GBit/s pipe
///////////////////////////////////////////////////////////////////////////////
// 100MB * 1024 * 1024 = 104857600
MinBandwidth = 104857600;    

// Do NOT set this too high or your Arma server will simulate ego-ddos
// 600MB * 1024 * 1024 = 629145600
MaxBandwidth = 629145600;        

///////////////////////////////////////////////////////////////////////////////
// Network Tuning
//
// Usually something we developers set. Only change these if you really know
// what you are doing. Do something wrong here and your sever will burn in hell
// and cause massive desych.
///////////////////////////////////////////////////////////////////////////////
MaxMsgSend = 256;
MaxSizeGuaranteed = 512;        
MaxSizeNonguaranteed = 256;    
MinErrorToSend = 0.004;    
MinErrorToSendNear = 0.03;        
MaxCustomFileSize = 0;           

 

 

 

**********

Config.CFG

 

hostname                            = "Put YOUR server name here that will show when being browsed for";
password                             = "pw";
passwordAdmin                          = "pw";
serverCommandPassword                = "pw";
logFile                                = "server.log";
verifySignatures                       = 0;
BattlEye                            = 0;
requiredBuild                         = 133596;
allowedLoadFileExtensions[]         = {:};
allowedPreprocessFileExtensions[]     = {"sqf"};
allowedHTMLLoadExtensions[]         = {"html"};
motdInterval                         = 5;               
maxPlayers                             = 5;        
voteMissionPlayers                     = 200;   
voteThreshold                         = 200;
disableVoN                            = 1;        
vonCodecQuality                     = 10;   
persistent                            = 1;       
kickDuplicate                         = 1;
equalModRequired                     = 0;
timeStampFormat                     = "short";
onUserConnected                     = "";
onUserDisconnected                     = "";
doubleIdDetected                     = "";
onUnsignedData                         = "kick (_this select 0)";    
onHackedData                         = "kick (_this select 0)";
onDifferentData                     = "kick (_this select 0)";
motd[]                                 = {"Welcome to Arma 3 Exile Mod!", "WWW.ExileMod.Com", "Enjoy your stay!" };

class Missions
{
    class Exile
    {
        //template = Exile.Altis;  // Exile.Namalsk
        template = Exile.Namalsk
        difficulty = "ExileRegular"; // ExileRegular or ExileHardcore
    };
};

 

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

I appreciate the effort into posting the .cfgs, but that doesn't entirely help me.

I only have the one 'basic.cfg' that has two lines in it. There is no other config, I'm just confused to what I've done wrong for neither of the config files to properly generate.

Share this post


Link to post
Share on other sites

Hello,

 

You did not understand.  CREATE these files and put  the contents above in those files.

 

I am updating my exile server now and I see those 2 files in the exile server zip file, so you have them and the basic.cfg is MORE than 2 lines too.

 

So, when you create your batch file to start exile, point the batch file to those 2 file locations.

 

Good example of what/how to do it: 

 

"-config=@ExileServer\config.cfg" "-cfg=@ExileServer\basic.cfg"

 

You can call them ANYTHING and place them ANYWHERE, JUST make sure you have the CORRECT names/paths listed above!

 

:)

 

 

 

1 person likes this

Share this post


Link to post
Share on other sites
17 hours ago, FN-2187 said:

I appreciate the effort into posting the .cfgs, but that doesn't entirely help me.

I only have the one 'basic.cfg' that has two lines in it. There is no other config, I'm just confused to what I've done wrong for neither of the config files to properly generate.

The config.cfg file comes with the Exile server files and is in the @ExileServer folder.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.