MrDraug

Altis Radiation Potato

17 posts in this topic

Posted (edited)

Hello!

Im trying to add some radiation zones. 

For Example my config.cpp this is what I did on 0.9.80 on my server

class Radiation
{
	// 1 = enabled, 0 = disabled
	enable = 1;
	contaminatedZones[] =
	{
		{{21845.1, 20977.6, 30}, 350, 400}, // Ghost Hotel
		{{3874.3633,13280.79, 30}, 600, 400}	// Kavala
	};
};

And here is my last try for 1.0.0 Potato (config.cpp), I tried a lot of combinations and nothing helps.

class Radiation
{
	// 1 = enabled, 0 = disabled
	enable = 1;
	contaminatedZones[] =
	{
		{{21845.1, 20977.6, 30}, 350, 400}, // Ghost Hotel
		{{3700, 13235, 30}, 800, 800}	// Kavala
	};
};

Setting a marker is not a problem, I cant get my radiation in cities.. 

Thank you com!

Edited by MrDraug

Share this post


Link to post
Share on other sites
35 minutes ago, MrDraug said:

Hello!

Im trying to add some radiation zones. 

For Example my config.cpp this is what I did on 0.9.80 on my server


class Radiation
{
	// 1 = enabled, 0 = disabled
	enable = 1;
	contaminatedZones[] =
	{
		{{21845.1, 20977.6, 30}, 350, 400}, // Ghost Hotel
		{{3874.3633,13280.79, 30}, 600, 400}	// Kavala
	};
};

And here is my last try for 1.0.0 Potato (config.cpp), I tried a lot of combinations and nothing helps.


class Radiation
{
	// 1 = enabled, 0 = disabled
	enable = 1;
	contaminatedZones[] =
	{
		{{21845.1, 20977.6, 30}, 350, 400}, // Ghost Hotel
		{{3700, 13235, 30}, 800, 800}	// Kavala
	};
};

Setting a marker is not a problem, I cant get my radiation in cities.. 

Thank you com!

They are defined in the mission.sqm in Potato 1.0.0

Share this post


Link to post
Share on other sites
Advertisement
10 minutes ago, Zeito said:

They are defined in the mission.sqm in Potato 1.0.0

Here is my code for Kavala from mission.sqm

    // Zone Kavala
    class Item0
    {
      position[]={3700, 0 ,13235};
      name="ContaminatedZoneKavalaIcon";
      text="Contaminated Zone";
      type="ExileContaminatedZone";
      markerType="ELLIPSE";
      colorName="ColorBlack";
      fillName="Border";
      a=800;
      b=800;
      drawBorder=1;
    };
    class Item1
    {
      position[]={3700, 0 ,13235};
      name="ContaminatedZoneKavalaIcon";
      text="";
      type="ExileContaminatedZone";
    };

It is only a marker, but I need radiation behind the marker :)

Share this post


Link to post
Share on other sites

And that isn't working for you? Here is an example from my mission.sqm and my zones work fine

    class Item49
    {

        position[] = {8563.59, 0, 11931.8};
        name = "ExileMarker8";
        text = "";
        markerType = "ELLIPSE";
        type = "ExileContaminatedZone";
        colorName = "ColorBlack";
        fillName = "Border";
        a = 450;
        b = 450;
        drawBorder = 1;
        id = 108;
        atlOffset = 0;
    };
    class Item50
    {

        position[] = {8563.59, 0, 11931.8};
        name = "ExileMarker9";
        text = "";
        type = "ExileContaminatedZoneIcon";
        id = 109;
        atlOffset = 0;
    };

1 person likes this

Share this post


Link to post
Share on other sites

So does it mean i dont realy need to add this Zone array in config.cpp any more? Only create a Marker in mission.sqm and it should work? Ok, thats funny, couse im got thouse coords from ExileZ and its prty central on the map and I was right in the middle and there was nothing... 

Share this post


Link to post
Share on other sites

Posted (edited)

    class Item0
    {
     position[]={3700, 0, 13235};
     name="ContaminatedZoneKavala";
     text="Contaminated Zone";
     type="ExileContaminatedZone";
     markerType="ELLIPSE";
     colorName="ColorBlack";
     fillName="Border";
     a=800;
     b=800;
     drawBorder=1;
    };
    class Item1
    {
     position[]={3700, 0, 13235};
     name="ContaminatedZoneKavalaIcon";
     text="";
     type="ExileContaminatedZone";
    };

So this is what im using right now. I can see a maker with a border on the map, but when i go in, there is nothing. No radiation.... btw. the ghost hotel location is working.

Edited by MrDraug

Share this post


Link to post
Share on other sites

Over here I read the coordinates of radiation zones in the config are no longer used or needed and now it's defined in the mission.sqm

 

1 person likes this

Share this post


Link to post
Share on other sites

Thank you @Emton , good to know. But now I dont realy know why my marker is not working.. As I said, I can see it on the map, but there is no radiation. I was on ghost hotel location, its working perfectly..

Share this post


Link to post
Share on other sites

Hmm I'm not sure but maybe it needs an id ? Here's the original format:

Spoiler

        class Item41
        {
            dataType = "Marker";
            position[] = {2901.51, 0, 12333.8};
            name = "ExileMarker41";
            text = "";
            markerType = "ELLIPSE";
            type = "ExileContaminatedZone";
            colorName = "ColorBlack";
            fillName = "Border";
            a = 1600;
            b = 1600;
            drawBorder = 1;
            id = 141;
            atlOffset = 0;
        };
        class Item42
        {
            dataType = "Marker";
            position[] = {2901.51, 0, 12333.8};
            name = "ExileMarker42";
            text = "";
            type = "ExileContaminatedZoneIcon";
            id = 142;
            atlOffset = 0;
        };

 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Also this guy says there's something to do with the height so maybe adjust the altitude of it. Me I'm just trying to figure out how to disable the zone right now, if i delete the marker from the mission.sqm it crashes arma starting up. Edit: Oh I think I got it working, deleting the 2 marker entries, adjusting the items from 58 to 56 and renumbering all the items after the contamination markers.

 

Edited by Emton
1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.