• 1
killerbud211

How to add lockers to traders

Question

So my group of guys and I got a new server on Esseker and we are trying to figure out how to add in the Locker (Private Stash). We just cant figure it out. Ether its just something real easy and we are just over looking it or we are just plain dumb.

Share this post


Link to post
Share on other sites

13 answers to this question

  • 0

Do you know how to place custom objects on a map? If so, open the editor and add the lockers then add the code to your server. 

Not really a server side bug by the way. Wrong subforum.

Share this post


Link to post
Share on other sites
  • 0

No I don't. I've been Map editing before but haven't done custom editing.

Sorry about the Wrong subforum too.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
8 minutes ago, killerbud211 said:

No I don't. I've been Map editing before but haven't done custom editing.

Sorry about the Wrong subforum too.

So you've placed objects on your map with the editor in the past? 

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, BetterDeadThanZed said:

So you've placed objects on your map with the editor in the past? 

Yes

Share this post


Link to post
Share on other sites
  • 0

Ok so place the lockers in the editor and export the code,  placing it in the file with your trader objects. That's all there is to do. The game will detect the lockers and automatically give the option to deposit or withdraw.

Share this post


Link to post
Share on other sites
  • 0

@Metalman10I've followed your instruction to a tee and for some reason my server wont load with the new lines added?

Basically I rent from QGS, so the server is mostly set up basic settings wise.

Ive added most mods myself, but map alterations I seem to be struggling with. Lockers being one of them

I get the mission Sqm with M3editor, add the lockers and trader boards respectively. Save with Dev tools getting the code for the objects.

Go to my unpacked mission folder and post the lines underneath in new lines in the Initserver.sqf and post the relevant lines underneath.

I then repack and reload it to my MPmisson folder it came from on my QGS game panel, restart the server, and it initially boots, but then just utterly fails and is stuck in a waiting stage?

Do you have any idea what I'm doing wrong?

Cheers for the help

Share this post


Link to post
Share on other sites
  • 0

Post your server RPT (even though you should be able to find the error in it yourself) and your initserver.sqf files in Pastebin links.

Share this post


Link to post
Share on other sites
  • 0

Apologies I'm on the work computer and have restricted access of what I can and cant post haha

 

Below is the following what I added to my Initserver.sqf if that helps? whenever I add these specific lines. The server just wont boot. It's stumped me.

["Exile_Locker",[9336.4,4863.53,5.55922],[[0.793515,0.608551,-0.00056939],[0.0123186,-0.0151273,0.99981]],false],
 ["Exile_Sign_Locker",[9335.1,4865.7,5.5502],[[0.766216,0.642584,0],[0,0,1]],false],
];

{
    private ["_object"];

    _object = (_x select 0) createVehicleLocal [0,0,0];
    _object setDir (_x select 2);
    _object setPosATL (_x select 1);
    _object enableSimulation false; // :)

}
forEach _objects;

 

Cheers for the help

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.