Sign in to follow this  
Followers 0
modernkilla82

Adding Status Bar To Mission File| Help Please |

5 posts in this topic

I need some help adding- This Status Bar into my mission file Exile.Esseker.PBO I do not know how to do it myself...i tried to follow this  but my server would just have the Creating and not Playing in arma 3 and i get stuck on Connecting...Can someone please help me out...I don not have much money but i will donate if needed. 

Share this post


Link to post
Share on other sites

Add the statusbar folder to your mission file.  For example, under server > mpmissions > unpack your Exile.Altis.pbo go to addons and add the statusbar folder from the mod download.  Within the Exile.Altis.pbo you will also see initplayerlocal.sqf.  Open it with Notepad++.  Between lines 6 and 8 put a blank lines for spacing and put in 

[] execVM "addons\statusBar\statusBar.sqf"

Mine looks like

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////

// Taken away for now
//#include "initServer.sqf"

[] execVM "addons\statusBar\statusBar.sqf";

if (!hasInterface || isServer) exitWith {};

 

Share this post


Link to post
Share on other sites
Advertisement

Don't forget to repack the pbo.  It's been a while since I put the statusbar in, but I think that's all you have to do.

Share this post


Link to post
Share on other sites
3 hours ago, Potatoskin said:

Add the statusbar folder to your mission file.  For example, under server > mpmissions > unpack your Exile.Altis.pbo go to addons and add the statusbar folder from the mod download.  Within the Exile.Altis.pbo you will also see initplayerlocal.sqf.  Open it with Notepad++.  Between lines 6 and 8 put a blank lines for spacing and put in 

[] execVM "addons\statusBar\statusBar.sqf"

Mine looks like

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////

// Taken away for now
//#include "initServer.sqf"

[] execVM "addons\statusBar\statusBar.sqf";

if (!hasInterface || isServer) exitWith {};

 

Didn't work...when trying to join the server it stays on Connecting... and on Creating instead of playing

Share this post


Link to post
Share on other sites

I also have mine with a bit of config in description.ext:

#include "config.cpp"

    class RscTitles
    { 
        #include "addons\StatusBar\statusBar.hpp"
    };

And in my init.sqf:
// Start the StatusBar
    [] execVM "addons\statusBar\statusBar.sqf";

The iniPlayerLocal.sqf is different on Tanoa (which is where this config came from) and doesn't contain the same bit as stated above.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.