Spackler

[SOLVED] help me with NOTIFY_MSG_ARRAY please

7 posts in this topic

I have the following in my code to show when players login...Has worked before but now once it gets to the last display is stays on screen.

Spoiler

ENABLE_NOTIFICATION_MESSAGES = true;
NOTIFY_MSG_ARRAY[] =
{
	{-1, -1, 8, 0.7, 0, 0, "#ff0000", "Create a party to avoid hearing people in side chat"},
	{-1, -1, 8, 0.7, 0, 0, "#ff0000", "Base building height has been restricted to 30m. You will no longer be able to build over 30m high."},
	{-1, -1, 8, 0.7, 0, 0, "#ff0000", "Sunday 8/14/2016 we will start removing all bases over 30m high. Adjust your base now."},
	{-1, -1, 8, 0.7, 0, 0, "#ff0000", "If you have any concerns about your base ask an admin in TS."}
};

 

Also it seems that when spawning persistent vehicles it does not work. You do not get a lock option but you do with non-persisent. So seems like they have been switched but neither stays at reboot.

 

Share this post


Link to post
Share on other sites

Hey,

I saw the error I had in my code so it wasn't deleting when all your messages were set to "just show once" like it is in your example. So that's fixed in the hotfix that I am going to upload in the next few minutes (57A) but the vehicle spawn is a problem somewhere on your end, I've just tested persistent and none persistent and it's working completely fine

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Posted (edited)

21 hours ago, infiSTAR said:

update is out :)

My Msg config:

ENABLE_NOTIFICATION_MESSAGES = true;
NOTIFY_MSG_ARRAY[] =
{
	{-1, -1, 6, 0.6, 0, 0, "#ff0000", "Welcome to our server"},
	{-1, -1, 4, 0.6, 0, 0, "#1900FF", "Enjoy!"},
	{-1, -1, 5, 0.6, "safeZoneX", "0.5", "#048B5B", "Protected and administrated by<br/>infiSTAR.de AdminTools, AntiHack and more!"}, <-- Original
	{-1, .-1, 10, 0.8, 0, 0, "#ff0000", "Server Restart all 4 Stunden:"},
	{-1, .-1, 10, 0.8, 0, 0, "#ff0000", "Um 00:00, 04:00, 08:00, 12:00, 16:00 und 20:00"},
	{-1, .-1, 10, 0.8, 0, 0, "#ff0000", "Kein Admin auf dem Server?<br/>Tippe !ts in den Chat und komm in unseren TS"}	
};

and i get this error:

21:27:34 "<infiSTAR.de> 0 - Cfg_infiSTAR_settings has been found, STARTING"
21:27:34 Error in expression <_x select 0)*60];_x set [1,(_x select 1)*60];NOTIFY_MSG_ARRAY set [_forEachIndex>
21:27:34   Error position: <*60];NOTIFY_MSG_ARRAY set [_forEachIndex>
21:27:34   Error *: Type String, expected Number,Not a Number
21:27:34 File a3_infiSTAR_Exile\fn_preInit.sqf, line 176
21:27:34 Error in expression <_x select 0)*60];_x set [1,(_x select 1)*60];NOTIFY_MSG_ARRAY set [_forEachIndex>
21:27:34   Error position: <*60];NOTIFY_MSG_ARRAY set [_forEachIndex>
21:27:34   Error Generic error in expression
21:27:34 File a3_infiSTAR_Exile\fn_preInit.sqf, line 176

 

Edited by [FCS-DE]^oo^[Linux]

Share this post


Link to post
Share on other sites

Look at your code again.. What is "SafezoneX", shold be a 0 no? 

{-1, -1, 5, 0.6, "safeZoneX", "0.5", "#048B5B", "Protected and administrated by<br/>infiSTAR.de AdminTools, AntiHack and more!"}, <-- Original

 

Share this post


Link to post
Share on other sites

SafeZones can be used their (now) falcon :)

however please remove " <-- Original"

and also your .-1 makes no sense as that is the same as 0.-1 if you want -0.1 you have to write it like I just did :)

so here it is in color what you need to change/remove

gvc51QtFM1jB2KfBmpPXp.png

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.