Lieutenant Bushman

you have been kicked off server

12 posts in this topic

so i am encountering a message 'kicked off server' while playing exile it happens anywhere from just as i enter the game to a few minutes after i enter. it has to do with not staying connected. i have already discussed this on the servers forums

 

the RDP is showing that infistar is failing to load and thats why but the BEC is showing this:

05:13:59 : Player #2 ltbushman (70.120.203.241:2304) connected
05:14:00 : RCon admin #0: (Global) JOIN OUR STEAM GROUP AT STEAM.KILLINZEDZ.NET
05:14:15 : Player #2 ltbushman disconnected
05:14:42 : Player #2 ltbushman (70.120.203.241:2304) connected
05:14:44 : Player #2 ltbushman - GUID: 5cf24e2f6aa4dbe8e1efd937ccfa2047
05:14:45 : Verified GUID (5cf24e2f6aa4dbe8e1efd937ccfa2047) of player #2 ltbushman
05:15:42 : Script Log: #2 ltbushman (5cf24e2f6aa4dbe8e1efd937ccfa2047) - #0 "

and that im being kicked because i cant stay connected. my internet is fine, my game is fine. please help.

 

 

Share this post


Link to post
Share on other sites

This is my server he is referring to. The error in the server when he gets kicked is from Infistar and says "Run check failed". This has happened to some other players too.

Share this post


Link to post
Share on other sites
Advertisement

Yep, infiSTAR could not run correct on these players or could not catch em for checking. @infiSTAR

Share this post


Link to post
Share on other sites
1 hour ago, MrWhite said:

Yep, infiSTAR could not run correct on these players or could not catch em for checking. @infiSTAR

I kinda figured that out but I'd like to know why it happens and if there is something server side I need to do or if it's a client side issue that players can address.

Share this post


Link to post
Share on other sites

I don't see what you posted above the screenshot, it keeps loading.

 

But the message "You've been kicked off bla bla" can also be caused by modified data file / wrong signatures and so on and so on, doesn't have to be infiSTAR :)

Share this post


Link to post
Share on other sites
10 hours ago, infiSTAR said:

I don't see what you posted above the screenshot, it keeps loading.

But the message "You've been kicked off bla bla" can also be caused by modified data file / wrong signatures and so on and so on, doesn't have to be infiSTAR :)

This is the kick message in the Infistar log:

12-08-2016 16:55:31 infiSTAR.de | Lieutenant Bushman | RCT Anthoney(76561198272018263) | 1h 38min 43s | Runcheck failed

 

Share this post


Link to post
Share on other sites

Okay,

when you log into an exile server your client creates a unit called EXILE_UNIT_GHOST

then the server is doing some magic and creates a new player object for you (either a bamib or one with your last position, gear etc.) and that unit type is called EXILE_UNIT_PLAYER

then it remoteExecCalls to your client and gives the unit to you so your client can select it and delete the EXILE_UNIT_GHOST.

 

Now your client unit within the "allPlayers" function/array is typeOf Exile_Unit_Player

Your gui loads and you can see the world through the Exile_Unit_Players eyes :)

That unit in not getting checked for certain values but before the checks start the unit will get a variable set on, when the life of the unit started.

That is done 35 seconds after you've taken control.

 Another 80 seconds later it is being checked if certain values are set - if they are not set it waits if your unit is alive for 5 minutes (because some people really play on gameboys) if that's the case and certain values are still not set then you're getting kicked off witch "Runcheck failed".

 

With other words, we're already giving a hacker like 7 minutes to bypass those function that are checked here just because some people have computers where I wonder that they run windows on :D

when testing that and making that function, I've tested it with 0.5 seconds and not 7 minutes - never had a problem.. 

1 person likes this

Share this post


Link to post
Share on other sites
17 hours ago, BetterDeadThanZed said:

Thank you for the detailed explanation. 

Hey

I hope that really helps a bit.


I really don't want the tool to kick people for no reason and would be happy to be able to remove that check but there's still so many ways to "inject" into arma :/

Share this post


Link to post
Share on other sites

Posted (edited)

If I could add to this:

I am the server admin. I have a clean exile server install and I have installed the Reborn exile mod with no other mods. I check the mod installation and ran it without infistar and worked fine. I was on server for well over 20 minutes with no kick. I thne installed infistar and now get kicked  with this in log

25-08-2016 09:31:14 infiSTAR.de  ID: 5 (SLOG_SKICK: Aztec | 0h 41min 37s | Player Clientside AntiHack not loaded or stopped! Exile_Unit_Player  @[27095.2,23322.8,0.00143814] 270233)

I have verified my arma3 files and also updated BE but still get kicked. I have also made sure Infistar is installed properly.

Any other ideas what i can check?

Added: and Yes i have the latest version of infistar installed.

Edited by Aztec

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.