Riggleboy

Roaming Trader Script

54 posts in this topic

12 hours ago, gfourth said:

I did add another items pack to my trader files, but didnt change any of the community customs. Since this issue I have tried to change my community customs by changing the class names to Travelling Trader and what not, but I can't get him to be a normal trader.

Next step is to switch it to another community customs trader and see what that does (community2 or 3).

I did also change travelling traders uniform and backpack, I'll switch those back too.

The problem could be in your initplayerlocal.sqf 

Look at this example from one of mine. See that i have defined Communuitycustoms3 as a vehicle trader

["Exile_Trader_Vehicle", ["HubSittingChairUB_move1"], "Exile_Trader_CommunityCustoms3", "WhiteHead_06", [[],[],[],["Exile_Uniform_ExileCustoms",[]],[],[],"","",[],["","","","","",""]], [1081.64, 7456.51, 3.26611], [0, 1, 0], [0, 0, 1]],

If i wanted him to be a normal trader, i would change it to this

["Exile_Trader_CommunityCustoms3", ["HubSittingChairUB_move1"], "Exile_Trader_CommunityCustoms3", "WhiteHead_06", [[],[],[],["Exile_Uniform_ExileCustoms",[]],[],[],"","",[],["","","","","",""]], [1081.64, 7456.51, 3.26611], [0, 1, 0], [0, 0, 1]],

Does that help at all?

Share this post


Link to post
Share on other sites
2 hours ago, TheDaddy said:

The problem could be in your initplayerlocal.sqf 

Look at this example from one of mine. See that i have defined Communuitycustoms3 as a vehicle trader


["Exile_Trader_Vehicle", ["HubSittingChairUB_move1"], "Exile_Trader_CommunityCustoms3", "WhiteHead_06", [[],[],[],["Exile_Uniform_ExileCustoms",[]],[],[],"","",[],["","","","","",""]], [1081.64, 7456.51, 3.26611], [0, 1, 0], [0, 0, 1]],

If i wanted him to be a normal trader, i would change it to this


["Exile_Trader_CommunityCustoms3", ["HubSittingChairUB_move1"], "Exile_Trader_CommunityCustoms3", "WhiteHead_06", [[],[],[],["Exile_Uniform_ExileCustoms",[]],[],[],"","",[],["","","","","",""]], [1081.64, 7456.51, 3.26611], [0, 1, 0], [0, 0, 1]],

Does that help at all?

Thank you TheDaddy.  I took a look, but then I remembered that I do not have any other traders on my map (yet), so my initplayerlocal is empty. :( It's been empty the whole time I've been working on the travelling trader, he's my first form of trader that I've added to my map.

I've tried everything I could think of, I rolled my mission file back and the travelling trader.sqf back to when I first had it working...  I tried using other community customs.  And no matter what he has the vehicle interface.

Stumped.

 

EDIT: Am I supposed to have him listed in the initplayerlocal??

Edited by gfourth

Share this post


Link to post
Share on other sites
Advertisement

No, he doesn't need to be because he is spawned by the mod. I'll have a think and try to replicate your issue.

Share this post


Link to post
Share on other sites

To update on my issue, in case anyone has any pointers...

I've placed every kind of trader on my map (armory, equp, food, diving), besides the travelling trader, and they ALL have the vehicle interface... WTH?

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.