Sign in to follow this  
Followers 0
1Man

Fix for Death Loop Bug/Spawn

9 posts in this topic

I find this easier than having to manually delete these in the database plus your players wont get stuck in the loop and leave!

1. Stop the SQL service

2. Edit my.ini in C:\ProgramData\MySQL\MySQL Server 5.7 or C:\ProgramData\MySQL\MySQL Server 5.6 depends on which one you have installed probably hidden file.

Add event_scheduler=ON to the bottom, save it then go to properties of my.ini and check read only, double check strict mode is off this saves you issues down the road with bambi creation timeouts.

3. Open up your SQL editor I.E. HeidiSQL and right click on the exile database scroll down to Create New and select event

Under setting just name it, I named mine Damaged Player under comments I put in Damaged 1

Under execution body delete everything and paste DELETE FROM `player` WHERE damage = 1

Under Timing this depends if you have revive setup, if you do every 5 mins should be fine if you dont then 1 min would be good as well.

Click save and start your SQL service back up

I do not foresee a huge performance impact on the database running every 1 or 5 mins.

Share this post


Link to post
Share on other sites
Advertisement

I just redid my database and this in fact does work so I really don't know what else to tell ya, I followed the directions from above and every 5 mins it does delete damaged players with value of 1

1 person likes this

Share this post


Link to post
Share on other sites

Ive done exactly this but everytime i look in data base theres still characters with damage = 1

Share this post


Link to post
Share on other sites

make sure event_scheduler=ON is in your my.ini and that your SQL is stopped then edit it, save then mark it read only and now start up SQL.

Share this post


Link to post
Share on other sites

But from what i have seen this has made players lose their characters because when they disconnect it kills them and turns into Damage=1 and then the database deletes their character.. or atleast thats how i see it

Share this post


Link to post
Share on other sites

did somebody fix this bug? because i have the same problem on my server! please help

 

thanks

Share this post


Link to post
Share on other sites

There really is no way around it, its going to give them a damage 1 unless your going to manually fix it every time it happens and change it to 0. This at the very least will allow them to get to their body and allow them to play versus waiting for some to have access to the database to change the value.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.