• 0
kuplion

MB 4WD Changing colour!! Fix?

Question

On our server, the MB 4WD is known as the Rainbow Jeep because they change colour each restart. Has anyone else experienced this? Is there a fix? It happens with the Exile_Car_... version and the Arma3 classname versions too.

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

It's actually like that in ArmA 3 and I didn't override it.  Is it annoying?  I rather liked it.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
30 minutes ago, Vishpala said:

It's actually like that in ArmA 3 and I didn't override it.  Is it annoying?  I rather liked it.

^ confirmation Vish is a girl IRL :P

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Vishpala said:

It's actually like that in ArmA 3 and I didn't override it.  Is it annoying?  I rather liked it.

Not annoying as such, but if you're reliant on a green jeep to help hide in the trees and after the restart it's bright orange, it's certainly changes the game play ever so slightly. :P

EDIT: Is there a way to override it that can be implemented with a CustomCode override?

1 hour ago, second_coming said:

^ confirmation Vish is a girl IRL :P

lol

Edited by kuplion

Share this post


Link to post
Share on other sites
  • 0

Wait, I'm confused.  Ther are two Jeeps the Exile_Car_MB4WD  and the Exile_Car_MB4WDOpen.  The Exile_Car_MB4WDOpen randomly changes between Brown/Green and different parts are hidden when you purchase it. But the Exile_Car_MB4WD is always Orange.  You can purchase a new paint job for the Exile_Car_MB4WD to change its color but it shouldn't auto change.  

I just tested in the editor and both vehicles are working properly for me.
I tested on a server through a restart:  

  • Exile_Car_MB4WD Orange - stayed orange
  • Exile_Car_MB4WD w/ Green Paint job - still green
  • Exile_Car_MB4WDOpen - randomized

Working perfectly for me.   :/

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Vishpala said:

Wait, I'm confused.  Ther are two Jeeps the Exile_Car_MB4WD  and the Exile_Car_MB4WDOpen.  The Exile_Car_MB4WDOpen randomly changes between Brown/Green and different parts are hidden when you purchase it. But the Exile_Car_MB4WD is always Orange.  You can purchase a new paint job for the Exile_Car_MB4WD to change its color but it shouldn't auto change.  

I just tested in the editor and both vehicles are working properly for me.
I tested on a server through a restart:  

  • Exile_Car_MB4WD Orange - stayed orange
  • Exile_Car_MB4WD w/ Green Paint job - still green
  • Exile_Car_MB4WDOpen - randomized

Working perfectly for me.   :/

Hmmm. I've definitely seen them change across restarts; I'll investigate further. Thank you for getting back to me.

Share this post


Link to post
Share on other sites
  • 0

@Vishpala, I have an update. I've spoken to several of my players and they've explained the issue slightly better.

The colours are random to each player, but seemingly persistent. So the orange jeep is always orange for me, but always blue for you; as thought the textures are chosen locally rather than server side. And you see your jeep as green but to me it's brown.

And the random changes are local too, so for me the jeep has no doors, but for you it does. Apparently both behave the same, in terms of physics, and things like capacity, gear, and fuel and all global and therefore the same across the server for any player who was to check it.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.