• 0
RastaLulz ツ

Vehicles unlock after restart

Question

Hi guys I have been searching over the forums for a vehicle stay locked type of script.

 

Basically this shouldn't happen:

Before restart, vehicles are normally locked by us people, after restart the vehicles that were locked are now unlocked by system-default.

 

How can I change this? I want to make it so that vehicles which are locked by players, remain locked and vehicles which are left unlocked, remain unlocked?

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Basically, what you are requesting is how vanilla exile works.  So, you need to work out what you have added or overriden that's causing the issue. 

Was it working before? What did you change since it worked? Switch those back off and narrow it down to the offending script or error. 

Run the vanilla mission with no additional pbo's in exileserver other than the originals. 

If this fixes it, you know the fault is in the mission. Turn all scripts off in your modified pbo thereby taking it back to default and then switching on one at a time until it breaks again or, you stumble across the error. 

If it wasn't the mission, the error should be in the exileserverconfig pbo. 

Repeat the process above by going back to default and see if that fixes it. If it does, you have got an error in there somewhere. Try using notepad++ and the plugin called compare to see if there is anything glaringly obvious. 

Hopefully by now you should be sorted... If not, pop back  

 

Good luck :)

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

Yes I have been going through the files and I found this in config.cpp inside folder > @Exile_Server > Addons > exile_server_config.pbo
 


		/**
		 * Set this to 1 to unlock vehicles on server boot if they are in safe zones
		 *
		 * 0 = off
		 * 1 = on
		 */
		unlockInSafeZonesAfterRestart = 1;	

 

I have changed this to:


		/**
		 * Set this to 1 to unlock vehicles on server boot if they are in safe zones
		 *
		 * 0 = off
		 * 1 = on
		 */
		unlockInSafeZonesAfterRestart = 0;	

so hopefully this works.

 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Hmm, don't get your hopes up. I have that set to 1 and all it does, which it's supposed to do, is unlock vehicles in safezones. Not all vehicles across the map. 

I'm afraid you have something else wrong. 

Have you messed around with the mission.sqm at all? Or added a separate safezone script? 

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, BaroN said:

Hmm, don't get your hopes up. I have that set to 1 and all it does, which it's supposed to do, is unlock vehicles in safezones. Not all vehicles across the map. 

I'm afraid you have something else wrong. 

Have you messed around with the mission.sqm at all? Or added a separate safezone script? 

No no, what I changed was right. In trader zones, the vehicles that are locked by players was supposed to stay locked. The server kept changing it's state to unlocked, but that script implemented already^ in config.cpp has fixed the issue. 

 

I guess this can help some people who are new to owning an Exile Mod server and don't know about the locking / unlocking after server restart in trader zones.

Share this post


Link to post
Share on other sites
  • 0

Great, wish you could have said in your first post that you meant it was only happening at the trader....! Could have told you straight away...

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.