Sign in to follow this  
Followers 0
johnyboy2o11

welcome script help plz

7 posts in this topic

Hi Everyone

I've been setting up a server for 3 months now it's been really  good fun and I've learned loads from all you scripter's  so first off thank you 2 everyone on this forum. 

It's probably the most easiest fix I just can't figure it out lol

Welcomemsg Script 

endLoadingScreen;

[] spawn 
{
	_text1 = (format
		[
			"<t color='%1' size='%2' font='%3'>%4</t><br/>
			<t color='%1' size='%2' font='%3'>%5</t><br/>",
			"#FFFFFF",
			0.50,
			"OrbitronMedium",
			"Welcome to Exile Stoners Lounge",
			format["Good luck and have fun %1", name player]
		]);
			
	[
		_text1,
		0.4,
		0.5,
		12,
		5,
		0,
		24358+round(random 5)
	] call BIS_fnc_dynamicText;

	_text2 = (format
		[
			"<t color='%1' size='%2' font='%3'>%4</t><br/>
			<t color='%1' size='%2' font='%3'>%5</t><br/>
			<t color='%1' size='%2' font='%3'>%6</t><br/>
			<t color='%1' size='%2' font='%3'>%7</t><br/>
			<t color='%1' size='%2' font='%3'>%8</t><br/>
			<t color='%1' size='%2' font='%3'>%9</t><br/>
			<t color='%1' size='%2' font='%3'>%10</t><br/>",
			"#FFFFFF",
			0.50,
			"OrbitronMedium",
			"Mods.",
			"Custom Traders.",
			"Custom Loadout.",
			"Personal Vehicle [Double Click Radio].",
			"Enigma Revive.",
			"Sell From Create [Create has 2 be Loaded in Vehicle].",
			"Service Re-Arm Repair.",
			"Anti-Theft [Safezone's].",
			"Tow-Lift Hack-Grind HaloJump AirDrop.",
			"Apps in XM8."
		]);

	[
		_text2,
		0.4,
		0.6,
		7,
		5,
		0,
		24358+round(random 5)
	] call BIS_fnc_dynamicText;

	_text3 = (format
		[
			"<t color='%1' size='%2' font='%3'>%4</t><br/>
			<t color='%1' size='%2' font='%3'>%5</t><br/>
			<t color='%1' size='%2' font='%3'>%6</t><br/>",
			"#FFFFFF",
			0.50,
			"OrbitronMedium",
			"Exile puts new players in a default group.",
			"Make a Party in your XM8 to combat this."
		]);

	[
		_text3,
		0.4,
		0.7,
		7,
		2,
		0,
		24358+round(random 5)
	] call BIS_fnc_dynamicText;
	
	_text4 = (format
		[
			"<t color='%1' size='%2' font='%3'>%4</t><br/>
			<t color='%1' size='%2' font='%3'>%5</t><br/>
			<t color='%1' size='%2' font='%3'>%6</t><br/>",
			"#FFFFFF",
			0.50,
			"OrbitronMedium",
			"Donate to help the server at www.ExileStonersLounge.com",
			"TS3: Coming Soon"
		]);

	[
		_text4,
		0.4,
		0.7,
		7,
		2,
		0,
		24358+round(random 5)
	] call BIS_fnc_dynamicText;
	
};


ExileClientIntroIsPlaying = false;

true

I added a new line so i copied text 2 section of the script to create a new line but the text appears with spaces  instead of

            "Mods.",
            "Custom Traders.",
            "Custom Loadout.",
            "Personal Vehicle [Double Click Radio].",
            "Enigma Revive.",
            "Sell From Create [Create has 2 be Loaded in Vehicle].",
            "Service Re-Arm Repair.",
            "Anti-Theft [Safezone's].",
            "Tow-Lift Hack-Grind HaloJump AirDrop.",
            "Apps in XM8."

all that fits in is

"Mods.",
            "Custom Traders.",


            "Custom Loadout.",


            "Personal Vehicle [Double Click Radio].",


            "Enigma Revive.",


            "Sell From Create [Create has 2 be Loaded in Vehicle].",


            "Service Re-Arm Repair.",

 

with spaces as above , I know it has something to do with the section below but am an idiot lol 

"<t color='%1' size='%2' font='%3'>%4</t><br/>
            <t color='%1' size='%2' font='%3'>%5</t><br/>
            <t color='%1' size='%2' font='%3'>%6</t><br/>
            <t color='%1' size='%2' font='%3'>%7</t><br/>
            <t color='%1' size='%2' font='%3'>%8</t><br/>
            <t color='%1' size='%2' font='%3'>%9</t><br/>
            <t color='%1' size='%2' font='%3'>%10</t><br/>", 

if anyone could help that would be awesome thanks

Share this post


Link to post
Share on other sites

Please could someone figure this out my server is ready to go

much appreciated 

JohnyBoy

Share this post


Link to post
Share on other sites
Advertisement

Text 1 3 and 4 are fine 2 lines of text with no spaces , but text 2 has spaces between each line of mod i have put in so it does not fit them all in on the screen 

if I could just figure out how to get rid of the spaces i'd be spot on m8

Share this post


Link to post
Share on other sites

Posted (edited)

12 hours ago, StokesMagee said:

@johnyboy2o11 don't use intro.sqf use initPlayerLocal.sqf :P

Any Ideas from the above comments plz m8

Edited by johnyboy2o11

Share this post


Link to post
Share on other sites

Admin could you please move this to the proper scripts section in Downloads and Releases section.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.