• 1
John

Constructions outside territories - Dont clean up

Question

Posted (edited)

@Eichi

 

I think I have discovered an issue where constructions outside territories, such as fire place or workshop will not cleanup, this is because the "last_updated_at" column in the DB gets set to the current date / time of each server restart.

I could be wrong, or broke something but I think this is a problem =(

Edited by John

Share this post


Link to post
Share on other sites

25 answers to this question

  • 0

Will investigate. Remember that @CEN had a similar issue.

Share this post


Link to post
Share on other sites
  • 0

Cannot confirm this. Are you updating the construction table on boot? The last_updated_at is implicitly set when you run an UPDATE on that table.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
3 minutes ago, Eichi said:

Cannot confirm this. Are you updating the construction table on boot? The last_updated_at is implicitly set when you run an UPDATE on that table.

After further testing it does not appear to update the last_updated_at on every boot, but it is updating them in bulk at set times, for some reason -

For instance, I might have 10 campfires in the DB, that al have the exact same last_updated_at

As far as territories / cleanup is concerned I have not touched anything outside of standard (that I am aware of) =(

Anything I can do to narrow it down? Specific tests?

Share this post


Link to post
Share on other sites
  • 0

Can you turn on query logging? Then we can see what it can be. Please post the query log here or via pastebin.

Share this post


Link to post
Share on other sites
  • 0

Seeing a very similar pattern @CEN though I cant seem to pinpoint why =*( ill look into query logging and see how we go.

Share this post


Link to post
Share on other sites
  • 0

Can you verify that you are running the latest exile.ini?

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Eichi said:

Can you verify that you are running the latest exile.ini?

I'm definitely using the latest exile.ini and just confirmed I have the same issue.

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Eichi said:

You have query logs?

Where will I find them on Windows with Oracle MySQL?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.