Sign in to follow this  
Followers 0
Echo of Zhiend

Fahrzeug Munition entfernen

16 posts in this topic

Posted (edited)

Hallo erstmal,

wie Ihr oben schon im Titel erkennen könnt, habe ich Folgendes Problem.

Ich möchte den Y-32 Xian auf unserem Server anbieten, allerdings ohne Waffen.  Der Xian ist schon eingetragen und alles, kaufen würde auch funktionieren, aber ich finde werde hier im Forum noch mit Google etwas wirklich brauchbares.

Meine Frage ist, muss ich eine eigene .sqf erstellen das mir Exile den Xian ohne Muni in den Waffen spawnt oder gibt es da mittlerweile eine elegantere Lösung. z.B. das Infistar sagt das das Fahrzeug kein Munition besitzen darf.

 

Freue mich über jede Antwort.

 

Gruß Echo

 

 

Edited by Echo of Zhiend

Share this post


Link to post
Share on other sites

Ja, du musst dir ein Skript bauen welches bei Fahrzeuginitialisierung die Waffen und/oder die Munition entfernt. Jede Waffe und jede Munitionsart inkl. der Menge der vorhandenen Magazine muss für jeden Fahrzeugtyp einzeln entfernt werden. Such mal in den einschlägigen Foren für Arma 3 - da wirst du ganz sicher fündig.

 

grüße

Cal

Share this post


Link to post
Share on other sites
Advertisement

Also erstmal danke für die Antwort.

Ich den Foren von Arma 3 hab ich schon geschaut, wie genau ich das entferne, also die Munitiosart etc weiß ich, wüsste nur noch nicht wie ich das script anfangen muss und in welchen Ordner genau es rein müsste, bin noch neu in der Thematik :) 

Aber werde mich weiter dransetzen und vllt finde ich ja was.

 

Gruß

Echo

Share this post


Link to post
Share on other sites

Posted (edited)

es ist auf jedenfall möglich , gibt einige tutorials, such einfach nach Arma 3 Vehicle remove Weapon.

Theoretisch ist es auch Möglich die Bewaffnung zu Ändern. zum, beispiel das die Bug bewaffnung nur 6.5mm Gatling schiesst usw.

ist aber alles Theoretisch. Damals bei meinen Arma 2 Dayz Server hatte ich so einige Fahrzeuge ummoduliert. 

die Datei wo du es anpassen kannst ist unter Exile_Server  /code  irgendwas mit Spawn Vehicles. 

Edited by Quixy

Share this post


Link to post
Share on other sites

Posted (edited)

Danke Quixy für die Antwort.

Werd mich gleich mal dransetzen, wird schon schief gehen :)

Ja Arma 2 Tutorials hab ich auch gefunden aber is ja anderes Game+ Mod.

 

Gruß

Echo

 

Edited by Echo of Zhiend

Share this post


Link to post
Share on other sites

ist zwar ne andere Mod, aber das prinzip ist das selbe.

Share this post


Link to post
Share on other sites

OK, habe nur ein Problem.
Hab die Datei gefunden, aber mit fehlen für den Xian noch die Lenkraketen von der Classname.

und ganz genau was ich da eintragen soll weiß ich auch nach stunden googeln und foren durchschauen auch nicht so wirklich :/

Share this post


Link to post
Share on other sites

Hab da was gefunden:rock:

With

"_vehicleObject setVehicleAmmo 0;"

and

"_vehicleObject setAmmoCargo 0;"

in to the files
ExileServer_object_vehicle_createNonPersistentVehicle.sqf, 
ExileServer_object_vehicle_createPersistentVehicle.sqf,
ExileServer_object_vehicle_database_load.sqf and 
ExileServer_system_trading_network_purchaseVehicleRequest.sqf 
can you remove ammunition from vehicles and ammo trucks.

Hier auch fürs Anzeigen der Waffen/Munition deiner Fahrzeuge...

weapons vehicle player;       <<< zeigt an welche Waffen das Fahrzeug hat

magazinesAllTurrent vehicle Player;     <<< zeigt welche Munition dafür benötigt wird

einfach in die Debug Konsole, unter Watch/Ansehen, eintippen.

 

Und um Munition auf die Blacklist zu packen, empfehle ich das hier

 

Edited by [HG]RaVeN103

Share this post


Link to post
Share on other sites

Danke Raven für die Antwort, werd es heut mal testen.

Im Moment hab ich leider ein ganz anderes Problem, wenn man auf den Server zu connecten versucht, is man nur im ladebildschirm und unten link erscheint immer: Connecting, Exile Spruch, Connecting, Exile Spruch...........

Das die ganze Zeit und weiter passiert nichts, irgendwie fährt der Server nicht richtig hoch.

Glaube das das Infistar ist was die Connection blockt. Kann das stimmen?

Spoiler
extDB2: Version: 71
extDB2: https://github.com/Torndeco/extDB2
extDB2: Linux Version
Message: All development for extDB2 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB2 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 20/02/15
 

extDB2: Found extdb-conf.ini
extDB2: Detected 8 Cores, Setting up 6 Worker Threads
 

[16:00:18 +02:00] [Thread 31496] extDB2: Database Type: MySQL
[16:00:18 +02:00] [Thread 31496] extDB2: Database Session Pool Started
[16:00:18 +02:00] [Thread 31496] extDB2: SQL_CUSTOM_V2: Loading Template Filename: /home/steam/steamcmd/arma3/@exileserver/extDB/sql_custom_v2/exile.ini
[16:00:18 +02:00] [Thread 31496] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available
[16:00:18 +02:00] [Thread 31911] extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Input String insert_infiSTARLog:CONNECTLOG:infiSTAR_PlayerConnected_id= 0
[16:00:18 +02:00] [Thread 31911] extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Callname insert_infiSTARLog
[16:00:18 +02:00] [Thread 31912] extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Input String insert_infiSTARLog:CONNECTLOG:infiSTAR_PlayerDisconnected_id= 0
[16:00:18 +02:00] [Thread 31912] extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Callname insert_infiSTARLog
[16:00:18 +02:00] [Thread 31914] extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Input String insert_infiSTARLog:SERVER_INFO:[SERVER START] TIME= 0 || EMAIL= paypal@leonor.pw || VERSION= 01-Sep-2016 01-18-33 - v0059
[16:00:18 +02:00] [Thread 31914] extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Callname insert_infiSTARLog

 

Share this post


Link to post
Share on other sites

machst du in der "Exile_Server_createcarefulvehicle" heißt die glaub ich! details folgen später. noch auf der arbeit!

Edited by Skryp _ LotzoTheUltraBear

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.