• 0
DavieReid88

[SOLVED] CUP Weapons/Units/Vehicles

Question

I was wondering if someone could help me, i wanting CUP on my server, i have a server through GTXGaming which is one click mod download, ive downloaded CBA, CUP Units, CUP Vehicles and Cup Wweapons.

I have my mod line this:

-mod=@CBA_A3;@CUP_Units;@CUP_Vehicles;@CUP_Weapons;

i changed my config for the traders to this:

class CfgExileArsenal
{
    #include "TRADERS\APEX\ItemListAPEX.hpp"
    #include "TRADERS\ARMA3V\ItemListARMA3V.hpp"
    #include "TRADERS\ARMA3W\ItemListARMA3W.hpp"
    #include "TRADERS\CUPW\ItemListCUPW.hpp"
    #include "TRADERS\CUPV\ItemListCUPV.hpp"
    //#include "TRADERS\EBM\prices.hpp"
    //#include "TRADERS\HAP\ItemListHAP.hpp"
    //#include "TRADERS\HLC\ItemListHLC.hpp"
    //#include "TRADERS\HVP\ItemListHVP.hpp"
    //#include "TRADERS\HVP\ItemListHWP.hpp"
    //#include "TRADERS\Jonzie\ItemListJonzie.hpp"
    //#include "TRADERS\MASV\ItemListMASV.hpp"
    //#include "TRADERS\MASW\ItemListMASW.hpp"
    //#include "TRADERS\NIA\ItemListNIA.hpp"
    //#include "TRADERS\R3FW\ItemListR3FW.hpp"
    //#include "TRADERS\RHSGREF\ItemListGREF.hpp"
    //#include "TRADERS\RHSV\ItemListRHSV.hpp"
    //#include "TRADERS\RHSW\ItemListRHSW.hpp"
    //#include "TRADERS\TRYK\ItemListTRYK.hpp"
    //#include "TRADERS\PODS\ItemListPODS.hpp"
    //#include "TRADERS\CUSTOM\ItemListCUSTOM.hpp"
    #include "TRADERS\Exile\ItemListExile.hpp"
};

class CfgTraderCategories 
{
    #include "TRADERS\APEX\TraderCategoriesAPEX.hpp"
    #include "TRADERS\ARMA3V\TraderCategoriesARMA3V.hpp"
    #include "TRADERS\ARMA3W\TraderCategoriesARMA3W.hpp"
    #include "TRADERS\CUPW\TraderCategoriesCUPW.hpp"
    #include "TRADERS\CUPV\TraderCategoriesCUPV.hpp"
    //#include  "TRADERS\EBM\traders.hpp"
    //#include  "TRADERS\HAP\TraderCategoriesHAP.hpp"
    //#include  "TRADERS\HLC\TraderCategoriesHLC.hpp"
    //#include  "TRADERS\HVP\TraderCategoriesHVP.hpp"
    //#include  "TRADERS\HVP\TraderCategoriesHWP.hpp"
    //#include  "TRADERS\Jonzie\TraderCategoriesJonzie.hpp"
    //#include  "TRADERS\MASV\TraderCategoriesMASV.hpp"
    //#include  "TRADERS\MASW\TraderCategoriesMASW.hpp"
    //#include  "TRADERS\NIA\TraderCategoriesNIA.hpp"
    //#include  "TRADERS\R3FW\TraderCategoriesR3FW.hpp"
    //#include  "TRADERS\RHSGREF\TraderCategoriesGREF.hpp"
    //#include  "TRADERS\RHSV\TraderCategoriesRHSV.hpp"
    //#include  "TRADERS\RHSW\TraderCategoriesRHSW.hpp"
    //#include  "TRADERS\TRYK\TraderCategoriesTRYK.hpp"
    //#include  "TRADERS\PODS\TraderCategoriesPODS.hpp"
    //#include  "TRADERS\CUSTOM\TraderCategoriesCUSTOM.hpp"
    #include "TRADERS\Exile\TraderCategoriesExile.hpp"
};

class CfgTraders
{
    #include "TRADERS\CfgTraders.hpp"
};

Altered my cfgtraders.hpp to this:

class Exile_Trader_Armory
    {
        name = "ARMORY";
        showWeaponFilter = 1;
        categories[] = 
        {
            //"PointerAttachments",
            //"CUPPointerAttachments",
            //"MASPointerAttachments",
            //"R3FPointerAttachments",
            //"RHSPointerAttachments",
            //"BipodAttachments",
            //"APEXBipodAttachments",
            //"R3FBipodAttachments",
            //"RHSBipodAttachments",
            //"MuzzleAttachments",
            //"APEXMuzzleAttachments",
            //"HLCMuzzleAttachments",
            "CUPMuzzleAttachments",
            //"MASMuzzleAttachments",
            //"NIAMuzzleAttachments",
            //"R3FMuzzleAttachments",
            //"RHSMuzzleAttachments",
            //"OpticAttachments",
            //"APEXOpticAttachments",
            //"HLCOpticAttachments",
            "CUPOpticAttachments",
            //"MASOpticAttachments",
            //"NIAOpticAttachments",
            //"R3FOpticAttachments",
            //"RHSOpticAttachments",
            //"NIAAttachments",
            //"Ammunition",
            //"APEXAmmunition",
            //"GREFAmmunition",
            //"HLCAmmunition",
            "CUPAmmunition",
            //"MASAmmunition",
            //"NIAAmmunition",
            //"R3FAmmunition",
            //"RHSAmmunition",
            //"Pistols",
            //"APEXPistols",
            "CUPPistols",
            //"MASPistols",
            //"R3FPistols",
            //"RHSPistols",
            //"Shotguns",
            //"SubMachineGuns",
            //"APEXSubMachineGuns",
            "CUPSubMachineGuns",
            //"MASSubMachineGuns",
            //"R3FSubMachineGuns",
            //"LightMachineGuns",
            //"APEXLightMachineGuns",
            //"HLCLightMachineGuns",
            "CUPLightMachineGuns",
            //"MASLightMachineGuns",
            //"NIALightMachineGuns",
            //"R3FLightMachineGuns",
            //"RHSLightMachineGuns",
            //"AssaultRifles",
            //"APEXAssaultRifles",
            //"HAPASSAULTRIFLES",
            //"HLCAssaultRifles",
            "CUPAssaultRifles",
            //"MASAssaultRifles",
            //"NIAAssaultRifles",
            //"R3FAssaultRifles",
            //"RHSAssaultRifles",
            //"GREFWeapons",
            //"SniperRifles",
            //"APEXSniperRifles",
            //"HAPSNIPERRIFLES",
            //"HLCSniperRifles",
            //"HWPweapons",
            "CUPSniperRifles",
            //"MASSniperRifles",
            //"NIASniperRifles",
            //"R3FSniperRifles",
            //"RHSSniperRifles"
        };
    };

When in the traders in my server the categories show up but they are blank like with no pictures, the price is still there but when i click on them to buy it comes up Bad Vehicle Type and doesnt work, is there something im doing wrong?

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0
4 minutes ago, DavieReid88 said:

@StokesMagee ikt actually doesnt it just has exile | ryanszombies

 

http://a3.launcher.eu/check

Use this to update your server, once you check it, and it doesn't give you an error, give it up to 30 minutes and see if CUP is in the mods list, else there is a problem with CUP loaded on the server.

 

//edit

don't forget to restart the launcher every time you check!

Share this post


Link to post
Share on other sites
Advertisement
  • 0

@StokesMagee yes i think so im connecting to the server though A3 launcher, how do i know if everything is correct? im new to server hosting learning each day.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, DavieReid88 said:

@StokesMagee yes i think so im connecting to the server though A3 launcher, how do i know if everything is correct? im new to server hosting learning each day.

On the a3Launcher, does your server show that CUP is enabled in the mod section (generally under the server name)

Share this post


Link to post
Share on other sites
  • 0

@StokesMagee I got it working, while ive been adding CUP to the server and havent actually closed the a3 launcher, i restarted the a3 launcher and reinstalled all CUP now it works thanks.

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, DavieReid88 said:

@StokesMagee I got it working, while ive been adding CUP to the server and havent actually closed the a3 launcher, i restarted the a3 launcher and reinstalled all CUP now it works thanks.

:)

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.