Sign in to follow this  
Followers 0
XYZ Loki

Vehicle spawn and inventory size

17 posts in this topic

Hey all

So I'm trying to do some editing to the vehicle spawns, I would like the server to spawn various vehicles mod vehicles

I am also trying to edit the inventory size of various vehicles

I also have a problem with vehicles teleporting back to traders when server restart 

Share this post


Link to post
Share on other sites
22 minutes ago, XYZ Loki said:

Hey all

So I'm trying to do some editing to the vehicle spawns, I would like the server to spawn various vehicles mod vehicles

I am also trying to edit the inventory size of various vehicles

I also have a problem with vehicles teleporting back to traders when server restart 

  1. Any cfg of dynamic spawn vehicle located in @ExileServer\Addons\exile_server_config.pbo -> config.cpp (classes: VehicleSpawn (array: ground) -> any ground vehicle, BUT remember it will be like a trash... (Spawn city = VehicleSpawn(ammount) + BambiSettings->spawnZoneVehicles).
  2. Inventory size -> search vehicle configuration files and search way to override 'em...
  3. If vehicle dynamic - no need teleport back to trader... They automatically will spawn at trader.

Share this post


Link to post
Share on other sites
Advertisement
23 minutes ago, Sid Debian said:
  1. Any cfg of dynamic spawn vehicle located in @ExileServer\Addons\exile_server_config.pbo -> config.cpp (classes: VehicleSpawn (array: ground) -> any ground vehicle, BUT remember it will be like a trash... (Spawn city = VehicleSpawn(ammount) + BambiSettings->spawnZoneVehicles).
  2. Inventory size -> search vehicle configuration files and search way to override 'em...
  3. If vehicle dynamic - no need teleport back to trader... They automatically will spawn at trader.

Regarding "3" how do I fix them it, basically someone buys a vehicle takes it from the trader and when the server restarts the vehicle will telephoto back to the trader... 

Share this post


Link to post
Share on other sites
1 minute ago, XYZ Loki said:

Regarding "3" how do I fix them it, basically someone buys a vehicle takes it from the trader and when the server restarts the vehicle will telephoto back to the trader... 

Hm. There's some problem... Do you change vehicle purchase script? Or you have wrong ini file for database dll in @ExileServer

Share this post


Link to post
Share on other sites
2 hours ago, Sid Debian said:

Hm. There's some problem... Do you change vehicle purchase script? Or you have wrong ini file for database dll in @ExileServer

Which files would you need to see to help me figure it out?

we are using this for traders as we run various mods and it makes it easier to config the traders

 

Share this post


Link to post
Share on other sites
12 minutes ago, XYZ Loki said:

Which files would you need to see to help me figure it out?

we are using this for traders as we run various mods and it makes it easier to config the traders

 

you need (just for test) replace with original @ExileServer\extDB\sql_custom_v2\exile.ini (DON'T  FORGET TO BACKUP ORIGINAL FILE)
try to install default database (for checkin') if it will be fine, then try to use your old database. If you have no problem, you find you problem. If it wouldn't help -> backup you exile exile_server.pbo and try to use default exile_server.pbo...

Edited by Sid Debian

Share this post


Link to post
Share on other sites
9 minutes ago, Sid Debian said:

you need (just for test) replace with original @ExileServer\extDB\sql_custom_v2\exile.ini (DON'T  FORGET TO BACKUP ORIGINAL FILE)
try to install default database (for checkin') if it will be fine, then try to use your old database. If you have no problem, you find you problem. If it wouldn't help -> backup you exile exile_server.pbo and try to use default exile_server.pbo...

Where can I get a orginal exile.in? 

Just to get this right 

First try replacing the exile.ini  if it works that's my issue? If that doesn't work try a default exile mission?

Share this post


Link to post
Share on other sites
2 minutes ago, XYZ Loki said:

Where can I get a orginal exile.in? 

Just to get this right 

First try replacing the exile.ini  if it works that's my issue? If that doesn't work try a default exile mission?

exilemod.com -> download -> exile server.

You said that you have no save vehicles... So possible solutions:

  1. exile server.pbo
  2. extDB2 (and config)
  3. Self MySQL Server...

So is that logical?

Share this post


Link to post
Share on other sites
2 minutes ago, Sid Debian said:

exilemod.com -> download -> exile server.

You said that you have no save vehicles... So possible solutions:

  1. exile server.pbo
  2. extDB2 (and config)
  3. Self MySQL Server...

So is that logical?

Basically anyone will buy a vehicle and take it to where ever but when server restarts that vehicle will be back at the trader 

Share this post


Link to post
Share on other sites
1 minute ago, XYZ Loki said:

Basically anyone will buy a vehicle and take it to where ever but when server restarts that vehicle will be back at the trader 

Let me see... You want to disable for database save the vehicle location (where you bought there it stay after restart)?
For example: you bought a car at baloto took a ride to berezino, then restart of server and car again will located in baloto?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.