Nerexis

Disable SHIFT Click marker on map

5 posts in this topic

What is current way to disable shift-click marker on map in Exile 1.0.2?
I have seen lots of topics regarding this issue, but I can't disable it.

Tried two ways:

- difficulty settings - didnt work or I'm doing something wrong. I have modified the file in: armaServerProfiles\Users\<my username>\xxx.Arma3Profile then in server config, I have set custom difficulty profile for my mission template

- second method: added

onMapSingleClick {_shift};

- in init.sqf and initPlayerLocal.sqf in mission pbo - also didnt work

Share this post


Link to post
Share on other sites

1. Copy and paste the file below into your mission file wherever you want preferably in a custom\overrides folder

this will be located in @exile\addons\exile_client\code\ExileClient_gui_map_event_onDraw

ExileClient_gui_map_event_onDraw

2. find this at the bottom

Spoiler

if!(ExileClientWaypoints isEqualTo [])then
{
    _control = _this select 0;
    {
        _control drawIcon 
        [
            "\a3\ui_f\data\Map\MapControl\custommark_CA.paa",
            [1, 1, 1, 1],
            ExileClientWaypoints select _forEachIndex,
            16,
            16,
            0,
            "",
            0,
            0,
            "PuristaMedium"
        ];
    }
    forEach ExileClientWaypoints;
};

and delete OR // comment out whats spoilered inside this new file in your mission folder

3. one this part is done go into your config.cpp for your mission file the one that has prices crafting ect

find the customcode section as is below

class CfgExileCustomCode 
{
    ExileClient_gui_map_event_onDraw = "custom\overrides\ExileClient_gui_map_event_onDraw.sqf";
};

4. paste what i have inside there to your own, MAKE SURE THE PATH IS CORRECT custom\overrides\

 

if this does not work i should have 1 more that *might* work

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Thank you very much for your help. It pointed me how to overwrite client files, but back to topic:

After your fix, now only 1 marker shows on map, would be better if none shows, but its anyway ok.
I also forget to add that I need to disable them on hud, but I figured it by myself.

To disable them on HUD:
1. Copy the "ExileClient_gui_hud_event_onDraw3d.sqf" from @exile to mission_file\custom\overrides\
2. Comment line inside that sqf:

call ExileClient_gui_hud_renderWaypoints;


3. Add to mission file config.cpp in class cfgCustomCode this line:

ExileClient_gui_hud_event_onDraw3d = "Custom\overrides\ExileClient_gui_hud_event_onDraw3d.sqf";

4. Pack you mission pbo 

Edited by Nerexis

Share this post


Link to post
Share on other sites

Actually adding this:
 

onMapSingleClick {_shift};

to initPlayerLocal.sqf, disables last marker :)

So if you want guys to disable shift-click marker completly in map and hud do this:
1. Apply @Crazy Mike code
2. Apply my code about HUD
3. Add onMapSingleClick code to initPlayerLocal.sqf

1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, Nerexis said:

Actually adding this:
 


onMapSingleClick {_shift};

to initPlayerLocal.sqf, disables last marker :)

So if you want guys to disable shift-click marker completly in map and hud do this:
1. Apply @Crazy Mike code
2. Apply my code about HUD
3. Add onMapSingleClick code to initPlayerLocal.sqf

yea i forgot that last step lmao, I have the multiple markers disabled because there somewhat derpy although useful sometimes, the normal one marker is much better, glad it helped

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.