• 0
koutamarto

Connecting RCON

Question

Hi guys. I see there are alot of people asking about connecting their RCON tools and I have read through most of threads

I am using Dart and my server is running fine. I can connect to the server via localhost (127.0.0.1) But not from a remote pc.

Battle Eye is running but I am not using BEC as I am using infistar restarts and messages.

I have set the Rcon IP to my public IP and set the password in the following files: extdb-conf.ini , config.cfg , beserver.cfg  (within C:\Arma\Server\SC\BattlEye)

my passwords for : passwordAdmin & serverCommandPassword  match my rcon password.

 

I have designated pot 2306 as my rcon port which I have also forwarded from my router.

Has anyone got any ideas how I can get this working?


Cheers
              

Share this post


Link to post
Share on other sites

15 answers to this question

  • 0

change the IP from 127.0.0.1 to Real Server IP , change it also in BEC congfig.cfg and in the BEserver.cfg

port 2306 is Okay

Edited by Quixy

Share this post


Link to post
Share on other sites
  • 0

Or just remove the IP setting in your BEserver.cfg.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
10 hours ago, Quixy said:

change the IP from 127.0.0.1 to Real Server IP , change it also in BEC congfig.cfg and in the BEserver.cfg

port 2306 is Okay

 

6 hours ago, kuplion said:

Or just remove the IP setting in your BEserver.cfg.

Thanks for the responses. Have tried all of this. Just fails to connect.

[2016-10-30 | 10:17:17] Connecting to 121.223.145.42:2306...
[2016-10-30 | 10:17:23] Failed to connect. Please make sure that you properly set a password in beserver.cfg and the server is running.

Does anyone have any other ideas?

Share this post


Link to post
Share on other sites
  • 0

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

Spoiler

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

Spoiler

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

Edited by Quixy

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Quixy said:

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

  Reveal hidden contents

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

  Reveal hidden contents

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

1 hour ago, Quixy said:

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

  Hide contents

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

  Hide contents

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

Yep its all matching as far as I can tell;

beserver.cfg

RConPassword freakshow
MaxPing 300
RConIP 121.223.145.42
RConPort 2306

Config.cfg

passwordAdmin      					= "freakshow";
serverCommandPassword				= "freakshow";

BEC config.cfg

#--------------------------------------------------------------------------------------------------------
[Bec]
#--------------------------------------------------------------------------------------------------------

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 121.223.145.42

# Set the port to the server. default port is 2302
Port = 2306

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Quixy said:

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

  Reveal hidden contents

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

  Reveal hidden contents

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

1 hour ago, Quixy said:

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

  Hide contents

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

  Hide contents

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

Yep its all matching as far as I can tell;

beserver.cfg

RConPassword freakshow
MaxPing 300
RConIP 121.223.145.42
RConPort 2306

Config.cfg

passwordAdmin      					= "freakshow";
serverCommandPassword				= "freakshow";

BEC config.cfg

#--------------------------------------------------------------------------------------------------------
[Bec]
#--------------------------------------------------------------------------------------------------------

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 121.223.145.42

# Set the port to the server. default port is 2302
Port = 2306

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Quixy said:

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

  Reveal hidden contents

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

  Reveal hidden contents

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

1 hour ago, Quixy said:

have you the right Password in the BEServer.cfg? see your Post !

BEC Config.cfg:

  Hide contents

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 123.456.789.000  //<<<< change this to your Server IP
# Set the port to the server. default port is 2302
Port = 2306

in the BEServer.cfg:

  Hide contents

RConPassword ****  //<<<  your Rcon PW
MaxPing 600
RConIP 123.456.789.000 //<<<<< change this to your Server IP
RConPort 2306

 

Yep its all matching as far as I can tell;

beserver.cfg

RConPassword freakshow
MaxPing 300
RConIP 121.223.145.42
RConPort 2306

Config.cfg

passwordAdmin      					= "freakshow";
serverCommandPassword				= "freakshow";

BEC config.cfg

#--------------------------------------------------------------------------------------------------------
[Bec]
#--------------------------------------------------------------------------------------------------------

# Set the ip to your server. normally 127.0.0.1 will be fine.
Ip = 121.223.145.42

# Set the port to the server. default port is 2302
Port = 2306

Share this post


Link to post
Share on other sites
  • 0

Honestly, just remove the IP settings entirely from BEserver.cfg and with your rcon tool point it at 127.0.0.1 if it's on the same machine or the external or internal IP address if using Rcon from a different machine.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, kuplion said:

Honestly, just remove the IP settings entirely from BEserver.cfg and with your rcon tool point it at 127.0.0.1 if it's on the same machine or the external or internal IP address if using Rcon from a different machine.

I did try that but I will try again.
Do u remove the port as well to look like this?

RConPassword freakshow
MaxPing 300

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.