• 0
D3lta

Problem Starting EXILE with all DLCs

Question

Hi Masters.

Cheers, this is my first post here !  . I want to setup an exile Server with all DLCs (including Apex)... How I do this?

See my config.bat

Best Regards!!

Quote



set DIR=%CD%
set ARMA3=%DIR%\arma3

set STEAM="G:\Steam\steamcmd.exe"
set STEAMUSERNAME=asdq1234
set STEAMPASSWORD=34234

set MAP=Altis
set INSTANCEID=Exile

rem Server name needs to be escaped! http://www.robvanderwoude.com/escapechars.php
set SERVERNAME=EXILE 
set IP=127.0.0.1
set PORT=2302
set MAXPLAYERS=10
set SERVERPASSWORD=343
set MAXPING=200
set RCONPASSWORD=a343
set ADMINPASSWORD=343

set MOD=P:\ARMA_MOD\ADDONS\EXILE\exile-server-package-master\exile-server-package-master\arma3\@Exile;
set SERVERMOD=%DIR%\run\@exile_server

set MYSQLHOST=localhost
set MYSQLUSER=root
set MYSQLPASS=123125
set MYSQLDB=exile

set PARAMS=-noSound -autoinit -ip=%IP% -port=%PORT% "-config=%DIR%\run\instance\config.cfg" "-cfg=%DIR%\run\instance\basic.cfg" "-profiles=%DIR%\run\instance" -name=instance "-mod=%MOD%" "-serverMod=%SERVERMOD%"

rem YOU DO NOT NEED TO EDIT BELOW HERE!

set ARMASERVEREXE=arma3server%INSTANCEID%
set ARMASERVERORIGEXE=arma3server.exe
set MISSIONNAME=mission.%MAP%
set MPMISSION=%ARMA3%\mpmissions
set SAR="%DIR%\bin\fnr.exe"
set ZIP="%DIR%\bin\7z.exe"
set PBO="%DIR%\bin\MakePbo.exe"
set BACKUPTIME=%DATE:/=-%@%TIME::=-%
set WGET="%DIR%\bin\wget.exe"

 

 

 

Edited by D3lta

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Hello D3lta,

To use the ARMA default mods, you do NOTHING!

They are loaded in by default at ARMA startup!

This also occurs when playing single player too.

 

Simple fix!

 

:)

 

 

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Z80CPU said:

Hello D3lta,

To use the ARMA default mods, you do NOTHING!

They are loaded in by default at ARMA startup!

This also occurs when playing single player too.

 

Simple fix!

 

:)

 

 

 

thanks a lot my friend, but now, I don't see the server on LAN browser filter.... why?    When I try to connect (using recent connection), i get "Connecting Failing"..... =(

 

Edited by D3lta

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Hello,

There can be hundreds of reason why you cannot connect.

Best thing to do is set up a default ARMA server - NO MODS, plain ole ARMA!.  Make sure you can connect to that.

Then, if you can connect, add the exile mod and NOTHING ELSE and try.

 

Add piece by piece till you get it working.

 

ALWAYS make backup of all your config files.  That way, if you mess up something, you can 'roll back' to what did work before you made those changes.

There are many guides on how to setup a default ARMA server if you run into issues as well as many guides on here on how to setup exile on a working ARMA server.

 

Do not make the mistake a lot of people do, add many things at once and then it does not work.  Then, they do not have a clue what broke things.  If you add one at a time, then you will always know what broke the server if it happened!

:)

 

 

Share this post


Link to post
Share on other sites
  • 0

MANUALLY put in the IP address.  I have a server sitting right next to me and I play it via the LAN.

Not saying putting in the manual will work, but it might.  Also make sure your ports are correct.

 

This is another reason to test with a default ARMA server setup.  If it connects, it is an exile issue.  If it does not, it is an ARMA server setup issue.

 

Also, make SURE ALL anti-virus/firewalls ARE OFF ON BOTH MACHINES!  Also, open the two ports required by ARMA on your router as well for both machines.

The ports and virus/firewall things WILL stop a client from seeing the server!

 

:)

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.