• 0
Forsvinna

[Solved]Trader code 13

Question

Im getting code 13 when trying to buy a Truck from the vehicle trader

i have The MAS vehicles added to the traders with prices and rep showing up perfectly they are added to the traders correctly

however everytime i try to buy one it throws me code 13 contact a admin after looking in the ExileServer_system_trading_network_purchaseVehicleRequest.sqf i found the code 13 and i tried adjusting the spawn radius 

 

Looking at : if (_vehicleclass iskindof "ship") then

should it say LAND? or AIR? i really am stumped on this and i cant get any of my new vehicles to spawn

 

if (_vehicleClass isKindOf "Ship") then
        {
            _position = [(getPosATL _playerObject), 80, 10] call ExileClient_util_world_findWaterPosition;
            if (_position isEqualTo []) then
            {
                throw 13;
            };
            _vehicleObject = [_vehicleClass, _position, (random 360), false, _pinCode] call ExileServer_object_vehicle_createPersistentVehicle;
        }
        else
        {
            _position = (getPos _playerObject) findEmptyPosition [10, 400, _vehicleClass];
            if (_position isEqualTo []) then
            {
                throw 13;
            };
            _vehicleObject = [_vehicleClass, _position, (random 360), true, _pinCode] call ExileServer_object_vehicle_createPersistentVehicle;

 

 

UPDATE SOLVED BY :  hogansheroes  

Thanks so much to  hogansheroes  i have figured out I had messed up in a line of code in my Traders

Edited by Forsvinna

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

Forsvinna just a quesation you have added the mas key to the keys also are you running a hosted server or dedi

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Im using the Traders you posted lmao! The chern map with OCP+jbad

After adding new items to the traders in the config.cpp i get the code 13

Share this post


Link to post
Share on other sites
  • 0

If it's the ferry trader on tanoa, try dropping the number 10 down to 8, then 7 if that doesn't work in the else block.

 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Forsvinna said:

Im using the Traders you posted lmao! The chern map with OCP+jbad

After adding new items to the traders in the config.cpp i get the code 13

Haha. Oh! :D Right, let me have a look and I'll get back to you..

Just to confirm, were non MAS vehicles spawning ok?

Share this post


Link to post
Share on other sites
  • 0

yes Non MAS vehicles work perfectly 

2 minutes ago, kuplion said:

Haha. Oh! :D Right, let me have a look and I'll get back to you..

Just to confirm, were non MAS vehicles spawning ok?

 

I Tried dropping it down to 5 just now and it didnt work still gave me 13

2 minutes ago, BaroN said:

If it's the ferry trader on tanoa, try dropping the number 10 down to 8, then 7 if that doesn't work in the else block.

 

 

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, hogansheroes said:

Forsvinna just a quesation you have added the mas key to the keys also are you running a hosted server or dedi

Im using a dedi And yes the mas keys are loaded! they were however named exactly the samething mas.bikey so i changed one to MasW and masV

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.