Flosstradamus

1.66 BUGS/PROBLEMS *UPDATED* Band-Aid in main post!

345 posts in this topic

Post here if you found anything to be wrong with the new patch.

If you have fixes post them as well

Be warned however that all fixes may be different for each server

Update!

Big thanks to Ultima-Weapon for providing some necessary fixes

Be warned that this is just a temporary Band-aid until Arma releases a hotfix. When they do you must revert the work that was added before you update!

Hello everyone,

As I posted earlier in this thread, I am back from work and have found the fix I promised.

First, a very big thanks to the Exile devs for coding a mod where the code itself is actually very easy to follow. Second, I would like to say thanks to all those who have thus far supported the fixes that I have posted in this thread thus far. Third, while I appreciate the effort of the individuals who have posted untested fixes for the disconnect/reconnect bug, there are some inherent flaws in those codes and though i did not try or test them, I do not believe they can possibly work because of the following: a) No client side code should be called from the server side; b) you should not sent objNull for the unit you want removed on disconnect. (There is more, but I will leave it at that. If this offends you, I am deeply sorry.)

Disclaimer: This code was not written or modified by the Exile dev team and therefore is not an 'Official' fix. Use at your own risk.

With that out of the way, let me continue with the fixes that I have.

To fix the endless blur after death:

Spoiler

Client File:
ExileClient_gui_postProcessing_initialize.sqf

Add:
BIS_DeathBlur ppEffectAdjust [0];
BIS_DeathBlur ppEffectCommit 0;
BIS_DeathBlur ppEffectEnable false;

After:
ExileClientPostProcessingSecurityCameraFilmGrain ppEffectEnable false;

Before:
true


Client File:
ExileClient_gui_postProcessing_reset.sqf

Add:
BIS_DeathBlur ppEffectAdjust [0];
BIS_DeathBlur ppEffectCommit 0;
BIS_DeathBlur ppEffectEnable false;

After:
ExileClientPostProcessingDelirium ppEffectEnable false;

Before:
true


Client File:
ExileClient_gui_postProcessing_toggleDialogBackgroundBlur.sqf

Add:
BIS_DeathBlur ppEffectAdjust [0];
BIS_DeathBlur ppEffectCommit 0;
BIS_DeathBlur ppEffectEnable false;

Before:
if (_this) then


Client File:
ExileClient_object_player_death_startBleedingOut.sqf

Add:
BIS_DeathBlur ppEffectAdjust [0];
BIS_DeathBlur ppEffectCommit 0;
BIS_DeathBlur ppEffectEnable false;

After:
ExileClientPostProcessingColorCorrections ppEffectCommit _respawnDelay;

Before:
ExileClientPostProcessingBackgroundBlur ppEffectAdjust [0];

To fix the onPlayerKilled event handler not firing:

Spoiler

Client File:
ExileClient_object_player_event_onKilled.sqf

Add:
[_this select 0, _this select 1, 3, 120] call ExileClient_object_player_event_onPlayerKilled;

Before:
closeDialog 0;

The above files need to be changed and placed in the 'fixes' folder (or folder of your choice if you know what you are doing) in your mission.pbo.

Then make sure to add the following to your CfgExileCustomCode in config.cpp
 

Spoiler

ExileClient_gui_postProcessing_initialize = "fixes\ExileClient_gui_postProcessing_initialize.sqf";
ExileClient_gui_postProcessing_reset = "fixes\ExileClient_gui_postProcessing_reset.sqf";
ExileClient_gui_postProcessing_toggleDialogBackgroundBlur = "fixes\ExileClient_gui_postProcessing_toggleDialogBackgroundBlur.sqf";
ExileClient_object_player_death_startBleedingOut = "fixes\ExileClient_object_player_death_startBleedingOut.sqf";
ExileClient_object_player_event_onKilled = "fixes\ExileClient_object_player_event_onKilled.sqf";

To fix the disconnect/reconnect dupe (Comparable with servers that run with or without CBA) :

Spoiler

Server File:
ExileServer_system_network_setupEventHandlers.sqf

Remove (or use // at the beginning of the line):
["ExileOnPlayerDisconnected", "onPlayerDisconnected", { [_uid, _name] call ExileServer_system_network_event_onPlayerDisconnected; }] call BIS_fnc_addStackedEventHandler;

Add in it's place:
["ExileOnPlayerDisconnected", "onPlayerDisconnected", { [_id, _uid, _name] call ExileServer_system_network_event_onPlayerDisconnected; }] call BIS_fnc_addStackedEventHandler;

Remove (or use // at the beginning of the line):
onPlayerDisconnected {[_uid, _name] call ExileServer_system_network_event_onPlayerDisconnected};

Add in it's place:
onPlayerDisconnected {[_id, _uid, _name] call ExileServer_system_network_event_onPlayerDisconnected};

Remove (or use // at the beginning of the line):
addMissionEventHandler ["HandleDisconnect", { [_uid, _name] call ExileServer_system_network_event_onHandleDisconnect; }];


Server File:
ExileServer_system_network_event_onPlayerDisconnected.sqf

Add:
params ["_id","_uid","_name"];
_unit = objNull;
{
	if((_x getVariable["ExileOwnerUID","0"]) == _uid) exitWith {
		_unit = _x;
	};
} forEach allUnits;
[_unit,_id,_uid,_name] call ExileServer_system_network_event_onHandleDisconnect;

Before:
true

Repack your server.pbo and mission.pbo and enjoy!

 

Once again a big thank you to Ultima-Weapon for providing these fixes for the community!

 

EDIT Eichi: Be aware this is NOT a fix, but a workaround. This will break your server in case Arma updates.

20 people like this

Share this post


Link to post
Share on other sites

Don't really want to post this, but mehhh

Logging out, logging back in dupes player body

5 people like this

Share this post


Link to post
Share on other sites
Advertisement
7 minutes ago, MGTDB said:

Don't really want to post this, but mehhh

Logging out, logging back in dupes player body

And dropping the mic :)

4 people like this

Share this post


Link to post
Share on other sites

-You die and the screen gets blurry. You respawn and the screen is still blurry. (RECONNECT necessary)

-No timer until auto-respawn after death

- player unit dupes after disconnect and relog

(workaround available)

-random Spawnvehicles (bikes, quads etc.) spawning in Safezone

- random sudden leaving vehicle without pressing keys?

Edited by Skryp _ LotzoTheUltraBear
2 people like this

Share this post


Link to post
Share on other sites
On 1.12.2016 at 6:15 PM, HerbertWitze said:
Do not save the last position when you leave the server!

can't confirm this

Edited by Skryp _ LotzoTheUltraBear
1 person likes this

Share this post


Link to post
Share on other sites
32 minutes ago, MGTDB said:

Don't really want to post this, but mehhh

Logging out, logging back in dupes player body

 

4 minutes ago, HerbertWitze said:
Do not save the last position when you leave the server!

 

Yeah thats right. Fist off all the Players not loaded in correctly, player not saving by disconnect.

Infistar tells me 0 of 1 Player loaded in so all Statsbars not working then. because no Player online.

1 person likes this

Share this post


Link to post
Share on other sites
18 minutes ago, HerbertWitze said:
Do not save the last position when you leave the server!

Can confirm this (sometimes you even loose your gear) but this happens irregularly!

47 minutes ago, MGTDB said:

Don't really want to post this, but mehhh

Logging out, logging back in dupes player body

This (also not always)!

Edited by Artharon

Share this post


Link to post
Share on other sites

- Status bar doesn't show the number of players connected anymore

- When a player got killed his body stay up and transform into a ai (not walking or running but stays into place)

- confirmed blurry vision after respawn

-confirmed doesn't save logout position after restart

Edited by HAM
3 people like this

Share this post


Link to post
Share on other sites

There will be nothing saved in the database. (Loot )

I have tested this on a new server.

Edited by HerbertWitze
1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now