TheChimpa

Certain buildings not spawning loot

7 posts in this topic

I've got a few buildings which are just refusing to spawn any loot at all. I've tried setting custom loot positions multiple times but still nothing. 

class Land_i_Barracks_V2_F //Arma 3 Two Floor White Barrack Building
	{
	table = "Military";
	positions[] = {{-2.12964, -4.15744, 0.603854}, {-13.1091, 0.0480347, 0.604078}, {-13, -3.82288, 0.604078}, {-7.80615, -1.83435, 0.604078}, {-7.4751, 4.09418, 0.604078}, {-12.6719, 2.12802, 0.604078}, {-5.92358, 1.89844, 0.604078}, {0.759766, 4.06613, 0.604078}, {0.618164, -2.07785, 2.1672}, {2.8252, -3.81564, 0.604078}, {7.01782, -1.97974, 0.604078}, {9.4978, -2.10663, 0.604078}, {13.8123, -3.78571, 0.604078}, {11.5718, 0.678192, 0.604078}, {13.624, 2.00946, 0.604078}, {9.05664, 1.94559, 0.604078}, {14.0996, 4.18118, 0.604078}, {2.74756, 1.80109, 0.604078}, {7.51831, 3.95557, 0.604078}, {1.85669, 0.863007, 0.604077}, {-2.21948, -5.05673, 3.93762}, {-5.18726, -5.04404, 3.93799}, {-12.9617, 0.0721436, 3.93806}, {-12.6077, -3.83548, 3.93806}, {-7.86353, -1.83939, 3.93806}, {-12.8923, 2.08969, 3.93806}, {-7.73901, 3.9169, 3.93806}, {-5.5354, 2.10782, 3.93806}, {0.519775, 4.06744, 3.93806}, {7.41895, 3.88892, 3.93806}, {2.82666, 1.87155, 3.93806}, {2.85645, -3.87207, 3.93806}, {7.6311, -1.70154, 3.93806}, {13.5767, -3.93118, 3.93806}, {9.42358, -1.98175, 3.93806}, {14.0361, 4.15518, 3.93806}, {13.9761, 1.80045, 3.93806}, {-4.44946, 0.750031, 3.93806}, {1.62427, -0.652435, 3.93806}, {8.43286, -0.570587, 3.93806}, {15.7185, 2.7135, 3.85224}, {12.501, 5.57809, 3.85243}, {7.19922, 5.66702, 3.85243}, {-0.362305, 5.69623, 3.85243}, {-10.0212, 5.68454, 3.85243}};
	};
class CampEast // CUP A2 Green Military Tents
	{
	table = "Military";
	positions[] = {{-1.78931, 2.30566, -1.35192}, {2.26367, 2.60498, -1.35193}, {2.13477, -3.35156, -1.35195}, {-2.00806, -2.604, -1.31192}, {0.00830078, 0.154785, -1.35192}};
	};
class Land_Airport_Tower_F //A3 Large White Air Control Tower 
	{
	table = "Military";
	positions[] = {{-0.776367, 6.59213, -10.4429}, {-1.59595, 2.09497, -10.4429}, {-0.763916, 6.99792, -8.94289}, {0.421143, 1.94247, -7.44272}, {-1.74194, 1.7189, -7.44272}, {-1.31689, 6.76617, -5.94224}, {0.508057, 1.75891, -4.44207}, {-1.75513, 1.51953, -4.44207}, {-0.916504, 7.05548, -2.94257}, {0.482666, 2.04871, -1.4424}, {-1.3418, 2.10321, -1.4424}, {1.61987, -5.04825, -1.4427}, {-2.51807, -0.764099, -1.44223}, {-2.32471, -4.84381, -1.44307}, {1.62012, -0.467468, -1.44221}, {1.05933, -0.425049, 2.25485}, {1.84009, -5.57983, 3.0289}, {-3.09204, -5.39615, 3.0289}, {-2.44238, -2.56146, 2.25477}, {-0.390137, 5.74396, 1.5532}};
	};

All these buildings have been custom placed as I'm using Chernarus as my map. Also on a side note I've noticed these buildings don't seem to take damage at all their windows don't break at all. At first I thought it was because they weren't spawning properly on the server but they're set exactly the same as the rest 

Example:

_objects =
[
	["Land_Airport_Tower_F",[4822.22,9888.67,339],[[-0.892174,-0.451691,0],[0,0,1]],true]
];

{
    private ["_object"];

    _object = (_x select 0) createVehicle [0,0,0];
    _object setPosASL (_x select 1);
	_object setVectorDirAndUp (_x select 2);
    _object allowDamage (_x select 3);
    _object enableSimulationGlobal (_x select 3);
}
forEach _objects;

If anyone has got any idea's I'd appretiate the help

Edited by TheChimpa

Share this post


Link to post
Share on other sites

Nevermind was being completely thick. Was an issue with Extended base building, would help if I read instructions correctly

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Bump.
Would realy love an answer to this. Been searching for the last hours to fix compatibility between Extended Base Mod and Taunus.
Taunus uses 4 different hangars for just the 2 types of hangers at the airfields. 2 of these are also used in base mod.
Safe for the barracks.

Loot is not spawning in just these specific buildings, the rest works fine.
Tried changing the loot positions manually, works for all the buildings instead of the base mod buildings.

Share this post


Link to post
Share on other sites

Ugh... nevermind.
EBM Comes with a replacement for the exileclient_system_lootmanager_thread_spawn.sqf
Add it to your mission file. Add a custom overwrite to your config.cpp (in the mission file) and your done.

(Makes sure it detects all "buildings" instead of just "houses")

1 person likes this

Share this post


Link to post
Share on other sites

NEED HELP !! I hate to open an old thread . Okay guys and gals i have some questions and am in dire need of help . I have an Exile Chernarus server that i have successfully uploaded my own custom array of buildings PVP areas with the use of 3den editor ...................... I want to know how to make loot spawn in the buildings and areas i have brought into my server . I'm a Noob at Scripting but i get the basic concept . A step by step process that works well would be nice . This is an example of the buildings I've placed around the map "Land_Mil_Barracks_i_EP1"

Share this post


Link to post
Share on other sites

Posted (edited)

I'm also having same issue with Malden 3 buildings.. Land_Mil_Barracks_i_EP1 is my main issue. I got loot in the rest just not that building and 3 others.

 

Edited by Poptart4050

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.