shootex20

[SOLVED] Database not saving right

26 posts in this topic

!!!!UPDATE!!!! Solved by removing Exile occupation addon, thank you all so much.

 

So I'm no SQL expert. But I'm having problems my database yesterday decided it was no longer gonna save. Anyone who buys a car from the trader and move it to go loot etc.

When the reboot hits (every 3 hours) gets pulled straight back to the trader. All the help I can get is appreciated this also happens when placing stuff in crates. But the player seems fine as long as they log out.

I've also tested this myself I used a heli put it half way across the map (cherno) and it got pulled back right after reboot. Lost all the inventory gained inside it as well.

All help appreciated in advance.

RPT: http://pastebin.com/z8HxjieW

EXT-2 Log : http://pastebin.com/j2SpY5Xx

Mods being used:

@Exile;

@CUP_Terrains_Core;

@CUP_Terrains_Maps;

@Ryanzombies;

@CBA_A3;

@3cb_baf_equipment;

@BAF_Vehicles;

@BAF_Weapons;

@CUP_Vehicles;

@CUP_Weapons;

@CUP_Units;

@RZInfection;

@ExtendedbaseBuilding;

@CDAH;@RHSAFRF;

@RHSUSAF;

;@AdvancedRappelling;

@AdvancedTowing;

@AdvancedUrban;

 

Share this post


Link to post
Share on other sites

oh boy... a lot of errors... :( but i guess here is the problem:

9:01:08 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do
{
case 0:
{
(format>
 9:01:08   Error position: <_result select 0) do
{
case 0:
{
(format>
 9:01:08   Error Undefined variable in expression: _result
 9:01:08 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 16
 9:01:08 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
 9:01:08   Error position: <_vehicleClassName, _temporaryPositionInO>
 9:01:08   Error Undefined variable in expression: _vehicleclassname
 9:01:08 File mpmissions\__cur_mp.Chernarus\CDAH_crafting\logic\CDAH_ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 24
 9:01:08 Error in expression <ode = _this select 4;
_vehicleObject = [_className, _position, _direction, _useP>
 9:01:08   Error position: <_className, _position, _direction, _useP>
 9:01:08   Error Undefined variable in expression: _classname

 9:01:08 File exile_server\code\ExileServer_object_vehicle_createPersistentVehicle.sqf, line 18 

Are you sure, you installed our cdah mod right? just go through the install guide again and check everything. important: the description needs the following:

        class ExileServer_system_network_dispatchIncomingMessage { allowedTargets = 2; };
        class ExileClient_system_network_dispatchIncomingMessage      { allowedTargets=1; };
        class CDAH_fnc_CDAH_Workshop_Gui                              { allowedTargets=0; };

----------------

AND this is important (but not your problem right now, i think). but we forgot to mention it in the instruction:

put this to the buttom of your init.sqf (in mission.pbo):

private ['_code', '_function', '_file'];

{
    _code = '';
    _function = _x select 0;
    _file = _x select 1;

    if (isText (missionConfigFile >> 'CfgExileCustomCode' >> _function)) then
    {
        _file = getText (missionConfigFile >> 'CfgExileCustomCode' >> _function);
    };

    _code = compileFinal (preprocessFileLineNumbers _file);                    

    missionNamespace setVariable [_function, _code];
}
forEach 
[
	['CDAH_ExileClient_action_rearmVehicle_completed', 'CDAH_crafting\logic\CDAH_ExileClient_action_rearmVehicle_completed.sqf'],
	['CDAH_ExileClient_action_rearmVehicle_condition', 'CDAH_crafting\logic\CDAH_ExileClient_action_rearmVehicle_condition.sqf']
];

good luck!!!

cheers, yes

Share this post


Link to post
Share on other sites
Advertisement
17 hours ago, yesyesjo said:

oh boy... a lot of errors... :( but i guess here is the problem:


9:01:08 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do
{
case 0:
{
(format>
 9:01:08   Error position: <_result select 0) do
{
case 0:
{
(format>
 9:01:08   Error Undefined variable in expression: _result
 9:01:08 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 16
 9:01:08 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
 9:01:08   Error position: <_vehicleClassName, _temporaryPositionInO>
 9:01:08   Error Undefined variable in expression: _vehicleclassname
 9:01:08 File mpmissions\__cur_mp.Chernarus\CDAH_crafting\logic\CDAH_ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 24
 9:01:08 Error in expression <ode = _this select 4;
_vehicleObject = [_className, _position, _direction, _useP>
 9:01:08   Error position: <_className, _position, _direction, _useP>
 9:01:08   Error Undefined variable in expression: _classname

 9:01:08 File exile_server\code\ExileServer_object_vehicle_createPersistentVehicle.sqf, line 18 

Are you sure, you installed our cdah mod right? just go through the install guide again and check everything. important: the description needs the following:

        class ExileServer_system_network_dispatchIncomingMessage { allowedTargets = 2; };
        class ExileClient_system_network_dispatchIncomingMessage      { allowedTargets=1; };
        class CDAH_fnc_CDAH_Workshop_Gui                              { allowedTargets=0; };

----------------

AND this is important (but not your problem right now, i think). but we forgot to mention it in the instruction:

put this to the buttom of your init.sqf (in mission.pbo):


private ['_code', '_function', '_file'];

{
    _code = '';
    _function = _x select 0;
    _file = _x select 1;

    if (isText (missionConfigFile >> 'CfgExileCustomCode' >> _function)) then
    {
        _file = getText (missionConfigFile >> 'CfgExileCustomCode' >> _function);
    };

    _code = compileFinal (preprocessFileLineNumbers _file);                    

    missionNamespace setVariable [_function, _code];
}
forEach 
[
	['CDAH_ExileClient_action_rearmVehicle_completed', 'CDAH_crafting\logic\CDAH_ExileClient_action_rearmVehicle_completed.sqf'],
	['CDAH_ExileClient_action_rearmVehicle_condition', 'CDAH_crafting\logic\CDAH_ExileClient_action_rearmVehicle_condition.sqf']
];

good luck!!!

cheers, yes

Just doubled checked CDAH everything seems good, I'll try and disable and see if that fixes problems. & I did add in the rearm like you told me to works great by the way :) Thanks.

Just a side note the problem occoured a two - three days after I installed CDAH.

Just in case heres my mission config, and my cfg exec file.

Config: http://pastebin.com/4CDKBf2T

CfgRemoteExec: http://pastebin.com/K3kuadjM

 

Also thanks for taking the time to respond, I did not see the error.

 

Edited by shootex20
adding extras

Share this post


Link to post
Share on other sites

Error still continuing even with CDAH disabled. Unsure what's going on at this point.

Share this post


Link to post
Share on other sites

May have found the problem. Damn mountain bike seems to of been causing problems. Typed 6965 in the db and found a mountain bike, deleted it don't see an error quite yet

1 person likes this

Share this post


Link to post
Share on other sites

ahhhh i remember! bikes dont have a container etc, so you cannot put them in the crafting code, because the database/exile dont like this... hehe... that must be your problem... i am glad you found it. i totally forgot that. :swear:

 

 

Edited by yesyesjo

Share this post


Link to post
Share on other sites
4 hours ago, shootex20 said:

May have found the problem. Damn mountain bike seems to of been causing problems. Typed 6965 in the db and found a mountain bike, deleted it don't see an error quite yet

is it now saving right?

Share this post


Link to post
Share on other sites
2 hours ago, yesyesjo said:

is it now saving right?

It was working, and then it stopped again. Getting annoying at this point 3 days now it's been doing this still cannot find a fix and talking with providers atm.

Will get a more recent RPT

Edited by shootex20
Typos

Share this post


Link to post
Share on other sites

hmmmm :(

config looks fine. but why so less in the description?

i am missing this:

        //Advanced Towing
        class SA_Simulate_Towing             { allowedTargets=0; };
        class SA_Attach_Tow_Ropes             { allowedTargets=0; };
        class SA_Take_Tow_Ropes             { allowedTargets=0; };
        class SA_Put_Away_Tow_Ropes         { allowedTargets=0; };
        class SA_Pickup_Tow_Ropes             { allowedTargets=0; };
        class SA_Drop_Tow_Ropes              { allowedTargets=0; };
        class SA_Set_Owner                     { allowedTargets=2; };
        class SA_Hint                          { allowedTargets=1; };
        class SA_Hide_Object_Global          { allowedTargets=2; };

        //Advanced Rapelling
        class AR_Client_Rappel_From_Heli { allowedTargets=0; };
        class AR_Hint { allowedTargets=1; };
        class AR_Hide_Object_Global { allowedTargets=2; };
        class AR_Enable_Rappelling_Animation { allowedTargets=2; };
        class AR_Rappel_From_Heli { allowedTargets=2; };

and i am not so firm with infistar. you "whitelistet" everything from our mod there?

Share this post


Link to post
Share on other sites

aaaaand by the way... i suggest you get rid of some mods/addons... in my opinion its way to much ;)

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.