sCorporation

Vehicles stehen falsch (DB Problem)

8 posts in this topic

Wir haben ein großes Problem und ich glaube das liegt an unserer Datenbank. Wir haben und auch andere Teams das Problem, dass Autos manchmal bei nem Neustart des Servers die vor über 2 Std gekauft wurden wieder da stehen wo sie gekauft wurden oder andere ehemalige Positionen einnehmen, die aber wesentlich länger als 30 Minuten her waren. Wir selber hatten das Problem, dass wir nen Auto gekauft haben...dann gefahren sind....und es nach dem Neustart nicht mehr da war (als wenn wir es nicht gekauft hätten). Geld war aber weg

Wir bräuchten bitte dringend eine Lösung dafür woran das liegen könnte.
 

Vielen Dank

Share this post


Link to post
Share on other sites

Also so ein problem hatte ich dahmals auf dem nitrado server, das lag bei mir daran dass der server

a) die leistung nicht gebracht hatte die ich gefordert hatte :P 

b) der server allgemein mal "aussetzter" hatte in form von 0% prozessor Auslastung über mehrere minuten hinweg

c) Der halt aufgrund der belastung oder der aussetzer (keine ahung was dann dazu gefürht hat vllt ja auch beides) es zum serverabsturtz kam...

d) und in dem zeitraum hatte ich auch immer mal probleme mit dem was du jetzt hast was bei mir aber auch logisch und ersichtlich war denn wenn der prozessor nichts macht dann kann er auch keine fahrzeugbewegungen in der datenbank speichern :)

teilweise standen dann 5 fahrzeuge am trader ineinander geglicht weil es die position wieder zurück gesetzt hatte

 

ob das nun auch dein problem sein könnte keine ahnung, wenn du bei nitrado bist dann könnte ich mir das aber recht gut vorstellen^^

Edited by Powerstriker46

Share this post


Link to post
Share on other sites
Advertisement

Danke für deine Antwort. Es liegt tatsächlich an der auslastung und die fps des Servers. Waren zu viele ki drauf und das hat die Performance stark geschwächt. Ich würde mich gerne mal wissen welche Hardware der Server braucht um eben bei ein bisschen mehr ai durch zu halten und stabil zu laufen 

Edited by sCorporation

Share this post


Link to post
Share on other sites

Ich habe das:

  • 32GB DDR 4
  • Intel Core i7-6700K
  • Software-Raid 1
  • 2x 2TB SATA

Meine server :

Exile.HeX47.DE 

Share this post


Link to post
Share on other sites

Ist das ein Root?

Von welchem Anbieter?

Und wie ist die Auslastung so bei dir? Bei wieviel AI und/oder Player?

Share this post


Link to post
Share on other sites

also das was der kollege oben hat ist definitiv ein root server :)

 

also ich weis ja nicht ob du einen gameserver oder einen root hast

aber ich kann dir sagen das gameserver zwar ohne zweifel günstig sogar billig sind aber leider halt schnell überlastet... ich habe so ein ähnliches problem ich habe die ki nicht meinen wünschen angepasst sondern der serverleistung, das bedeutet wiederum 15 roaming fahrzeuge für die ganze karte, und noch extra 30 Ais die über die karte laufen... mehr geht nicht wenn 20 spieler halbwegs vernümpftig spielen wollen (PVE server)

wenn der server voll ist schafft er grade so noch durchschnittlich  20 FPS manchmal auch etwas weniger...

ich schaue mich auch schon nach einem root um, das problem ist nur dass man da 70 euro pro monat hin blätter und man zusätzlich noch eine windows server lizens braucht (um die 50 euro)

und ich werde umsteigen wenn die spieler die da drauf spielen was mit dazu geben...

denn auf einen root kannst du deutlich mehr KI platzieren (sogar mehrere Spiele über einen root laufen lassen)<-- aber ich denke wenn ich dann die KI einstelle dann ist auch der server voll ausgelastet darum habe ich das mal mit dem 2. server in einem in klammern geschrieben

Share this post


Link to post
Share on other sites

ja habe mich mit jemanden aus dem forum hier unterhalten der auch root server betrieben hat/betreibt

https://www.myloc.de/server-hosting/dedicated-server.html

 

und er hat gemeint dass der für 70 euro nicht schlecht sein soll und er ihn selbst eine zeit lang hatte

(also so einen ähnlichen) aber ehe ich das mache möchte ich auch ein paar spenden sehen, es haben mich schon etliche gefragt wenn ich die spendenseite endlich einrichte und gestern habe ichs dann mal gemacht... nun ja werde sehen was zusammen kommt ob es dann für so einen root reicht oder nicht entscheiden meine stamm spieler :)

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.