Brock5992

Building in Cities

11 posts in this topic

I just run a small server for me and some friends and we want to be able to build in the cities.  When I try to place a flag I get this:

I can't find a setting anywhere in the files to allow base building in cities.  Is there a setting I am missing?

Aborted.PNG

Share this post


Link to post
Share on other sites

its simple, the Constructions are forbidden in few citys with ExileNonConstrutionZones define inside the mission.sqm.

Share this post


Link to post
Share on other sites
Advertisement

So, if I just delete the  "ExileNonConstructionZones" I want then I should be able to build there?

Edit.

That worked.  Thanks.

Edited by Brock5992

Share this post


Link to post
Share on other sites
On 1/29/2017 at 5:23 PM, Sgt. ScrapMetal said:

its simple, the Constructions are forbidden in few citys with ExileNonConstrutionZones define inside the mission.sqm.

I'm assuming this ExileNonConstrutionZones is supposed to be inside of config.cpp in the mission file based on what I've been reading. I do not have it there and cannot find anything similar in the whole of config.cpp inside my mission file. Can anyone shed any light about that and why I'm still getting the same toast message as OP?

Share this post


Link to post
Share on other sites

Posted (edited)

It's not in the config.cpp.  It's in the mission.sqm file.

Edited by Brock5992
1 person likes this

Share this post


Link to post
Share on other sites
27 minutes ago, Brock5992 said:

It's not in the config.cpp.  It's in the mission.sqm file.

I was under the impression that only the editor interacts with a .sqm file. So how would I go about editing this specific problem ( ExileNonConstrutionZones) and/or opening it with some viewing program to edit? Unsure how to proceed, thanks for the heads up that it's in .sqm though. 

Share this post


Link to post
Share on other sites

You can either use something like Notepad++ and delete out the ExileNonContructionZones or you can go into the map editor and select the ExileNonContructionZones on the left side of the screen and delete them from within there if you only want to delete certain zones.

1 person likes this

Share this post


Link to post
Share on other sites
4 minutes ago, Brock5992 said:

You can either use something like Notepad++ and delete out the ExileNonContructionZones or you can go into the map editor and select the ExileNonContructionZones on the left side of the screen and delete them from within there if you only want to delete certain zones.

When I attempt to open it with notepad++ it loads this:

Untitled.png

When I attempt to open with Visual Studio it gives the error "the file will not be displayed in the editor because it is either binary, very large or uses an usupported text encoding".

Share this post


Link to post
Share on other sites

It saved in binary mode.  Use the map editor and "save as" and there should be a box to uncheck to not save in binary.  After that you can edit it with notepad++.

1 person likes this

Share this post


Link to post
Share on other sites
4 minutes ago, Brock5992 said:

It saved in binary mode.  Use the map editor and "save as" and there should be a box to uncheck to not save in binary.  After that you can edit it with notepad++.

Ah. I got ya. Now once this is saved as non-binary and edited, should I reload it in the editor and re-binarize it before uploading to my server? 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.