• 0
Sign in to follow this  
Followers 0
Bob_the_K

Issue with CUP_Terrains v1.3.0

Question

I'm running an Esseker server and recently upgraded CUP_Terrains to v1.3.0.  Now when I start the server, the console window is spammed with the "reading from bank" message and in my server.RPT, I'm getting lots of these:

12:10:00 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.cup_cwa_misc

But cup_cwa_misc is already in my addOns[] section in mission.sqm. 

What else could be missing?

 

Share this post


Link to post
Share on other sites

8 answers to this question

  • 1

If aboved proposed solution doesn't work. Comment the " //cup_cwa_misc " and load your mission in Eden. It will get rid of the addon and anything requiring it inside of your entities. Once it loads, just save it, and then repack and upload to your server.

comment.PNG

This is my mission.sqm addons. Don't add all of the things in here as I have other things loaded.

Edited by Super Jerome
1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Had the same issue, just removed the line from the mission.sqm, server started fine.

Share this post


Link to post
Share on other sites
  • 0

That worked!  Thanks!   I always thought that when downloadable content was deleted, it had to be added to addOns[] in order to be deleted.  I guess they took it out of cup_terrains altogether.

Share this post


Link to post
Share on other sites
  • 0

Yeah, it appears as though they removed an entire category of "extra stuff" with 1.3.0. I had to remove that component from my mission file too but I also discovered that I'd used it in heaps of my POI's for my Cherno server so I had to go through all my mission files for POI's and remove every removed component then re-number all the objects :(  was a bit of a time waster but only took a couple of hours in the end.

Exile handled it pretty nicely, it's only if you have the sqm file for a hand-built zone or something and want to edit it that it can become a little more annoying.

Share this post


Link to post
Share on other sites
  • 0

So on closer examination of my server.rpt,, I'm also seeing lots of these since the update:

 8:26:16 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted, mil

 Granted they're warnings and the server still starts, but what else do I need to remove so that msg doesn't appear?  There's no specific file, entity, or object in addOns[] that is just "mil".
 

 

Share this post


Link to post
Share on other sites
  • 0

I haven't tested this myself yet but it appears as though the CUP team released another mod that may include the stuff missing from our mission files.

https://steamcommunity.com/sharedfiles/filedetails/?id=853743366

Everything missing from CUP Terrains 1.3.0 for me was in the "CWA" category and that's clearly what that package is titled. Might be worth testing for those still having problems.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

I jumped on the CUP Discord and I found out the CWA and MBR stuff was moved to a seperate mod called CUP Terrains CWA. Although CUP Terrains Maps currently lists CWA as a dependency, it's not required and they are going to remove it as a dependency according to what they said on Discord.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.