bustednuts

Eden Trader Setup

2 posts in this topic

Houdy all. Kinda stumped here. I am trying to add waste dump traders to tanoa airfeilds . I have added signs and lockers but the traders refuse to work. I am placing the output that I am getting from the eden plugin 

Spoiler

private _traders = [
    ["Exile_Trader_WasteDump",[7201.02,6972.69,0.00143886],75.8089,"Exile_Trader_WasteDump","WhiteHead_14"],
    ["Exile_Trader_WasteDump",[11543,13179.4,0.00143909],0,"Exile_Trader_WasteDump","WhiteHead_10"],
    ["Exile_Trader_WasteDump",[2206.59,13410.7,0.00143909],141.171,"Exile_Trader_WasteDump","WhiteHead_15"],
    ["Exile_Trader_WasteDump",[2082.21,3443.39,0.00143909],348.209,"Exile_Trader_WasteDump","WhiteHead_18"],
    ["Exile_Trader_WasteDump",[11686.5,3044,0.00143862],38.5054,"Exile_Trader_WasteDump","WhiteHead_16"]
];
{
    private _trader = [
        _x select 0,
        _x select 4,
        ["HubStanding_idle1"],
        _x select 1,
        _x select 2
    ] call ExileClient_object_trader_create;
    _trader setVariable ["ExileTraderType", _x select 3];
} forEach _traders;

in the initplayerlocal and no dice.  The initplayerlocal looks different than what the output is so I am at a loss as why it's like this.  Any help would be awesome. Thanks and have a nice day!!!

 

Share this post


Link to post
Share on other sites
1 hour ago, bustednuts said:

Houdy all. Kinda stumped here. I am trying to add waste dump traders to tanoa airfeilds . I have added signs and lockers but the traders refuse to work. I am placing the output that I am getting from the eden plugin 

  Reveal hidden contents

private _traders = [
    ["Exile_Trader_WasteDump",[7201.02,6972.69,0.00143886],75.8089,"Exile_Trader_WasteDump","WhiteHead_14"],
    ["Exile_Trader_WasteDump",[11543,13179.4,0.00143909],0,"Exile_Trader_WasteDump","WhiteHead_10"],
    ["Exile_Trader_WasteDump",[2206.59,13410.7,0.00143909],141.171,"Exile_Trader_WasteDump","WhiteHead_15"],
    ["Exile_Trader_WasteDump",[2082.21,3443.39,0.00143909],348.209,"Exile_Trader_WasteDump","WhiteHead_18"],
    ["Exile_Trader_WasteDump",[11686.5,3044,0.00143862],38.5054,"Exile_Trader_WasteDump","WhiteHead_16"]
];
{
    private _trader = [
        _x select 0,
        _x select 4,
        ["HubStanding_idle1"],
        _x select 1,
        _x select 2
    ] call ExileClient_object_trader_create;
    _trader setVariable ["ExileTraderType", _x select 3];
} forEach _traders;

in the initplayerlocal and no dice.  The initplayerlocal looks different than what the output is so I am at a loss as why it's like this.  Any help would be awesome. Thanks and have a nice day!!!

 

Wrong format. Download the Exile plugin for the 3DEN editor, place the plugin into your Exile files, load the game up and now extract your trader NPC information. Place it in the initPlayerLocal.sqf file and you are good to go.

It should look something like this:

["Exile_Trader_Vehicle", [], "Exile_Trader_Vehicle", "WhiteHead_20", [[],[],[],["Exile_Uniform_ExileCustoms",[]],[],[],"H_RacingHelmet_4_F","G_Combat",[],["","","","","",""]], [6254.93, 7850.65, 305.294], [0.309344, -0.95095, 0], [0, 0, 1]],

Click HERE to download the plugin, or go to downloads and look for 3DEN Plugin. 

You will have to remove the plugin from your Exile mod before you can play on a Server FYI.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.