Sign in to follow this  
Followers 0
lt.larry

[SOLVED] infiStar PW problem

6 posts in this topic

I'm running into troubles when trying to install infistar on my server which is running on win7 pc. The server starts up nicely and I'm able to join but I don't get the announcement of infistar and F1 doesn't open the tool menu.

This is the error on the log file

infistar
"<infiSTAR.de> 0 - TESTING IF serverCommandPassword IS SET PROPERLY"
"<infiSTAR.de> 0 - serverCommandPassword NOT SET!   [xxx@xxx.com - 19-Feb-2017 12-00-32 - v0072 - test69 - [""Arma 3"",""Arma3"",166,139586,""Stable"",true,""Windows""]]"
"<infiSTAR.de> 0 - serverCommandPassword   in EXILE_AHAT_CONFIG.hpp is salasana"
"<infiSTAR.de> 0 - serverCommandPassword   is defined in your servers config.cfg"
"<infiSTAR.de> 0 - serverCommandPassword   has to be set it in EXILE_AHAT_CONFIG.hpp where it says serverCommandPassword = ""changeme"";"
"<infiSTAR.de> 0 - infiSTAR will NOT START if passwords are not set properly!"

Here are some key parts of the script files to show where I have typed the serverCommandPassword. I have followed every step in the process but looks like I still can't get the passwords in the correct locations.

ARMA3/@ExileServer/config.cfg

password = "varitelevisio";
passwordAdmin = "televisiovari";
serverCommandPassword = "salasana";

ARMA3/MPMissions/Exile.Altis/description.ext

#include "config.cpp"
#include "infiSTAR_AdminMenu.hpp"
#include "CfgRemoteExec.hpp"

ARMA3/@ExileServer/addons/exile_server_config.pbo/config.cpp

class RCON
{
    /*
    Note that for this to work you need to have serverCommandPassowrd defined in config.cfg and BE enabled
    */

    // This needs to match config.cfg serverCommandPassword
    serverPassword = "salasana";

 

EXILE_AHAT_CONFIG.hpp

class Cfg_infiSTAR_settings {
/*
    "serverCommandPassword" is serverCommandPassword - in your servers config.cfg
    if your config.cfg does not have serverCommandPassword yet, simply add it in a new line:
    serverCommandPassword = "changeme";
    
    This is   VERY IMPORTANT   as it is needed to KICK & BAN people.
    
    It will try to get this password from "@ExileServer\addons\exile_server_config" first. If you did not set a password there (config.cpp),
    then it will take what you put here.
*/
serverCommandPassword = "salasana";

/*
    "passwordAdmin" is passwordAdmin - in your servers config.cfg, needed for servercommands from client
    
    This is used to be able to use the "login" function ingame. Will log you in as Arma "Admin".
*/
passwordAdmin = "televisiovari";
/* serverCommandPassword and passwordAdmin should always be different passwords or it could cause problems! */

TADST LOG

hostName = "test69";
password = "varitelevisio";
passwordAdmin = "televisiovari";
serverCommandPassword = "";
logFile = "";

I wonder why the password is empty in TADST log file?

 

Edited by lt.larry
better of with out spoilers...

Share this post


Link to post
Share on other sites

After some more testing I've found out that even if I change the serverCommandPassword in EXILE_AHAT_CONFIG.hpp and in config.cfg it still shows the password ("<infiSTAR.de> 0 - serverCommandPassword   in EXILE_AHAT_CONFIG.hpp is salasana") I have set in the config.cpp under exile_server_config.pbo.

I've added the servercommandpassword to every single file I've possibly found without luck...

I will purchase the infistar XM8 tools immediately when someone helps me to solve this stupid problem. I'm sure the solution is simple but I just can't find it!

Share this post


Link to post
Share on other sites
Advertisement

Hey

your problem seems so strange, like you have several config files. Maybe your TADST (never used that program) is using a config file from a different location.

Just set a server Password in the .cfg you think is the correct one, boot your server and see if it got the password or not.
If it has the password, then you know it's the right server.cfg file.

Now stop the server and open the cfg file again, if it does not have the line, add the line:
serverCommandPassword                = "salasana";
(not passwordAdmin                          = "salasana";)

else just set it to that value.

Now please go to your infiSTAR pbo, unpack it again and open the EXILE_AHAT_CONFIG.hpp


 

class Cfg_infiSTAR_settings {
/*
	"serverCommandPassword" is serverCommandPassword - in your servers config.cfg
	if your config.cfg does not have serverCommandPassword yet, simply add it in a new line:
	serverCommandPassword = "changeme";
	
	This is   VERY IMPORTANT   as it is needed to KICK & BAN people.
	
	It will try to get this password from "@ExileServer\addons\exile_server_config" first. If you did not set a password there (config.cpp),
	then it will take what you put here.
*/
serverCommandPassword = "changeme";

and where it says changeme (I guess you know that)

you put 
serverCommandPassword = "salasana";

too!

save the file, close the file. Go one folder back and make the whole "a3_infiSTAR_Exile" folder a pbo again.

The location of the pbo should be.
Arma3server\@ExileServer\addons\a3_infiSTAR_Exile.pbo

that way you don't need to change your -serverMod parameter as it will simply start with @ExileServer 

 

Share this post


Link to post
Share on other sites

Thanks for the swift reply! Like I assumed, I was being an idiot and couldn't find the correct location for serverCommandPassword.

TADST allows you to quickly select some basic settings for your server and then it creates a config file for the server. In the first tab of TADST I typed server pw and admin pw. The serverCommandPassword has to be inserted in the last tab of TADST interface... There is a text box and it even says "insert serverCommandPassword". Maybe, just maybe, the service won't start if you "forget" to insert the password there...

Everything works smoothly now! Thanks for your great work and I just bought the xm8 apps too!

I should maybe do a quick guide for TADST basic set up so that others could avoid stepping in the same mines as I did. I'm not even going to tell how many hours I added and deleted passwords in the server files...

Share this post


Link to post
Share on other sites

We have closed this thread and marked it as solved.

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.