aussie battler

Custom DMS bandit missions: not found in the operative map

12 posts in this topic

Hi

I am having trouble adding custom objects to DMS missions.

I get the error:

House not found in the list

House 67682400# 1060022: mil_hangar_ep1.p3d (to) not found in the operative map


To get rid of the error I replace the object with another one & hope for no errors. In turn this error causes problems with DMS not being able to clean up mission objects & the make become a mess with dead mission before restart.

Can I add the class name to the addons section in my mission.sqm to remove the problem?

cheers

 

 

Edited by aussie battler

Share this post


Link to post
Share on other sites
Advertisement

Hey @tinboye

thanks for the reply. I'm using Cup.

Maybe I can only use cup buildings in Ai missions?

Edited by aussie battler

Share this post


Link to post
Share on other sites

no, you just need to add the right class names into your mission.sqm, try adding

"mil" into your

addons[]=
{

section of your mission.sqm see if that works.

Share this post


Link to post
Share on other sites

Thanks for your reply @tinboye

I added the objects to addonsAuto[ ]= , but that didn't work. I think I'm calling  it wrong.

Spoiler

    addOnsAuto[]=
    {
        "exile_client",
        "cup_chernarus_config",
        "unfinished_building_02_f.p3d",
        "slum_03_f.p3d",
        "cargo_tower_v4_f.p3d",
        "cargo_house_v2_f.p3d",
        "medevac_hq_v1_f.p3d",
        "hangar_2.p3d",
        "indpipe1_stair.p3d",
        "ind_sawmill.p3d",
        "bagbunker_01_small_green_f.p3d",
        "i_stone_shed_v3_f.p3d",
        "stan_east.p3d",
        "bagbunker_01_large_green_f.p3d",
        "barracks_01_dilapidated_f.p3d",
        "stan_east.p3d",
        "CUP_Core"
    };

 

I have seen that other people call this in their addons, im just not sure what classes each object belongs to...

 

Spoiler

addOns[]=
    {
        "exile_client",
        "cup_chernarus_config",
        "CUP_CAStructures_Castle",
        "CUP_Misc3_Config",
        "A3_Structures_F_Civ_Garbage",
         "CUP_Core"        
    };

Thanks for the heads up, i'll dig deep into it.

Edited by aussie battler

Share this post


Link to post
Share on other sites

Sometimes by just adding cup_core will be enough.  or once you add 1. Then rpt will say you need to add another. It will give the warning about cannot play/edit...addon will be deleted... then say the class name in quotations.   there will always be A3_character_f  showing as an error. That's something on arm's side

Share this post


Link to post
Share on other sites

@red_ned also helped me in the right direction:

6 minutes ago, red_ned said:

you can just replace the cargo_hq with ->

Land_Cargo_House_V4_F

there were a few object name changes while I have been away which I just started to push into my files.

the stock Arma objects can be found : https://community.bistudio.com/wiki/Arma_3_CfgVehicles_EMPTY

Also remember you need to make sure if using Linux server that the names are case sensitive

 

Share this post


Link to post
Share on other sites

if objects show up but rpt shows error when loading the server then it is a case of listing mods in the mission.sqm file, mine looked like this:

Spoiler

class Mission
{
 addOns[]=
 {
  "exile_client",
  "a3_map_altis",
  "hlcweapons_ar15",
  "hlcweapons_falpocalypse",
  "hlcweapons_fhawcovert",
  "hlcweapons_g3",
  "hlcweapons_mp5",
  "mas_brdm",
  "mas_cars_hilux",
  "mas_cars_lr",
  "mas_ch47",
  "mas_hmmwv",
  "mas_mi24",
  "mas_uh60m",
  "mas_ural",
  "mas_weapons",
  "mas_weapons_m4",
  "mas_weapons_pack",
  "rhs_c_a2port_air",
  "rhs_c_a2port_car",
  "rhs_c_a3retex",
  "rhs_c_air",
  "rhs_c_btr",
  "rhs_c_cars",
  "rhs_c_troops",
  "rhs_c_trucks",
  "rhs_us_a2_airimport",
  "rhsusf_c_airweapons",
  "rhsusf_c_fmtv",
  "rhsusf_c_heavyweapons",
  "rhsusf_c_m109",
  "rhsusf_c_rg33",
  "rhsusf_c_troops",
  "rhsusf_c_weapons",
  "rhsusf_vehicles",
  "uh1h"
 };
 addOnsAuto[]=
 {
  "exile_client",
  "a3_map_altis"
 };

I kept adding things until it stopped nagging, this list will force mods to be installed on a client before they can join

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.