Honeybee

Weird Server Error

13 posts in this topic

Hey guys working on installing my Exile Server I think everything works except I keep getting this error! Its weird 

 

RPT Of Error:

"ExileServer - Starting session for '[RN] Johnny Honeybee' with ID 'OxQYqlOU'..."
"ExileServer - Dispatching hasPlayerRequest for session 'OxQYqlOU'..."
Error in expression <llExtension _query);
(_result select 1) select 0>
  Error position: <select 0>
  Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
Error in expression <llExtension _query);
(_result select 1) select 0>
  Error position: <select 0>
  Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16

 

Here is the file that its calling the error on "ExileServer_system_database_query_instertSingle.sqf" 

/**
 * ExileServer_system_database_query_insertSingle
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_parameters","_query","_result"];
_parameters = _this;
_query = [0, ExileServerDatabaseSessionId, _parameters] joinString ":";
_result = call compile ("extDB2" callExtension _query);
(_result select 1) select 0

 

 

Some more info: 

 

This error is getting thrown whenever I actually click on the Spawn menu and hit the "Spawn" Button. ExtDB and everything is connect just fine according to RPT. 

 

Any help would be great! 

Share this post


Link to post
Share on other sites

Did  you add the infistar db into your db and add to exile.ini?

Share this post


Link to post
Share on other sites
Advertisement
9 hours ago, tinboye said:

Did  you add the infistar db into your db and add to exile.ini?

I have not yet installed infistart I was trying to launch it just to see if everything is working fine.

Share this post


Link to post
Share on other sites

Oh i got ya, the spawn menu as in when you first start playing.  not that your spawning items onto the map via infistar.  i seem to recall this error on servers as well, but it did not effect the gameplay at all.

Share this post


Link to post
Share on other sites
4 minutes ago, tinboye said:

Oh i got ya, the spawn menu as in when you first start playing.  not that your spawning items onto the map via infistar.  i seem to recall this error on servers as well, but it did not effect the gameplay at all.

The error is not allowing me to spawn it goes to "Requesting Bambi Character..." then disconnects me from the server. Because it cannot spawn the Bambi Character when it requests it. 

Share this post


Link to post
Share on other sites

your mising something then, go back over your exile.ini, make sure that in your sql DB that its not restricted

check both config.cpp within mission and serverside.

Share this post


Link to post
Share on other sites
9 minutes ago, tinboye said:

your mising something then, go back over your exile.ini, make sure that in your sql DB that its not restricted

check both config.cpp within mission and serverside.

So its not an error on Line 16 within the file like it says?

Share this post


Link to post
Share on other sites
6 minutes ago, tinboye said:

nope

There are 0 DB errors it connects perfectly fine though?

"ExileServer - Installed extDB2 version: 70"
"ExileServer - Connected to database!"
"ExileServer - Database protocol initialized!"
"Exile/BIS_fnc_log: [preInit] ExileServer_fnc_preInit (202 ms)"
Connected to Steam servers
"Exile/BIS_fnc_log: [script] initServer.sqf"

 

Share this post


Link to post
Share on other sites

go into your extdb folder and looked through the latest logs to make sure there is no error?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.