Remoz

Game load but stuck before spawn selection

23 posts in this topic

Hi all exilemod team :-)

I'm a newbie on server admin of Arma 3 and Exile, but i have setup a cloud machine with all the necessary, following the sweet potato guide.

At this moment the server start normally without errors, i see it from Arma 3 server browser (added by direct IP), when i (player) try to join, arma load completely but stuck into the view (see attached png) before spawn location selection.

The Server console messages are the following:


7:40:43 Dedicated host created.
 7:40:51 BattlEye Server: Initialized (v1.215)
 7:40:51 Host identity created.
 7:40:51 Game Port: 2302, Steam Query Port: 2303
 7:40:52 Mission Exile.Altis read from bank.
 7:40:52 Roles assigned.
 7:40:52 Reading mission ...
 7:41:14 Mission read.
 7:41:14 Game started.
 7:41:39 Remoz uses modified data file
 7:41:39 BattlEye Server: Player #0 Remoz (XX.XXX.XX.XXX:5550) connected
 7:41:39 Player Remoz connecting.
 7:41:41 BattlEye Server: Player #0 Remoz - GUID: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 7:41:41 Player Remoz connected (id=XXXXXXXXXXXXXXXXX).
 7:41:41 BattlEye Server: Verified GUID (XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX) of player #0 Remoz

Where i've broken? :-)

 

P.S. (into the mysql database i see all exile's tables empty, i've checked the db connection and seems to be good, anche my.ini modified)

 

Many many thanks,

bye bye

 

Remoz

ArmA_3_03_05.2017_-_13_42_30_03.png

Share this post


Link to post
Share on other sites

Either your DB doesn't have Strict Mode disabled, or you've got a mod that is breaking your spawning.

Share this post


Link to post
Share on other sites
Advertisement
45 minutes ago, kuplion said:

Either your DB doesn't have Strict Mode disabled, or you've got a mod that is breaking your spawning.

I'm sure strict mode is disabled, check attached my.ini file please :-(

What do you mean for "or you've got a mod that is breaking your spawning"? I've downloaded both client and server exile 1.0.2 directly from exilemod.com and used these zip files.

In meantime i've uninstalled completely my mysql server instance, deleted folders, reinstalled freshly following the "EXILE SERVER INSTALLATION GUIDE V1.0.1.pdf" instructions, but i'm at the same point :-(

Help me, please!

Remoz

Cattura.PNG

Share this post


Link to post
Share on other sites

What version of MySQL are you running?

Do you have any custom scripts/changes to your server/mission files? Are you using CBA?

Share this post


Link to post
Share on other sites
4 minutes ago, kuplion said:

What version of MySQL are you running?

Do you have any custom scripts/changes to your server/mission files? Are you using CBA?

Hello,

i've tried the version bundled with the potato's guide (5.7.11: http://www.exilemod.com/topic/17829-guide-server-installupgrade-guide-101-sweet-potato/) and the latest from mysql official site (5.7.17), full installation, default TCP port 3306.

I'm on Windows Server 2012 R2, maybe this is a problem?

No custom script, i'm in my first fresh installation.

What's CBA? :-)

 

Many thanks for support!

Remoz

Share this post


Link to post
Share on other sites
10 minutes ago, Remoz said:

Hello,

i've tried the version bundled with the potato's guide (5.7.11: http://www.exilemod.com/topic/17829-guide-server-installupgrade-guide-101-sweet-potato/) and the latest from mysql official site (5.7.17), full installation, default TCP port 3306.

I'm on Windows Server 2012 R2, maybe this is a problem?

No custom script, i'm in my first fresh installation.

What's CBA? :-)

 

Many thanks for support!

Remoz

Ok that's a compatible MySQL version. :)

CBA is an addon that is required by certain other addons. What addons are you running, or is it literally pure Exile (Altis/Tanoa/Namalsk)?

Share this post


Link to post
Share on other sites
3 minutes ago, kuplion said:

Ok that's a compatible MySQL version. :)

CBA is an addon that is required by certain other addons. What addons are you running, or is it literally pure Exile (Altis/Tanoa/Namalsk)?

Only Pure Exile: i'm started from scratch yesterday, i'm trying to setup a stock exile server for now, after maybe i try to customize it, but not too :-)

Look the attached image for screen of my stock Arma3Server folder...

If you want, i can give you RDP access to this machine, is a Cloud VM, if you wanna see my mistakes :-D

Many thanks,

Remoz

Capture.PNG

Share this post


Link to post
Share on other sites

In the SC folder, there should be an .RPT file. Can you upload the most recent one to Pastebin and share the link here?

Share this post


Link to post
Share on other sites
16 minutes ago, kuplion said:

In the SC folder, there should be an .RPT file. Can you upload the most recent one to Pastebin and share the link here?

Yes, i checked it just right now and i see this:

10:42:43 "ExileServer - MySQL connection error!"
10:42:43 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."

Extract from .rpt file (if you want the entire version are 17MB :-) ): http://pastebin.com/yCFCBwj5

but in /extDB/ i don't have a logs folder, where can be the mysql connection logs?

 

Thanks,

bye

Remoz

Share this post


Link to post
Share on other sites
19 minutes ago, Remoz said:

Yes, i checked it just right now and i see this:

10:42:43 "ExileServer - MySQL connection error!"
10:42:43 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."

Extract from .rpt file (if you want the entire version are 17MB :-) ): http://pastebin.com/yCFCBwj5

but in /extDB/ i don't have a logs folder, where can be the mysql connection logs?

 

Thanks,

bye

Remoz

Do you have extDB2.dll in your @ExileServer folder? Have you added your database settings to extdb-conf.ini (also in @ExileServer) ?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.