Beowulfv

say3D sounds

3 posts in this topic

I'm having an odd problem with executing the sound file when using the say3D command. If I use playsound it plays the sound file, but that's only for local and not for other players to hear. I try to execute with say3D and I get no sound. This should be easy, but I might be missing something that Exile requires me to do.

Examples of what I have:
description
 

class CfgSounds
{
    sounds[] = {mySound};
    class mySound
    {
        name = "mySound";
        sound[] = {"\sounds\mySound.ogg", 1, 1};
        titles[] = {};
    };
};

Function.sqf

player say3D "mySound";

 

Share this post


Link to post
Share on other sites

in your rpt are you getting any kind of error about being allowed to use that command?

I know for example with sm_zombz you have to add

class SM_Say3D { allowedTargets = 1; };

to the cfgremoteexec section of the mission file.

so maybe

class mySound { allowedTargets = 1; };

https://community.bistudio.com/wiki/CfgRemoteExec

Edited by tinboye

Share this post


Link to post
Share on other sites

Not getting any errors in RPT before or after I execute the script. I tried using 0, 1, and 2 for allowed targets.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.