• 0
Reditz86

Occupation places: Roaming Ai not spawning in cites/towns

Question

Hi everyone,

I recently set up an exile server about a week and a half ago with added mods of Ryan's Zombies and Demons + ExileZ (for zombie spawns). I also have DMS, Exile Occupation and infiSTAR installed too. Everything is running pretty smoothly but i seem to have the problem of having the roaming ai never spawn in any of the major/most common cites/towns on the Altis map. They do spawn however in random very tiny villages with maybe one or two buildings max way out of the way of any major city or town. I'm looking at having them spawn in major towns/cities with zombies and having them fighting the zombies and players alike if thats possible. I was just curious if it has something to do with my zombie spawn triggers as i'm using just the default trigger set ups in ExileZ or if its my max ai count which i have increased to no affect or maybe i'm looking about this all the wrong way. If this is linked else where please help direct me as i have had a look at various forums for an answer but it could just be blind lol. I do appreciate any help or advice that is given as i'm still new and learning about all this.

Cheers

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Make sure the max AI count in both Occupation and DMS Missions are increased. I believe the amount of AI that spawn also depends on the number of players connected to the server, as this rule also applies to missions. 

There is also a setting in Occupation to have AI spawn in certain locations (check this), up to you if you want to use this but i turn it off as i think its better to never know where AI are!

Check your min fps setting too in the config file as if your fps drops below a certain number, AI will not spawn. 

Ideally, disable your zombie mods and see what happens. If it works without them enabled, add them back in one by one to see which one is the culprit.

Edited by Johnny82

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Johnny82 said:

Make sure the max AI count in both Occupation and DMS Missions are increased. I believe the amount of AI that spawn also depends on the number of players connected to the server, as this rule also applies to missions. 

There is also a setting in Occupation to have AI spawn in certain locations (check this), up to you if you want to use this but i turn it off as i think its better to never know where AI are!

Check your min fps setting too in the config file as if your fps drops below a certain number, AI will not spawn. 

Ideally, disable your zombie mods and see what happens. If it works without them enabled, add them back in one by one to see which one is the culprit.

Hey Johnny 82

Thanks for the reply!

I had a look at some of the settings you suggested and increased my ai count up to something ridiculous like 400 then realized i was lucky if i was doing 150 or so ai in the server so i took it down to more like 200. I only have a small server but the more players there are the less ai in theory? 

I did finally have some ai spawn in the bigger towns and cities, only a few here and there but thats still good news! I also had a play around with that static spawn as u suggested and added a few ai into the main towns to make things more exciting.

Ive been regularly checking the servers fps and haven't seen it drop below the min fps which is 5 in my case. Everything seems to be working fine for the moment, i really do appreciate your advice, thanks for your help!

The only small problem if you can call it that is a lot of my static and roaming ai run around with pistols out instead of rifles (which are on their backs).. maybe a load out issue not sure.  

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Glad I could help :)

The AI running around with rifles on their back is weird alright. Are they in orange bambi suits? If they are then they are survivors that have just spawned and this is normal. If you shoot them you will loose respect and poptabs if not fired upon first. 

To make the AIs loadout vary more you would need to change their loadout in DMS & DMS Occupation config files. There is a section in each config file that is usually commented out with "//" that allows them to spawn with Apex/more advanced weapons etc. Remove these forward slashes to allow spawning with more advanced weapons etc. 

There should also be a section in the config file (lots of individual lines one after another) that allows you to change probabilities for AI to spawn with NV, Scopes, Suppressors etc. 

Hope this helps. Please vote/like the post if you found it helpful ;)

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Yea it was the bambies and a few of the bandit ai were at the start but that seems to have disappeared now

Awesome ill definitely give that a look, Thanks! :) 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.