.Doppelpoint

server performance 1.68

37 posts in this topic

Posted (edited)

Hi,

we are hosting a tanoa server with 30-50 players and had some question about the performance after arma 3  1.68 update.

before we updated to 1.68 we had a cpu usage of 90-100%, now is the arma3server.exe idling like 50-60% all the time with the same amount of players.

did somone else notice this issue or do somone know any fix for that issue?

 

some information:

•we didnt change any serverexile files (only the fix from eichi with the doors and the custombuildings).

•the server FPS is pretty bad, with 30players we have only 20 server FPS we had much more than 20 server FPS before we updated our server to 1.68

•AllMapMissionObjects Simulated: arround 10k (we had arround 9,5k before the 1.68 update)

•We also try the .exe dwarden performance binary (https://www.dropbox.com/sh/582opsto4mmr8d8/AABGmPFGJUK1a0ZmKi_4Tst7a/168perf/perf01?dl=0) but seems not help enough.

• i have notice that CPU 1 and CPU 3 and 7 didnt get high, on 1.66 we had all cores up to 100%/90% thats pretty strange.

•50-100 AI units without Headlessclient.

 

Startparameters:

"-mod=@Exile" "-serverMod=@ExileServer" -world=empty -nosplash -noSound -noPause -high -autoinit -enableHT

performanceissue.png

 

btw. its a dedicated server, windows server 2012 R2 (Arma3server 32bit)

regards

Edited by .Doppelpoint

Share this post


Link to post
Share on other sites

Having exact same problem. (between 10-70 players)

It's because the hotfix that Eichi provided. It bypasses the simulation manager, otherwise you can't open doors...

My CPU is also about 50-60% now, and FPS has dropped a lot...

Now I'm wondering, is there something we can do about this? Wait for Exile patch? 

Share this post


Link to post
Share on other sites
Advertisement

We're seeing performance losses of around 10% across our Arma 3 Exile, Epoch and KoTH servers since 1.68

Share this post


Link to post
Share on other sites

thanks for your replies,
i think we need to wait for a fix from Exile side and BI side.
hopefully they will fix the 10% performance loss.
did somone else had crashes with the 32bit arma3server.exe? (tested with dwarden binarys and without) RPT logs are clean, no errors.

Share this post


Link to post
Share on other sites

I used to be able to run Exile with 100 players for the first few months of it, then subsequent Arma patches have nerfed performance so have had to drop to 80, 70 and now 60. There won't be a magic update that fixes performance.

1 person likes this

Share this post


Link to post
Share on other sites
// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE

This was in the hotfix for doors. Can we expect performance increase with the next Exile update then...?

Share this post


Link to post
Share on other sites
9 hours ago, MGTDB said:

I used to be able to run Exile with 100 players for the first few months of it, then subsequent Arma patches have nerfed performance so have had to drop to 80, 70 and now 60. There won't be a magic update that fixes performance.

Imagine that. Bohemia managing to almost halve the performance in Exile's lifetime. Imagine the future! 

1 person likes this

Share this post


Link to post
Share on other sites

Two players on my Tanoa server. Server FPS = 16. So sad. Previously it would barely drop below 47 with 2 players on. I hope the Exile update addresses this issue.

1 person likes this

Share this post


Link to post
Share on other sites

 

1 hour ago, BetterDeadThanZed said:

Two players on my Tanoa server. Server FPS = 16. So sad. Previously it would barely drop below 47 with 2 players on. I hope the Exile update addresses this issue.

I know server performance dropped, but there's something really wrong if you don't have ~50 server FPS with only 2 players...

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.