• 0
TroyT

Ambient Flyover aircraft stuck

Question

We're having an issue where our AmbientFlyOver aircraft are getting stuck in mid-air.  I have it activated on out test server which never automatically restarts.  If I come back 8 hours after a manual restart there may be 10 of them just hanging out in mid-flight.  Many times, if you approach them, they will continue flying.  Many times they won't.  

I thought maybe it was a trigger issue, where when I look at the map with AI Markers on I can see them but maybe a player wouldn't see them and by the time they got into range the plane would continue.  I tried to approach normally but the results were the same.  I've used the stock aircraft in the config as well as other aircraft.

This was happening prior to the update.  I had disabled it a while ago and turned it back on yesterday to see if the update changed anything.  It didn't.

I (and my players) really like the effect of having them around and would like to keep them.

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Hello TroyT.

To my knowledge, this should not happen.  Without me digging thru the code, you CAN do this instead:

#1 - Do not use Exile's, rather create your own

#2 - Create a timed script which will delete airplanes/jets at a set time - Example:  Every 10 minutes, they are deleted.

 

Either will work for you!

 

Do keep this in mind, it should not be happening which indicates you have an issue somewhere:

Misconfigured/Corrupt/Missing Item In Exile

Misconfigured/Corrupt/Missing Item In Some Mod

ARMA/Exile/Mod 'clash'

 

 

Again, do note - These are two solutions to your problem without me examining the code!  They do not FIX the issue, rather, they HIDE THE ISSUE!

 

:)

 

Share this post


Link to post
Share on other sites
  • 0

I have this happening too, notice it started after the infiSTAR update, but that may be a case of 'post hoc ergo propter hoc'.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
On 26/03/2017 at 4:03 AM, doc0955 said:

I have this happening too, notice it started after the infiSTAR update, but that may be a case of 'post hoc ergo propter hoc'.

Hmmm, I mentioned this to infiSTAR except player vehicles were freezing mid-air but he said it's an ArmA issue. So i would bring this up with him because it only started happening for me after an infiSTAR update too.

Share this post


Link to post
Share on other sites
  • 0

what Sandmanuix said, DMS freezes AI if a player is not within a certain distance of them to save your FPS. You can increase or decrease this. In this instance try increasing the freezing distance or just set to '0' to disable i believe. Freezing should go away then.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.