malfunc

BattlEye RCON - can't connect

8 posts in this topic

I can't get BattlEye RCON to work. When I use DaRT/BCP and try to connect via RCON to my server, it keeps saying "connection failed". I've feel like I've tried everything with no luck.

When I try to connect using BPC/DaRT from local machine, I use these settings:

IP: 127.0.0.1
Port: 2309
Password: test123

And I get "Connection error".

This is my start.bat:

start "A3Exile" /high "arma3server_x64.exe" -config=config.cfg -cfg=basic.cfg -name=exile bepath="C:\Users\Administrator\Desktop\A3SERVER_TEST\battleye" -profiles=A3Profiles -world=empty -loadMissionToMemory -cpuCount=8 -maxMem=24000 -noSplash -noSound -noPause -enableHT -malloc=tbbmalloc -autoinit

and this is my BEserver.cfg (located in C:\Users\Administrator\Desktop\A3SERVER_TEST\battleye):

RConPassword test123
RConPort 2309

 

My console.log:

Spoiler

15:38:23 BattlEye Server: Initialized (v1.215)
15:38:23 Host identity created.
15:38:23 Game Port: 2302, Steam Query Port: 2303
15:38:24 Mission Exile.Chernarus read from bank.
15:38:24 Roles assigned.
15:38:24 Reading mission ...
15:38:34 Mission read.
15:38:45 Successfull attempt to execute serverCommand '#exec users' by server.
15:38:45 Successfull attempt to execute serverCommand '#exec users' by server.
15:38:45 Game started.
 

 

Windows Firewall is disabled.

What am I doing wrong?

Share this post


Link to post
Share on other sites

I did some more digging, and it seems that if I run the 32-bit version of arma3server.exe, RCON works fine. As soon as I run the 64bit, it won't work.

Can anyone confirm this behaviour? Or does anyone run 64 bit and have RCON working?

Share this post


Link to post
Share on other sites
Advertisement

you need to specify actual IP of server if your remote connecting with rcon, 127.0.0.1 will only allow localhost connection

 

Share this post


Link to post
Share on other sites
18 minutes ago, tinboye said:

you need to specify actual IP of server if your remote connecting with rcon, 127.0.0.1 will only allow localhost connection

 

Not according to Be RCON documentation. If I define 127.0.0.1 as an IP, I will only be able to connect locally. If I define an external IP, i will only be able to connect from remote. If I don't define one, I will be able to connect from both.

Also, I've tried all 3 options and none works.

Share this post


Link to post
Share on other sites

Problem solved.

Fuck you, Arma developers. Update your ¤#%#¤& documentation!

Because I'm using the 64 bit ARMA server (armaserver_x64.exe), I'm also using 64bit BE dll's. The 64bit BE dll's require the config file to be named "beserver_x64.cfg" instead of the default "beserver.cfg". I simply changed the filename and it worked right off.

Many hours of troubleshooting because Bohemia couldn't be bothered to update their documentation.

Edited by malfunc
1 person likes this

Share this post


Link to post
Share on other sites

yup that would do it too lol

 

any FYI, arma documentation is a wiki, so it allows anyone to update the documentation. So its not maintained by bohemia LOL

 

Edited by tinboye

Share this post


Link to post
Share on other sites
7 minutes ago, tinboye said:

yup that would do it too lol

 

any FYI, arma documentation is a wiki, so it allows anyone to update the documentation. So its not maintained by bohemia LOL

 

Surely there must be some kind of documentation that gets updated by Bohemia on some level. Otherwise server owners would have absolutely zero chance of knowing when they change configuration parameters etc. It wouldn't make sense to have us just guess around.

Share this post


Link to post
Share on other sites

I agree there should be, but If you look at some of the documentation, like for the server.cfg file, its still showing arma2 info, with sone added things for arma3.

its maintained by https://www.mediawiki.org but i do not see any way to contribute, so it must be a private wiki maintained by them. So ya they are just being bohemia lol

 

Edited by tinboye

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.