• 0
StevieP

Floodlights/base laptop issue

Question

Hello,

i have noticed that after a server restart my base laptop no longer works, the open option doesn't work any more. I can fix this by just moving and putting it back down again until next restart then it's broken again, gets kind of annoying. Any simple solution out there for this one? 

Also, similar issue is with the floodlight after a restart, they work perfect until a server restart and then they are kind of dull when you turn the generator on, the light doesn't seem to be emitting in the right direction and the floodlight itself hasn't moved or changed position, this also can be fixed by moving it and putting it back down, then you turn on the gen and hey presto bright light in the correct direction. Any ideas?

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

Hello StevieP,

This is an issue with ARMA 1.68 and Exile.  Search the forums and you will find the 'fix'.  This also occurs with fireplaces, security cameras, and doors too.

:)

 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0
On 4/18/2017 at 2:59 PM, Z80CPU said:

Hello StevieP,

This is an issue with ARMA 1.68 and Exile.  Search the forums and you will find the 'fix'.  This also occurs with fireplaces, security cameras, and doors too.

:)

 

I am having zero luck finding this fix or even a mention about it, there are posts about flood light issues but they were pre patch 1.0.2 so i am stuck and frustrated at the fact i've spent hours searching and googling this issue, surely i am not the only server owner having this issue.. Like you said, it's multiple base building items like laptop, floodlights and campfire that have to be moved and put down again after each restart for them to function again. It's not killing my server in functionality but it's just frustrating me as the admin that i cant fix it.

Any one out there at all have this issue or have solved it and can offer advice?

Share this post


Link to post
Share on other sites
Advertisement
  • 0
55 minutes ago, StevieP said:

I am having zero luck finding this fix or even a mention about it, there are posts about flood light issues but they were pre patch 1.0.2 so i am stuck and frustrated at the fact i've spent hours searching and googling this issue, surely i am not the only server owner having this issue.. Like you said, it's multiple base building items like laptop, floodlights and campfire that have to be moved and put down again after each restart for them to function again. It's not killing my server in functionality but it's just frustrating me as the admin that i cant fix it.

Any one out there at all have this issue or have solved it and can offer advice?

http://www.exilemod.com/topic/21761-168-bugs-megathread-discussion/?page=1

2 people like this

Share this post


Link to post
Share on other sites
  • 0

While @SavageMcTavish has pointed you to the right place to find your answers, that fix and pretty much most of the others I found in the forums do not actually include the items you're trying to fix. So, I have included below, the section of that same fix that I use, which encompasses all the appropriate Exile items as well as all the EBM items. You'll understand where to put it after reading the link that was given above.

Spoiler

// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE
//if (getNumber(configFile >> "CfgVehicles" >> (_data select 1) >> "exileRequiresSimulation") isEqualTo 1) then
//{
//    _constructionObject enableSimulationGlobal true;
//    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
//}
//else 
//{
//    _constructionObject enableSimulationGlobal false;
//};

if (typeOf _constructionObject in [
        //Exile Objects
        "Exile_Construction_ConcreteDoor_Static",
        "Exile_Construction_ConcreteGate_Static",
        "Exile_Construction_WoodGate_Static",
        "Exile_Construction_WoodDoor_Static",
        "Exile_Construction_ConcreteWindowHatch_Static",
        "Exile_Construction_WoodGate_Reinforced_Static",
        "Exile_Construction_WoodDoor_Reinforced_Static",
        "Exile_Construction_ConcreteFloorHatch_Static",
        "Exile_Construction_Laptop_Static",
        "Exile_Construction_CampFire_Static",
        "Exile_Construction_PortableGenerator_Static",
        "Exile_Construction_BaseCamera_Static",
        "Exile_Construction_FloodLight_Static",
        "Exile_ConcreteMixer",
        //EBM Buildings
        "Land_Cargo_Patrol_V2_F",
        "Land_Cargo_Tower_V2_F",
        "Land_Cargo_House_V2_F",
        "Land_i_Garage_V2_F",
        "Land_Dome_Big_F",
        "Land_spp_Tower_F",
        "Land_Airport_Tower_F",
        "Land_i_Barracks_V1_F",
        "Land_TTowerSmall_1_F",
        "Land_i_House_Small_03_V1_F",
        "Land_i_House_Big_01_V2_F",
        "Land_Research_HQ_F",
        "Land_Research_house_V1_F",
        //EBM Gates
        "Land_Stone_Gate_F",
        "Land_City_Gate_F",
        "Land_BarGate_F",
        //EBM Misc
        "Land_FuelStation_Feed_F",
        "Land_ToiletBox_F",
        "Land_PlasticCase_01_medium_F",
        //EBM Lights
        "Land_Camping_Light_F",
        "Land_LampShabby_F",
        "Land_LampStreet_F",
        "Land_PortableLight_double_F",
        "Land_LampAirport_F",
        "Land_LampHalogen_F"
]) then
{
    _constructionObject enableSimulationGlobal true;
    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
}
else 
{
    _constructionObject enableSimulationGlobal false;
};
// 2017-03-16 - TEMPORARY WORKAROUND UNTIL EXILE UPDATE

 

3 people like this

Share this post


Link to post
Share on other sites
  • 0
29 minutes ago, Kurewe said:

While @SavageMcTavish has pointed you to the right place to find your answers, that fix and pretty much most of the others I found in the forums do not actually include the items you're trying to fix. So, I have included below, the section of that same fix that I use, which encompasses all the appropriate Exile items as well as all the EBM items. You'll understand where to put it after reading the link that was given above.

  Hide contents

// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE
//if (getNumber(configFile >> "CfgVehicles" >> (_data select 1) >> "exileRequiresSimulation") isEqualTo 1) then
//{
//    _constructionObject enableSimulationGlobal true;
//    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
//}
//else 
//{
//    _constructionObject enableSimulationGlobal false;
//};

if (typeOf _constructionObject in [
        //Exile Objects
        "Exile_Construction_ConcreteDoor_Static",
        "Exile_Construction_ConcreteGate_Static",
        "Exile_Construction_WoodGate_Static",
        "Exile_Construction_WoodDoor_Static",
        "Exile_Construction_ConcreteWindowHatch_Static",
        "Exile_Construction_WoodGate_Reinforced_Static",
        "Exile_Construction_WoodDoor_Reinforced_Static",
        "Exile_Construction_ConcreteFloorHatch_Static",
        "Exile_Construction_Laptop_Static",
        "Exile_Construction_CampFire_Static",
        "Exile_Construction_PortableGenerator_Static",
        "Exile_Construction_BaseCamera_Static",
        "Exile_Construction_FloodLight_Static",
        "Exile_ConcreteMixer",
        //EBM Buildings
        "Land_Cargo_Patrol_V2_F",
        "Land_Cargo_Tower_V2_F",
        "Land_Cargo_House_V2_F",
        "Land_i_Garage_V2_F",
        "Land_Dome_Big_F",
        "Land_spp_Tower_F",
        "Land_Airport_Tower_F",
        "Land_i_Barracks_V1_F",
        "Land_TTowerSmall_1_F",
        "Land_i_House_Small_03_V1_F",
        "Land_i_House_Big_01_V2_F",
        "Land_Research_HQ_F",
        "Land_Research_house_V1_F",
        //EBM Gates
        "Land_Stone_Gate_F",
        "Land_City_Gate_F",
        "Land_BarGate_F",
        //EBM Misc
        "Land_FuelStation_Feed_F",
        "Land_ToiletBox_F",
        "Land_PlasticCase_01_medium_F",
        //EBM Lights
        "Land_Camping_Light_F",
        "Land_LampShabby_F",
        "Land_LampStreet_F",
        "Land_PortableLight_double_F",
        "Land_LampAirport_F",
        "Land_LampHalogen_F"
]) then
{
    _constructionObject enableSimulationGlobal true;
    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
}
else 
{
    _constructionObject enableSimulationGlobal false;
};
// 2017-03-16 - TEMPORARY WORKAROUND UNTIL EXILE UPDATE

 

Thank you. I shall add this to my ever increasing Exile notes ☺️

2 people like this

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, SavageMcTavish said:

Thank you. I shall add this to my ever increasing Exile notes ☺️

Not a problem. 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Kurewe said:

While @SavageMcTavish has pointed you to the right place to find your answers, that fix and pretty much most of the others I found in the forums do not actually include the items you're trying to fix. So, I have included below, the section of that same fix that I use, which encompasses all the appropriate Exile items as well as all the EBM items. You'll understand where to put it after reading the link that was given above.

  Reveal hidden contents

// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE
//if (getNumber(configFile >> "CfgVehicles" >> (_data select 1) >> "exileRequiresSimulation") isEqualTo 1) then
//{
//    _constructionObject enableSimulationGlobal true;
//    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
//}
//else 
//{
//    _constructionObject enableSimulationGlobal false;
//};

if (typeOf _constructionObject in [
        //Exile Objects
        "Exile_Construction_ConcreteDoor_Static",
        "Exile_Construction_ConcreteGate_Static",
        "Exile_Construction_WoodGate_Static",
        "Exile_Construction_WoodDoor_Static",
        "Exile_Construction_ConcreteWindowHatch_Static",
        "Exile_Construction_WoodGate_Reinforced_Static",
        "Exile_Construction_WoodDoor_Reinforced_Static",
        "Exile_Construction_ConcreteFloorHatch_Static",
        "Exile_Construction_Laptop_Static",
        "Exile_Construction_CampFire_Static",
        "Exile_Construction_PortableGenerator_Static",
        "Exile_Construction_BaseCamera_Static",
        "Exile_Construction_FloodLight_Static",
        "Exile_ConcreteMixer",
        //EBM Buildings
        "Land_Cargo_Patrol_V2_F",
        "Land_Cargo_Tower_V2_F",
        "Land_Cargo_House_V2_F",
        "Land_i_Garage_V2_F",
        "Land_Dome_Big_F",
        "Land_spp_Tower_F",
        "Land_Airport_Tower_F",
        "Land_i_Barracks_V1_F",
        "Land_TTowerSmall_1_F",
        "Land_i_House_Small_03_V1_F",
        "Land_i_House_Big_01_V2_F",
        "Land_Research_HQ_F",
        "Land_Research_house_V1_F",
        //EBM Gates
        "Land_Stone_Gate_F",
        "Land_City_Gate_F",
        "Land_BarGate_F",
        //EBM Misc
        "Land_FuelStation_Feed_F",
        "Land_ToiletBox_F",
        "Land_PlasticCase_01_medium_F",
        //EBM Lights
        "Land_Camping_Light_F",
        "Land_LampShabby_F",
        "Land_LampStreet_F",
        "Land_PortableLight_double_F",
        "Land_LampAirport_F",
        "Land_LampHalogen_F"
]) then
{
    _constructionObject enableSimulationGlobal true;
    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
}
else 
{
    _constructionObject enableSimulationGlobal false;
};
// 2017-03-16 - TEMPORARY WORKAROUND UNTIL EXILE UPDATE

 

ah ok, thanks for the response man, i appreciate it. Is that the same code/fix that sorted out the territory base doors not opening after a restart because that code looks familiar as i had to implement that to my server to resolve the door issue. Should be quite easy for me to locate that and add to it. sweet.

Share this post


Link to post
Share on other sites
  • 0
28 minutes ago, StevieP said:

ah ok, thanks for the response man, i appreciate it. Is that the same code/fix that sorted out the territory base doors not opening after a restart because that code looks familiar as i had to implement that to my server to resolve the door issue. Should be quite easy for me to locate that and add to it. sweet.

Yes, exactly the same fix, but with the added extras. You should be able to copy that whole section I provided and paste it over the corresponding section in your file.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.